Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
CrazyLittle
Sep 11, 2001





Clapping Larry

jwh posted:

I'm prepared to offer you all of my returnable beer bottles, shipped at your expense, plus a cat. You can choose a grey cat, or an orange one. That is my final offer.

I'm a sucker for grey cats. Can you ship it parcel post? *edit* Wait nevermind I just saw a picture of the orange one... GIMMIE

OER, as it pertained to the connections I'm using.

This setup has a single computer behind a:
  • Cisco 3640 router, (card1) NM-2fe2w, (wic1/0) wic-1ADSL, (wic1/1) wic-1dsu-t1.
  • wic-1ADSL is an ADSL connection that my company sells.
  • wic-1dsu-t1 is connected to a 1720 wic-1dsu, which is just acting as a T1 endpoint.

Supplemental links: 1) OER in a single-router setup
2) Cisco IOS 12.3T OER reference (lots of good hints)

code:
!Cisco IOS Software, 3600 Software (C3640-IK9O3S-M), Version 12.4(16), RELEASE SOFTWARE (fc1)
!c3640-ik9o3s-mz.124-16.bin
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxxxxxx
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxx
!
no aaa new-model
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.100.1.1 10.100.1.50
!
ip dhcp pool localLAN
   network 10.100.1.0 255.255.255.0
   dns-server yyy.yyy.yyy.yyy zzz.zzz.zzz.zzz
   default-router 10.100.1.1
!
!
!
!
!
key chain OERKEYCHAIN
 key 1
   key-string xxxxxxxx
!
!
oer master
 max-range-utilization percent 10
 keepalive 1
 logging
 !
 border 10.100.1.1 key-chain OERKEYCHAIN
  interface FastEthernet1/0 internal
  interface Serial1/1 external
  interface ATM1/0.1 external
 !
 learn
  throughput
  periodic-interval 1
  monitor-period 2
  prefixes 200
  expire after time 300
  aggregation-type prefix-length 32
!
oer border
 local FastEthernet1/0
 master 10.100.1.1 key-chain OERKEYCHAIN
!
!
!
!
!
!
!
!
!
!
!
username xxxxxxxx password 0 xxxxxxxx
!
!
!
!
!
!
!
interface ATM1/0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM1/0.1 point-to-point
 description lovely DSL connection to internet
 ip address 192.168.0.2 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 no snmp trap link-status
 atm route-bridged ip
 pvc 0/35
 !
!
interface FastEthernet1/0
 description local LAN
 ip address 10.100.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address dhcp
 duplex auto
 speed auto
!
interface Serial1/1
 description fake internet t1 to lab
 ip address 172.16.0.2 255.255.255.252
 ip nat outside
 ip virtual-reassembly
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1 name DSLgateway
ip route 0.0.0.0 0.0.0.0 172.16.0.1 name T1gateway
!
ip nat inside source route-map oerfailover interface Serial1/1 overload oer
!
access-list 1 permit 10.100.1.0 0.0.0.255
access-list 2 permit any
!
route-map oerfailover permit 10
 match ip address 1
 set ip next-hop 172.16.0.1 192.168.0.1
!
!
!
control-plane
!
!
!
line con 0
 login local
line aux 0
 modem InOut
 transport input all
line vty 0 4
 login local
 transport input telnet
!
!
end
So here's the thing that gets me. When watching the console logging, I can see the OER master watching, picking, choosing and rerouting the traffic... but I can't get it to route to BOTH interface at the same time. It seems to be switching over everything completely. Any thoughts on that, or should I file a new ticket with Cisco TAC and wait another 6 months to be ignored... only to figure it out by myself?

Yeah, I'm kinda bitter at TAC right now.

CrazyLittle fucked around with this message at 05:36 on Sep 13, 2007

Adbot
ADBOT LOVES YOU

R1CH
Apr 7, 2002

The Ron Jeremy of the coding world

jwh posted:

Can you hard code the ID? I think there's an option for that. There's an option for hard-coding some client identifier, although it might not be the one you need.

I haven't seen any options to tune the dhcp client, sadly.

For that matter, why is your ISP so slow to reply to your request? Fifteen seconds is a long time.
Yeah the only things that can be hard coded are hostname and client identifier, not the DHCP transaction ID. It increments by one each time. I have no idea why my ISP does this, it seems to prevent Vonage / some routers / etc from working which may be something they consider "good". Either that or they have one DHCP server for the whole country and it's overloaded to all hell.

XakEp
Dec 20, 2002
Amor est vitae essentia

CrazyLittle posted:

So here's the thing that gets me. When watching the console logging, I can see the OER master watching, picking, choosing and rerouting the traffic... but I can't get it to route to BOTH interface at the same time. It seems to be switching over everything completely. Any thoughts on that, or should I file a new ticket with Cisco TAC and wait another 6 months to be ignored... only to figure it out by myself?

Yeah, I'm kinda bitter at TAC right now.

As I understand it, thats what its supposed to do. Pick best path routing and route the traffic over the links that'll get the data there faster. As one route gets congested, it switches over.

http://www.cisco.com/en/US/products/ps6628/products_ios_protocol_option_home.html

CrazyLittle
Sep 11, 2001





Clapping Larry

XakEp posted:

As I understand it, thats what its supposed to do. Pick best path routing and route the traffic over the links that'll get the data there faster. As one route gets congested, it switches over.

http://www.cisco.com/en/US/products/ps6628/products_ios_protocol_option_home.html

Yeah but shouldn't it be a soft cutover, where current traffic on that line keeps flowing? I'm getting the impression that it's just doing a hopping dance between the two lines, completely moving everything over at the slightest hint of congestion, instead of balancing load across both links simultaneously.

XakEp
Dec 20, 2002
Amor est vitae essentia

CrazyLittle posted:

Yeah but shouldn't it be a soft cutover, where current traffic on that line keeps flowing? I'm getting the impression that it's just doing a hopping dance between the two lines, completely moving everything over at the slightest hint of congestion, instead of balancing load across both links simultaneously.

If a TCP connection has been established, it cant just cut over to a new IP address and route mid stream. Especially if there's encryption involved - it cant be easily reassembled.

nex
Jul 23, 2001

øæå¨æøåø
Grimey Drawer
Thanks for this thread, it contains a lot of really good information and was a great read.

Just so this bump isnt worthless, here is a fluff piece Cisco wrote about the company I work for: http://www.cisco.com/en/US/netsol/ns577/networking_solutions_customer_profile0900aecd806a1efe.html :c00lbert:

brent78
Jun 23, 2004

I killed your cat, you druggie bitch.
I setup a VPN on a PIX 515e and connect with the Cisco VPN client software. It works great, however I'm no longer able to route to the Internet, just the private internal network. Is there a way to have it route ALL my traffic through the PIX. I know a split tunnel is possible, but I don't want to do that. I heard somewhere that a PIX can't route traffic out the same interface it comes in on, so what I'm asking may not be possible without a VPN concentrator or whatnot.

XakEp
Dec 20, 2002
Amor est vitae essentia

brent78 posted:

I setup a VPN on a PIX 515e and connect with the Cisco VPN client software. It works great, however I'm no longer able to route to the Internet, just the private internal network. Is there a way to have it route ALL my traffic through the PIX. I know a split tunnel is possible, but I don't want to do that. I heard somewhere that a PIX can't route traffic out the same interface it comes in on, so what I'm asking may not be possible without a VPN concentrator or whatnot.

Out of curiosity, why dont you want to do a split tunnel?

brent78
Jun 23, 2004

I killed your cat, you druggie bitch.

XakEp posted:

Out of curiosity, why dont you want to do a split tunnel?
So I don't have to deal with Time Warner packet shaping my cable connection.

Tremblay
Oct 8, 2002
More dog whistles than a Petco

brent78 posted:

I setup a VPN on a PIX 515e and connect with the Cisco VPN client software. It works great, however I'm no longer able to route to the Internet, just the private internal network. Is there a way to have it route ALL my traffic through the PIX. I know a split tunnel is possible, but I don't want to do that. I heard somewhere that a PIX can't route traffic out the same interface it comes in on, so what I'm asking may not be possible without a VPN concentrator or whatnot.

Is the PIX running 6, 7, or 8?

This is applicable to 7 and 8. If your are running 6 let me know and I can dig up that too.

http://cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00805734ae.shtml

brent78
Jun 23, 2004

I killed your cat, you druggie bitch.

Tremblay posted:

This is applicable to 7 and 8. If your are running 6 let me know and I can dig up that too.
Perfect, that's exactly what I was looking for. I'm running 7.x, so I should be good to go.

jwh
Jun 12, 2002

I feel like I'm beating a dead horse here, but Cisco came back to me finally and told me that, more or less, "IPSec client VPN termination against IOS is an afterthought," and that the recommended platform for client VPN termination is an ASA.

Well, no kidding, I'd love to use my two ASA5540's, since I already paid for them. Problem is, they have no VRF capabilities, and that's what I need.

So as near as I can tell, Cisco's remote access VPN offering can be described as follows:

PIX/ASA: Platform of choice, provided you don't need VRF termination
IOS: Sort of an afterthought; you get VRF termination, but lose most other features.

AT&T does large-scale virtualized VPN termination; what the hell are they using?

ashgromnies
Jun 19, 2004
I don't know poo poo about networking and reading through this thread and all its acronyms is confusing me quite a bit. IPSec? IOS? ASA?

Anyways, I need to set up a network that would support about 30 people via wireless or hard-wired connections with drops in different rooms. The internet connection is supplied via Comcast cable internet. Right now there is a lovely Linksys wireless router hooked into a Cisco switch and it's a piece of garbage and we are plagued by terrible network speeds and reliability.

Where can I learn this stuff/suggestions?

jwh
Jun 12, 2002

ashgromnies posted:

Where can I learn this stuff/suggestions?

IPSec is the collection of protocols commonly brought to use as 'VPN'.

IOS is the operating system of Cisco routers and switches.

ASA is Cisco's 'Adaptive Security Appliance', which is more or less the successor to the PIX, which had been Cisco's security product.

The best way to learn is probably to read, ask questions, and then read some more.

Tremblay
Oct 8, 2002
More dog whistles than a Petco

jwh posted:

I feel like I'm beating a dead horse here, but Cisco came back to me finally and told me that, more or less, "IPSec client VPN termination against IOS is an afterthought," and that the recommended platform for client VPN termination is an ASA.

Well, no kidding, I'd love to use my two ASA5540's, since I already paid for them. Problem is, they have no VRF capabilities, and that's what I need.

So as near as I can tell, Cisco's remote access VPN offering can be described as follows:

PIX/ASA: Platform of choice, provided you don't need VRF termination
IOS: Sort of an afterthought; you get VRF termination, but lose most other features.

AT&T does large-scale virtualized VPN termination; what the hell are they using?

6k/7ks with VPN-SPAs I think. I understand you need VRF support but what other features are you looking to implement that IOS doesn't provide for RA?

EDIT: I'm not a VPN eng but I'll do what I can to help.

jwh
Jun 12, 2002

Tremblay posted:

6k/7ks with VPN-SPAs I think. I understand you need VRF support but what other features are you looking to implement that IOS doesn't provide for RA?

EDIT: I'm not a VPN eng but I'll do what I can to help.

I appreciate it; I'm finding remote access VPN on IOS (ie., Easy VPN with Dynamic Virtual Tunnel Interfaces: http://www.cisco.com/en/US/products/ps6635/products_white_paper0900aecd803645b5.shtml ), to work great, except with respect to control and administration.

This makes sense, like I mention, because IOS is focused on site-to-site VPN configurations, and user VPN termination isn't as feature-rich as it is on the PIX/ASA.

Some of the issues I've run into include not having any correlation between cloned virtual-access interfaces and the user that it's been cloned for, and a general clumsiness with administration- for instance, if I don't know who's on what interface, it's difficult to troubleshoot remote access problems. Things like 'show crypto session' don't produce any information about which user is occupying which crypto socket, either.

Don't get me wrong, I can understand why the limitations are there, and I'm well aware that I'm operating outside the norm on this one. I guess my dream, would be for the ASA to receive full VRF support, with it's full range of VPN features intact, or for IOS to receive remote access VPN administration improvements.

edit: By clumsiness, I mean things like not sending the virtual-access information as part of radius data, as either Cisco VSA or NAS-Port.

jwh fucked around with this message at 21:05 on Sep 24, 2007

jwh
Jun 12, 2002

Going through the 12.4(15)T release notes pdf, and there's some neat stuff worth mentioning:

Beginning in 12.4(11)T, apparently the ISR IP Base line gets BGP, and BGP support in Advanced Security as well. Wish that had happened last year, since we bought about 90 IOS upgrade licenses from Advanced Security to Advanced IP Services.

ISR's get BFD

SSL VPN VRF integration (which sounds good).

Rommon booting from usbflash.

Bunch of AToM junk

I only have two routers running 12.4(15)T, because they need to do Active Directory password changes via RADIUS, which is also a new feature, but so far it's been pretty swell.

PDF is here: http://cisco.com/application/pdf/en/us/guest/products/ps8258/c1161/cdccont_0900aecd80679ce3.pdf

Boner Buffet
Feb 16, 2006
What is the general opinion on refurbed cisco gear? Seeing as I work for a not for profit shop, is refurbished equipment, specifically a 45xx series core switch, a bad idea?

ChimpyMonkey
Sep 11, 2001

Well, of course we're going to throw poo at him!
Anyone here running 12.2(33)SXH on a Sup32? We were previously running SXF on the same box, upgraded to SXH a couple of days ago. Now we have no rate-limit or traffic-shape available to us.

Our SE seems to think that these features were not functioning under SXF at all either, but that they were cosmetically available.

Anyone have a 6500 running SXF and either of these able to confirm for me? We never really tested the rate-limiting or traff-shaping we had applied to customers (1000s of km away). I'm curious as to if it wasn't working under SXF at all, or our SE is pulling our leg.

jwh
Jun 12, 2002

InferiorWang posted:

What is the general opinion on refurbed cisco gear? Seeing as I work for a not for profit shop, is refurbished equipment, specifically a 45xx series core switch, a bad idea?

Can you put the refurbished switch under smartnet? If so, it sounds like it would be fine.

Boner Buffet
Feb 16, 2006
http://www.cisco.com/web/ordering/ciscocapital/refurbished/

According to that page, the warranty and service options are the same as new equipment.

dwarftosser
Sep 3, 2002

PLEASE LET ME SUCK YOUR COCK, BRETT!

jwh posted:

Can you put the refurbished switch under smartnet? If so, it sounds like it would be fine.

You can for now, which makes it a great option. However I hear Cisco is going to limit what products you can and cannot get a smartnet on sometime in the near future to try to curb the massive explosion of Used / Refurbed dealers that seem to be around now.

Tremblay
Oct 8, 2002
More dog whistles than a Petco

dwarftosser posted:

You can for now, which makes it a great option. However I hear Cisco is going to limit what products you can and cannot get a smartnet on sometime in the near future to try to curb the massive explosion of Used / Refurbed dealers that seem to be around now.

For what its worth I've heard no talk of this.

Tremblay
Oct 8, 2002
More dog whistles than a Petco

ChimpyMonkey posted:

Anyone here running 12.2(33)SXH on a Sup32? We were previously running SXF on the same box, upgraded to SXH a couple of days ago. Now we have no rate-limit or traffic-shape available to us.

Our SE seems to think that these features were not functioning under SXF at all either, but that they were cosmetically available.

Anyone have a 6500 running SXF and either of these able to confirm for me? We never really tested the rate-limiting or traff-shaping we had applied to customers (1000s of km away). I'm curious as to if it wasn't working under SXF at all, or our SE is pulling our leg.

Possibly. I'll try to check this out today.

dwarftosser
Sep 3, 2002

PLEASE LET ME SUCK YOUR COCK, BRETT!

Tremblay posted:

For what its worth I've heard no talk of this.

Hopefully it's just speculation then, because I like buying used. :) I heard it from a friend I used to work with who is an SE3 in in Cisco's DoD division while we were golfing a few weeks ago.

M@
Jul 10, 2004

dwarftosser posted:

Hopefully it's just speculation then, because I like buying used. :) I heard it from a friend I used to work with who is an SE3 in in Cisco's DoD division while we were golfing a few weeks ago.

They're certainly trying like hell to stomp out the used market. They like painting the "grey" market as stolen/counterfeit gear and don't have any problem telling customers that. I've had them tell a customer of mine (I sell used equipment) that everything I was selling them was either fake, or stolen off the back of a truck, which is extremely false. Luckily my customer laughed it off and forwarded me the email.

As of now, yes, you can put used switches (used Cisco anything, for that matter) under smartnet, as long as they've never been covered under smartnet previously. Actually, that's not 100% true, you can softline used gear that's already been covered but it's a major pain in the rear end so I don't ever even bring it up.

Let's just hope Cisco keeps allowing smartnet on used equipment :)

CrazyLittle
Sep 11, 2001





Clapping Larry

M@ posted:

They're certainly trying like hell to stomp out the used market. They like painting the "grey" market as stolen/counterfeit gear and don't have any problem telling customers that.

Part of that reasoning is that they can't have any real knowledge of the chain of ownership on any given part, and stuff like T1 WIC cards are easily counterfeited. I've had at least 3 couterfeit WICs pass my desk in the past 3 months, and two of them went bad within 30 days. If Cisco had to support that, it would be a monetary black hole.

M@
Jul 10, 2004

CrazyLittle posted:

Part of that reasoning is that they can't have any real knowledge of the chain of ownership on any given part, and stuff like T1 WIC cards are easily counterfeited. I've had at least 3 couterfeit WICs pass my desk in the past 3 months, and two of them went bad within 30 days. If Cisco had to support that, it would be a monetary black hole.

Certainly. I don't, however, think it's fair to lump legitimate dealers, who test their equipment and know to spot fakes, with the dudes on eBay selling Chisco WICs for $2/ea.

Since I know a lot of you guys buy used Cisco, I'll plug an organization I'm part of. Try to buy your used gear from someone who is part of:

quote:

UNEDA is an alliance of more than 300 of the top used network equipment dealers worldwide. These secondary market suppliers work together to promote industry best practices, ensure the highest standards of product quality, and eradicate counterfeit and fraud in the secondary market.

That's what we're doing to fight Cisco's witch hunt. Who knows if it'll work.

ate shit on live tv
Feb 15, 2004

by Azathoth

M@ posted:

That's what we're doing to fight Cisco's witch hunt. Who knows if it'll work.

You really can't blame Cisco for that though. The margin that Cisco runs is so high that its actually more cost effective to give away used gear then to sell and support it.

Internally Cisco has a list called Reverse Logistics that is a bunch of returned Cisco Gear from customers, oversells etc. They just pass the list around to various organizations inside of Cisco (like the lab I work with), and we pick whatever we want off of the list. This actually saves Cisco more money then if they tried to sell that same equipment as used themselves.

Visual GNUdio
Aug 27, 2003


When I have a server that has multiple NICs tied into one switch I can bond those NICs and configure them to create one channel for both transmit and receive load balancing via LACP/802.3ad, effectively doubling my throughput in either direction. The requirement is that the NICs are all talking to one switch, or in the Cisco world, talking to multiple switches that are configured as a cluster. Here then is the question: If I have a single server with 2 NICs which are connected to 2 switches (in this case, bladed Catalyst 3020s), and these switches cannot be clustered, if these two switches are themselves connected to a single core switch (say a Cat 6000 series) might I still be able to enable link aggregation for both transmit and receive?

Here’s a recap in half-assed crappy drawings:

This I know works, both for transmit and recieve:



This I’m pretty certain doesn’t work (transmit balancing will work, but not receive):



So the question is this – would something like the following work to load balance traffic both in and out from the core?

ate shit on live tv
Feb 15, 2004

by Azathoth

luma posted:

When I have a server that has multiple NICs tied into one switch I can bond those NICs and configure them to create one channel for both transmit and receive load balancing via LACP/802.3ad, effectively doubling my throughput in either direction. The requirement is that the NICs are all talking to one switch, or in the Cisco world, talking to multiple switches that are configured as a cluster. Here then is the question: If I have a single server with 2 NICs which are connected to 2 switches (in this case, bladed Catalyst 3020s), and these switches cannot be clustered, if these two switches are themselves connected to a single core switch (say a Cat 6000 series) might I still be able to enable link aggregation for both transmit and receive?

Here’s a recap in half-assed crappy drawings:

This I know works, both for transmit and recieve:


This I’m pretty certain doesn’t work (transmit balancing will work, but not receive):



So the question is this – would something like the following work to load balance traffic both in and out from the core?


I'd question why you were doing that (why pass through those switches at all.)

But otherwise if you did some kind of transparent pass-through of those switches and went directly to the Core switch you could get link-aggregation. Of course the disadvantage is that you can't directly talk to any of the devices connected to either of those pass-through switches. It would require you to configure the ports you were connected to on the switches into a transparent link. I'm not sure of the actual term.

Visual GNUdio
Aug 27, 2003


Powercrazy posted:

I'd question why you were doing that (why pass through those switches at all.)

But otherwise if you did some kind of transparent pass-through of those switches and went directly to the Core switch you could get link-aggregation. Of course the disadvantage is that you can't directly talk to any of the devices connected to either of those pass-through switches. It would require you to configure the ports you were connected to on the switches into a transparent link. I'm not sure of the actual term.
It's a reasonable question - the answer is that the servers in question are HP blade servers in a C-Class enclosure. The intermediary switches are blade-ified Cisco Cat 3020s. The signal routing cannot be modified as it's hardwired within the enclosure. Losing the ability to communicate to other attached nodes in the switch is problematic, as in many applications there is a lot of inter-blade traffic.

inignot
Sep 1, 2003

WWBCD?

luma posted:

When I have a server that has multiple NICs tied into one switch I can bond those NICs and configure them to create one channel for both transmit and receive load balancing via LACP/802.3ad...blah blah blah

Read this.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml

Visual GNUdio
Aug 27, 2003


That unfortunately will not apply, as near as I can gather (I could be completely wrong). The configuration they outline is the same as in my first diagram, which I've done a number of times before with great success. My issue is that my configuration is hard-wired in a manner outlined in my second diagram, and the two switches themselves do not support clustering, which I'm told is a requirement. So the question standing is whether my third diagram could work.

inignot
Sep 1, 2003

WWBCD?

luma posted:

My issue is that my configuration is hard-wired in a manner outlined in my second diagram, and the two switches themselves do not support clustering, which I'm told is a requirement. So the question standing is whether my third diagram could work.

I don't think LACP is going to work in scenario 2 or 3. Active/Active load balanced connections need to terminate to the same switch (or switch stack). See if your nics or os support some kind of active/standby failover option based on link status or ping polling.

multiprotocol
Sep 16, 2004
label switching is fun. i can relate to that.
The 3020s do support trunking/port-channeling between each other (see 'media-type internal'; you lose one or more of the 'external' ports, numbered 17-24 on each switch), but you can't do what Nortel refers to as 'split-MLT'. Unfortunately, you're going to be doing active/passive if you want to diversify your connectivity.

We have the exact same setup in our environment (HP C-class, Cisco 3020s uplinked to a pair of 4948s, uplinked to a pair of 6509s) and I don't believe that you'll be able to do actual load-balancing on the switches, like you have described.

ragzilla
Sep 9, 2005
don't ask me, i only work here


inignot posted:

I don't think LACP is going to work in scenario 2 or 3. Active/Active load balanced connections need to terminate to the same switch (or switch stack). See if your nics or os support some kind of active/standby failover option based on link status or ping polling.

Alternately you could run your Active/Active at layer 3 instead of layer 2, by running a routing protocol on the server (like ospf using quagga), and let CEF/OSPF ECMP do your load balancing at layer 3.

ChimpyMonkey
Sep 11, 2001

Well, of course we're going to throw poo at him!
Dear Cisco,

Please make a working bug toolkit, with accurate data for current IOS releases.

Thank you,
The Internet

Anyone actually seen the "new" bug toolkit work? I keep trying but all I ever get is this error: "Error occurred while fetching bug summary from database. Please try later."

Visual GNUdio
Aug 27, 2003


multiprotocol posted:

The 3020s do support trunking/port-channeling between each other (see 'media-type internal'; you lose one or more of the 'external' ports, numbered 17-24 on each switch), but you can't do what Nortel refers to as 'split-MLT'. Unfortunately, you're going to be doing active/passive if you want to diversify your connectivity.

We have the exact same setup in our environment (HP C-class, Cisco 3020s uplinked to a pair of 4948s, uplinked to a pair of 6509s) and I don't believe that you'll be able to do actual load-balancing on the switches, like you have described.

This is pretty much as I expected. Now I just have to break it to my customers that the NICs I've been selling them aren't going to help. At all.

Also, the ports that cross connect on the C-Class are 23-24 (for the "media-type internal" thing). 17-22 are purely external.

Adbot
ADBOT LOVES YOU

inignot
Sep 1, 2003

WWBCD?
You could try this:

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/l2pt.html#wp999408

I have no idea if this will tunnel LACP. I've only ever used it once, and that was to tunnel CDP for ODR updates between two routers connected to a switch not running ODR, but only for an obtuse CCIE study scenario.

I think the design concept is just screwed.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply