Search Amazon.com:
Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«91 »
  • Post
  • Reply
biznatchio
Mar 31, 2001

I stole a pie from Estelle Getty.


||||||| posted:

Begin FAQ

NO.

I went ahead and edited that into my post #3 up there. Let's see if that helps the question from coming up three times per page.

Adbot
ADBOT LOVES YOU

MyDogIsBeano
Jun 21, 2005

by Lowtax


biznatchio posted:

I went ahead and edited that into my post #3 up there. Let's see if that helps the question from coming up three times per page.

Is there a FAQ available?

|||||||
Aug 19, 2004

I'm not Chemmy

MyDogIsBeano posted:

Is there a FAQ available?

There is now.

madlobster
Aug 12, 2003


Is it a known issue that when "Highlight threads I've seen in a different color" in the User Control Panel is on, all viewed threads are highlighted blue, instead of the SALR colors?

metachronos
Sep 11, 2001

When I roll, baby I roll DEEP

madlobster posted:

Is it a known issue that when "Highlight threads I've seen in a different color" in the User Control Panel is on, all viewed threads are highlighted blue, instead of the SALR colors?

Yeah, just turn off that option.

d[-.-]b
Aug 1, 2004

my fav champ that hero who cats a spell that make all bad guy fall down and say my dick BIG


Hardcore Sax posted:

Any chance of adding an image transloader into the waffleimages buttons? That would make it infinitely more useful for me.

Also, spoiler tags in the vbcode.

Double requesting this.

Demented Footstool
Jan 3, 2007

Do Not Summon The Fire

d[-.-]b posted:

Hardcore Sax posted:

Any chance of adding an image transloader into the waffleimages buttons? That would make it infinitely more useful for me.

Also, spoiler tags in the vbcode.
Double requesting this.

Both features have been coded / added and should be in the next nightly.

Edit:

duz posted:

Only if you don't know magic.
Some magic that was.

Demented Footstool fucked around with this message at Jul 27, 2007 around 05:55

duz
Jul 11, 2005

Excellent. The Arkham Asylum
shower cam is operational.

Demented Footstool posted:

d[-.-]b - It seems your username breaks the forum's quoting code.

Only if you don't know magic.

d[-.-]b posted:

ɔıƃɐW

Effingham
Aug 1, 2006

The bells of the Gion Temple echo the impermanence of all things...


Dammit.

When I opened Firefox this morning, it asked if I wanted to update SALR. Like an idiot, I said "yes." Now it's not working again.

The quoted images aren't showing (again) and no combination of buttons in SALR seems to fix this. what got *un*fixed in the new release?

duz
Jul 11, 2005

Excellent. The Arkham Asylum
shower cam is operational.

Effingham posted:

Dammit.

When I opened Firefox this morning, it asked if I wanted to update SALR. Like an idiot, I said "yes." Now it's not working again.

The quoted images aren't showing (again) and no combination of buttons in SALR seems to fix this. what got *un*fixed in the new release?

The only thing I touched was the code that inserted the new rate thread icons. If you're still having problems, uninstall and reinstall the extension.

chizad
Jul 9, 2001

'Cus we find ourselves in the same old mess
Singin' drunken lullabies

I don't recall seeing this question being asked before, but if it has feel free to call me an idiot. I've got a thread that shows me as being the thread poster, even though I'm not. What would be the best way of resetting things so SALR shows the correct person as the thread poster again? It's not a big deal, just more of an annoyance.

I've had this problem with both 070713 and 070725.

poopiehead
Oct 6, 2004



which thread is doing that? (or are those two numbers thread ID's that must be in archives?)

poopiehead fucked around with this message at Jul 27, 2007 around 16:36

chizad
Jul 9, 2001

'Cus we find ourselves in the same old mess
Singin' drunken lullabies

poopiehead posted:

which thread is doing that? (or are those two numbers thread ID's that must be in archives?)

The two numbers are version numbers, I just left off the 1.99. at the beginning.

The thread is "Harry Potter and the Deathly Hallows release thread" in The Book Barn, thread ID is 2565670. The strange thing is it just started doing it the other day. For the longest time it showed the correct person as the thread poster, then a day or two ago after I posted a quick reply it started showing me as thread poster.

poopiehead
Oct 6, 2004



Can't tell you how it happened but the poster id is stored in the sqllite file. So either digging in and deleting the row(with something like this or deleting the whole file will probably fix it. If you delete the file you will lose any info SALR has stored about threads. Thread highlighting shouldn't really be affected though.

GI Joe Dirtbag
May 2, 2004

by Fragmaster


Still kickin' rear end. Thanks a lot for all of your hard work in making browsing the forums easy work.

duz
Jul 11, 2005

Excellent. The Arkham Asylum
shower cam is operational.

poopiehead posted:

Can't tell you how it happened but the poster id is stored in the sqllite file. So either digging in and deleting the row(with something like this or deleting the whole file will probably fix it. If you delete the file you will lose any info SALR has stored about threads. Thread highlighting shouldn't really be affected though.

Since the forums now track the OP, I need to update that code to remove it from the database.

poopiehead
Oct 6, 2004



duz posted:

Since the forums now track the OP, I need to update that code to remove it from the database.

oops. I didn't mean to say I didn't get why you put it there. I meant I didn't know what caused chizad's problem.

ManicJason
Oct 27, 2003

He doesn't really stop the puck, but he scares the hell out of the other team.

Small, retarded issue: If you view one person's posts in a thread via the ? link, mouse gestures for forward/back don't work correctly, though the page navigator buttons work right. (example page)

1.99.070725

duz
Jul 11, 2005

Excellent. The Arkham Asylum
shower cam is operational.

New Nightly out.
Post any issues you have here, after making sure you're using the latest version.

Known Issues
See the second post

Changelog
Custom user notes shouldn't overwrite the magic three (OP, Admin, Mod)
OP detection is now forum based and doesn't use the DB
Spoiler tags added to the VB Code Button
Waffle Images button should support URL transloading

Bug Fixes
Custom user notes shouldn't overwrite the magic three (OP, Admin, Mod)

wormil
Sep 12, 2002

Hulk will smoke you!

duz posted:

Spoiler tags added to the VB Code Button

You are the bomb!

Gewgle
Mar 30, 2005
Sometimes I like to ride my bicycle

THe OPs name doesn't become custom colored (so far in ask/tell and GBS)

MrMoo
Sep 14, 2000


Probably just me but on Ubuntu update 1.99.070729 is really slow, I thought it might be NFS home but changing the salsa files to point to /var/tmp still crawled after loading a new page, the previous series was fine, a fruity sqlite?

Xenomorph
Jun 13, 2001


CygnusTM posted:

I found the difference. If you open the options windows via the Add-ons panel, it's static. If you open it via the SA menu, it's resizeable.

is this some weird Firefox limitation?

IcePotato
Dec 29, 2003

There was nothing to fear
Nothing to fear


Does anyone have a problem with firefox crashing when loading a few tabs at once from the forums? If no one has the problem, I'll blow out the profile and see if that fixes it, but if other people are having the problem it might be worth investigating a bit more.

erebus25
Jan 20, 2004

by Lowtax


Right not a bug, but as the latest version removes the code that has SALR doing the highlighting of the original Thread Poster if anyone isn't getting the user highlighted you need to switch it on in the SA control panel, "Highlight the username of the "original poster" in thread posts".

Let's just repeat that so that the next three pages aren't full of people asking the same thing.

IF YOU THE THREAD POSTER'S NAME ISN'T BEING HIGHLIGHTED GO TO THE "USER CONTROL PANEL" LINK AT THE TOP OF THE PAGE THEN "EDIT OPTIONS" AND MAKE SURE YOU HAVE "Highlight the username of the "original poster" in thread posts" SET TO YES.

ryanbruce
May 1, 2002

The "Dell Dude"


Hey guys, the OP's name isn't being highlighted any more.. any ideas?

MyDogIsBeano
Jun 21, 2005

by Lowtax


erebus25 posted:

RIF THE THREAD POSTER'S NAME ISN'T BEING HIGHLIGHTED GO TO THE "USER CONTROL PANEL" LINK AT THE TOP OF THE PAGE THEN "EDIT OPTIONS" AND MAKE SURE YOU HAVE "Highlight the username of the "original poster" in thread posts" SET TO YES.

duz posted:

Known Issues

Ignoring threads not working entirely right
Converting YouTube links to the embedded player not working entirely right
Forum view thread coloring not working
Always show Go to Last Post not working
Threads can not be unread (we are relying on the forums to do it and they don't yet)

biznatchio posted:



AKA FAQ part two.

SALR makes quoting separate posts comically easy. You can tell who has FF SALR and who doesn't just by the style of quoting they do.

Grouch
Apr 28, 2002
Random Lurker

Any one else having problems with the SA Menu?

It keeps randomly dissapearing and giving me the "Visit a forum to reload list" message, i've tried visiting various sub-forums, logging in and out, uninstalling the extension and re-installing but nothing works.

withak
Jan 15, 2003

F != m * a

No problems here.

Demented Footstool
Jan 3, 2007

Do Not Summon The Fire

Grouch posted:

Any one else having problems with the SA Menu?

It keeps randomly dissapearing and giving me the "Visit a forum to reload list" message, i've tried visiting various sub-forums, logging in and out, uninstalling the extension and re-installing but nothing works.

Not having that issue either. What version of SALR are you using?

Disgustipated
Jul 28, 2003

Black metal ist krieg

Bug report, 070729:

Admins/Mods are getting "null" tacked on to the end of the "Forum Administrator" thing. I assume it has something to do with the new code to not over write the "magic 3".

Ex:


Grouch
Apr 28, 2002
Random Lurker

Demented Footstool posted:

Not having that issue either. What version of SALR are you using?

Using version 1.99.070729

Lollerich
Mar 25, 2004

The little doctors are back,
they want to play with you!


Why doesn't the plugin auto-update itself any longer?

duz
Jul 11, 2005

Excellent. The Arkham Asylum
shower cam is operational.

Disgustipated posted:

Bug report, 070729:

Admins/Mods are getting "null" tacked on to the end of the "Forum Administrator" thing. I assume it has something to do with the new code to not over write the "magic 3".


Yep, it has to do with the new OP detection. Go into your Forums Control Panel and enable highlighting. It should then go away. I'll fix it permanently tonight.

Lollerich posted:

Why doesn't the plugin auto-update itself any longer?

I believe that by default, Firefox only checks once a week for updates.

Tivac
Feb 18, 2003

No matter how things may seem to change, never forget who you are

Lollerich posted:

Why doesn't the plugin auto-update itself any longer?

https://addons.mozilla.org/en-US/firefox/addon/2098 will help with that. It picks up updates much faster.

Disgustipated
Jul 28, 2003

Black metal ist krieg

duz posted:

Yep, it has to do with the new OP detection. Go into your Forums Control Panel and enable highlighting. It should then go away. I'll fix it permanently tonight.


I believe that by default, Firefox only checks once a week for updates.
It's already enabled. The OP highlighting works fine, but users that are highlighted because they are special but don't have an actual note stored, show up with null.

Lollerich
Mar 25, 2004

The little doctors are back,
they want to play with you!


duz posted:

I believe that by default, Firefox only checks once a week for updates.
I was not aware of that. I thought it was daily or random or something.

Tivac posted:

https://addons.mozilla.org/en-US/firefox/addon/2098 will help with that. It picks up updates much faster.
Thanks!

EX-GAIJIN AT LAST
Feb 12, 2002

Is it that he has a genius for leadership, or merely that you have a genius for being led?

IcePotato posted:

Does anyone have a problem with firefox crashing when loading a few tabs at once from the forums? If no one has the problem, I'll blow out the profile and see if that fixes it, but if other people are having the problem it might be worth investigating a bit more.

I had that problem, with the 7/25 version. So far it hasn't happened with 7/29 but it was very intermittent.

Grouch posted:

Any one else having problems with the SA Menu?

It keeps randomly dissapearing and giving me the "Visit a forum to reload list" message, i've tried visiting various sub-forums, logging in and out, uninstalling the extension and re-installing but nothing works.

This also used to happen to me every 2-3 days it seemed, with both the 7/25 version and the one before that. It worked when the browser was loaded and I chose one forum to view; then from there it would be empty. What I did to restore the list was visit forums home, visit a forum, close the browser, open the browser, visit forums home again, and choose a forum again. Then it would reload the list.

Hasn't happened yet with the 7/29 version but again, it was intermittent so we'll see.

kri kri
Jul 18, 2007



Is it possible to add a feature that automatically expands YouTube embedded videos?

Adbot
ADBOT LOVES YOU

duz
Jul 11, 2005

Excellent. The Arkham Asylum
shower cam is operational.

kri kri posted:

Is it possible to add a feature that automatically expands YouTube embedded videos?

It's already in there but doesn't work quite right so it's disabled. To re-enable it, set extensions.salastread.enableVideoEmbedder to true in about:config.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply
«91 »