Search Amazon.com:
Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«30 »
  • Post
  • Reply
CrzyDTpBoy
Aug 5, 2003

997...998...999......GAMETIME

Grayham posted:

Do I need to download all of these individually?

Short answer: yes.

Long answer: there may be a way to get it to recursively install packages, but probably not from the web GUI.

Adbot
ADBOT LOVES YOU

unknown
Nov 16, 2002
Ain't got no stinking title yet!

Just to update my previous comments/questions. I finally got the system to pxe boot and install Freebsd 7.0 automatically. It now takes me 4 minutes from initial turn on of the computer to a working login prompt with a fresh install.

Couple of notes about sysinstall for the record:

- it sucks balls for automation

- do not use the 'diskPartitionWrite' or 'diskLabelCommit' commands as they will stop the auto-creation of the filesystem (newfs). Just let 'installCommit' do all the work.

- If you're running your own commands/apps, note that after 'installCommit' is run, all apps are run out of a chroot, and you don't have access to the original mfsroot disk structure any more.

- mfsroot can't be bigger that ~75megs due to memory issues. All apps needs to be statically compiled.

- sysinstall will only install the generic kernel from the dist CD, you need make your own app to move a custom kernel in.


There's probably a bunch of other things that have caused me hair loss, but those are the big hurdles if you ever need to do it yourself.

Sergeant Hobo
Jan 7, 2007

Zhu Li, do the thing!


Here's a rather subjective question: Do people tend to use the software that's installed in the base more than anything you can get for ports? For example, if I wanted to set up a FTP server, should I bother using the built-in one or should I get something like ProFTPD from ports?

HATE TROLL TIM
Dec 14, 2006


Sergeant Hobo posted:

Here's a rather subjective question: Do people tend to use the software that's installed in the base more than anything you can get for ports? For example, if I wanted to set up a FTP server, should I bother using the built-in one or should I get something like ProFTPD from ports?

vsftpd

It's amazing.

To answer your question better, I always do "Minimal" installs, which basically means SSH and DNS are the only base services I end up using.

Sergeant Hobo
Jan 7, 2007

Zhu Li, do the thing!


timb posted:

vsftpd

It's amazing.

To answer your question better, I always do "Minimal" installs, which basically means SSH and DNS are the only base services I end up using.

I don't remember what I did (probably a typical install) but I'll look for a minimal option next time I do. And I'm fairly sure I've heard of VSFTP before so I'll check that out.

uncleTomOfFinland
May 25, 2008



I tend to lean towards the defaults since you usually can't go horribly wrong with them and theres more configuration examples and documentation.

Sergeant Hobo
Jan 7, 2007

Zhu Li, do the thing!


Perhaps I should be asking what the criteria are for inclusion in the FreeBSD base then.

Bob Morales
Aug 18, 2006

HYPER-THREADING


Anyone know why my download of 7.0-RELEASE-i386-disc2.iso stops at 402,668k?

I tried 2 different mirrors.

complex
Sep 16, 2003



Bob Morales posted:

Anyone know why my download of 7.0-RELEASE-i386-disc2.iso stops at 402,668k?

I tried 2 different mirrors.

If you are using FTP try HTTP, or vice versa. Assuming you are in the US try the other mirrors at http://www.freebsd.org/doc/en/books...-MIRRORS-US-FTP

Bob Morales
Aug 18, 2006

HYPER-THREADING


complex posted:

If you are using FTP try HTTP, or vice versa. Assuming you are in the US try the other mirrors at http://www.freebsd.org/doc/en/books...-MIRRORS-US-FTP

Ended up using a torrent, but thanks.

minute
Jul 31, 2003



I just got a macbook pro, so I decided to put FreeBSD on my old Dell 600m to play around with. Everything's going pretty well so far, except for wireless.

I tried reading the man pages and the FreeBSD handbook, and put the following lines in /boot/loader.conf:

if_ipw_load="YES"
legal.intel_ipw.license_ack=1
wlan_load="YES"
firmware_load="YES"
ipw_bss_load="YES"
ipw_ibss_load="YES"
ipw_monitor_load="YES"

Unfortunately, Dell's BIOS sucks, and I can't verify that I have an ipw wireless card, but I'm pretty sure that's the one.

During boot, there were no messages about ipw. I did a "less /var/run/dmesg.boot | grep ipw" just to make sure.

I ran "ifconfig ipw0 up" and it tells me that the ipw0 interface does not exist.

Any ideas? Is there anyway to verify that loader.conf is actually being loaded?

JHVH-1
Jun 28, 2002


If the driver for your wireless is loaded (it might not even be in the kernel if you haven't built a custom one) you can do 'ifconfig -a' and it will list all the devices even if they aren't up.

I've never done wireless on freebsd, but if it works like a normal device then it should be listed in sysinstall too when you configure your network interfaces. I usually use that to add the network info to rc.local when I am doing ethernet configs.

This might be relevant: http://damien.bergamini.free.fr/ipw/iwi-freebsd.html

EDIT: But the background says DISCONTINUED. So the page might be outdated.

minute
Jul 31, 2003



ifconfig -a doesn't show ipw either, nor is it an option in sysinstall.

After looking at that guide it seems I was trying to load the ipw module when what I actually wanted was the iwi module. Haven't verified that everything works correctly yet, but at least it seems to be loading the module.

Thanks.

Edit: Also, a dumb question, what does it mean for a device to be "up"? Is it not up by default after being loaded?

minute fucked around with this message at Jul 9, 2008 around 04:57

JHVH-1
Jun 28, 2002


minute posted:

Edit: Also, a dumb question, what does it mean for a device to be "up"? Is it not up by default after being loaded?

It essentially means it is enabled. When you run ifconfig without any flags it just shows you devices that are up. It could be up, but not active. Such as with ethernet, where the device can be up but the media (the ethernet cable) isn't active (plugged in and getting a link).

minute
Jul 31, 2003



Okay I added the line

ifconfig_iwi0="ssid klinksys wepmode on weptxkey 1 wepkey 1:0x<40-bit hex> DHCP"

to my /etc/rc.conf. When I rebooted I got:

DHCPREQUEST on iwi0 to 255.255.255.255 port 67
DHCPDISCOVER on iwi0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on iwi0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on iwi0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on iwi0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on iwi0 to 255.255.255.255 port 67 interval 19
DHCPDISCOVER on iwi0 to 255.255.255.255 port 67 interval 4
No DHCPOFFERS received.

I'm pretty sure the hexkey is right, as I tried it on my macbook, but I'm not sure about the weptxkey. I tried the 104-bit version of the wepkey and it didn't work either.

Am I missing anything?

Edit: drat it I'm so confused. The man pages say that the WEP key is either 5 or 13 characters? The passphrase I chose is neither of these...?

minute fucked around with this message at Jul 9, 2008 around 06:26

unknown
Nov 16, 2002
Ain't got no stinking title yet!

Q: Are you sure this is a iwi (Intel 2200/2225/2915) wireless device?

If yes - you need to compile the driver into the kernel so it can load it. (check out /boot/kernel/ and see if there's any iwi_* files.) It looks like iwi is not included in GENERIC kernel (or at least not in the kernel conf file).


If no - what's the wireless card/chipset you have?

code:
an(4)                    - Aironet Communications 4500/4800 wireless network adapter driver
arl(4)                   - Aironet Arlan 655 wireless network adapter driver
ath(4)                   - Atheros IEEE 802.11 wireless network driver
awi(4)                   - AMD PCnetMobile IEEE 802.11 PCMCIA wireless network driver
cnw(4)                   - Netwave AirSurfer wireless network driver
ipw(4)                   - Intel PRO/Wireless 2100 IEEE 802.11 driver
iwi(4)                   - Intel PRO/Wireless 2200BG/2225BG/2915ABG IEEE 802.11 driver
ral(4)                   - Ralink Technology IEEE 802.11 wireless network driver
rum(4)                   - Ralink Technology USB IEEE 802.11a/b/g wireless network device
wpi(4)                   - Intel 3945ABG Wireless LAN IEEE 802.11 driver
zyd(4)                   - ZyDAS ZD1211/ZD1211B USB IEEE 802.11b/g wireless network device

minute
Jul 31, 2003



Yep, it's the right device. It's loading correctly, and I can scan for access points just fine. Right now, I'm just confused about WEP keys. Apparently I have to give a 5 byte or 13 byte key, but the one I chose when I set up the router is 10 bytes. I'm not really sure how that's supposed to work.

SmirkingJack
Nov 27, 2002


My (small) office wants to have a secondary web server sitting on the shelf in case the primary server goes down for the count. When it does this secondary server will be brought online and carry the load until the primary gets repaired or replaced. Long story short, running them in parallel and continously synced so one will automatically pick up when the other fails would be ideal, but isn't going to happen.

To cut down as much as possible on the down time until backups can be restored to the secondary server and it can assume web serving duties I was thinking that every hour I would create a snapshot of the data partition and save it to a removable hard drive, where all of the backups are stored. Then, when the time comes, I would stick this removable drive into the secondary server and copy over everything to it's data partition. The partitions would be the same size and the servers set up identically.

It seems like a fairly straight forward procedure, but is there anything wrong with my thinking? What would be the best way of restoring from a snapshot, simply copy everything over? Just cp or should I look into dd or something else? Would dd maintain permissions?


I know it isn't ideal, but it is what it is and I am doing the best with what I have. Any help you offer is greatly appreciated.

uncleTomOfFinland
May 25, 2008



SmirkingJack posted:

To cut down as much as possible on the down time until backups can be restored to the secondary server and it can assume web serving duties I was thinking that every hour I would create a snapshot of the data partition and save it to a removable hard drive, where all of the backups are stored. Then, when the time comes, I would stick this removable drive into the secondary server and copy over everything to it's data partition. The partitions would be the same size and the servers set up identically.

It seems like a fairly straight forward procedure, but is there anything wrong with my thinking? What would be the best way of restoring from a snapshot, simply copy everything over? Just cp or should I look into dd or something else? Would dd maintain permissions?

Are you running a database or anything volatile like that on the server?

quote:

I know it isn't ideal, but it is what it is and I am doing the best with what I have. Any help you offer is greatly appreciated.
The fact youre bothering with backups and even spare hardware puts you above a lot of people, unfortunately.

uncleTomOfFinland fucked around with this message at Jul 10, 2008 around 15:31

SmirkingJack
Nov 27, 2002


Pavol Paska posted:

Are you running a database or anything volatile like that on the server?

Ah, good point, I forgot to mention this. The data partition will be holding ezjails and within some of those jails MySQL will be running. I figured that I would cron a mysqldump to happen within the jails before the snapshot was created.

porkface
Dec 28, 2000

Oregoons Godfather

In my experience, over time, your server configurations are going to get out of synch and you'll have an awful lot of things to remember to do under pressure and in a hurry when trying to get the backup server online.

Why can't you just keep them automatically in synch, at least nightly?

SmirkingJack
Nov 27, 2002


porkface posted:

In my experience, over time, your server configurations are going to get out of synch and you'll have an awful lot of things to remember to do under pressure and in a hurry when trying to get the backup server online.

Why can't you just keep them automatically in synch, at least nightly?

Yeah, that's a fear of mine, but in theory it shouldn't be too bad. Since the jail (data) partition will hold all of the jails which in turn hold their individual configurations, copying one partition over the other should keep all of the jail configs in sync. Therefore, it should just be the host configs that I would need to worry about, but over the last few years I can't think of anything specific that I have had to change on the host so when these changes do occur it should be infrequent enough that it won't be problematic to update the other server.

Sergeant Hobo
Jan 7, 2007

Zhu Li, do the thing!


SmirkingJack posted:

Long story short, running them in parallel and continously synced so one will automatically pick up when the other fails would be ideal, but isn't going to happen.

Forgive me for being a newbie at FreeBSD/the slight derail, but isn't failover essentially what CARP is for? Or is there some other issue precluding you from using that?

Sergeant Hobo fucked around with this message at Jul 10, 2008 around 22:30

EvilMoFo
Jan 1, 2006



Sergeant Hobo posted:

Forgive me for being a newbie at FreeBSD/the slight derail, but isn't failover essentially what CARP is for? Or is there some other issue precluding you from using that?
that is for the (pf) firewall and not for a webserver

Sergeant Hobo
Jan 7, 2007

Zhu Li, do the thing!


EvilMoFo posted:

that is for the (pf) firewall and not for a webserver

Ah, gotcha. I got confused because it said "In some configurations, this may be used for availability or load balancing." Carry on.

minute
Jul 31, 2003



edit: nm

minute fucked around with this message at Jul 11, 2008 around 06:42

complex
Sep 16, 2003



EvilMoFo posted:

that is for the (pf) firewall and not for a webserver

We use CARP at work for webservers and many other types of servers too.

EvilMoFo
Jan 1, 2006



complex posted:

We use CARP at work for webservers and many other types of servers too.
i had only seen it in relation to pfsync .... i will have to look into it further

j6p
Nov 16, 2003


Okay, here's what I hope is an easy one. I am brand new to the world of BSD and have been using some downloaded teaching material to learn my away around. I should note that I am learning on OSX Tiger (I know this isn't an ideal situation to begin my understanding of BSD but it is my only available option at this time). I'm using tcsh in case that's relevant. Today I ran into a problem while attempting to perform an exercise in one of my books:

"Create a command that will list the contents of each subdirectory of the /home directory beginning with the letter k, count the number of files found, and save that number in a file called k-users-files."

The answer to this problem, as given by the book, is:

code:
ls /home/k* | wc > k-users-files
However this does not produce the correct answer, at least on my machine. The output from the ls command lists files in columns with a separate line identifying each subdirectory's path and a blank line to separate each subdirectory listing. So the output of wc (the line, word, and byte count of the resulting "k-users-files" file) doesn't tell me anything about the number of files in the "k" subdirectories because there are extra words and lines being counted.

Is this just an OSX Tiger quirk or did the authors of this book screw up, and what is the "real" answer to this problem?

Requested username
Dec 11, 2005


If you truly want to "Create a command that will list the contents of each subdirectory of the /home directory beginning with the letter k, count the number of files found, and save that number in a file called k-users-files."

Then you want this:
code:
ls /home/*/k* | wc > k-users-files
As for your ls problems. All I can say is try "ls -1". The command you've written (and my modified one) both work correctly in ksh and zsh on OpenBSD.

It could also be that ls is aliased to something else. If the output of "which ls" says that it's an alias then you'll have to fix whatever's setting that. On typical *nix systems this will be a file like .profile for Bourne-ish shells or .login for the 'C' shells.

j6p
Nov 16, 2003


Thanks for your input. Now that you've put it that way, I guess my problem is also one of grammar. It is difficult to tell by the way the question is worded if I am supposed to count files only in subdirectories that begin with the letter k or if I am supposed to count files that begin with the letter k in all subdirectories. In the latter case then your code will indeed produce the correct answer - you could even add the -l argument to the wc command to get nothing but the correct answer.

Your interpretation of the question is probably correct, insofar as it seems a more likely real-world scenario. With that solved, though, can anyone produce a command to solve the former interpretation of the question? That is, how would one go about listing all files in subdirectories that begin with the letter k?

JHVH-1
Jun 28, 2002


I thought when you pipe ls instead of outputting it to the screen it doesn't need -1.

And you could use wc -l to count the lines, by default it counts words.

From ls man file:
-1 (The numeric digit ``one''.) Force output to be one entry per
line. This is the default when output is not to a terminal.

So if you are piping to another command you don't need the -1 flag.

JHVH-1 fucked around with this message at Jul 13, 2008 around 05:30

DeciusMagnus
Mar 16, 2004

Seven times five
They were livin' creatures
Watch 'em come to life
Right before your eyes

JHVH-1 posted:

I thought when you pipe ls instead of outputting it to the screen it doesn't need -1.

If the ls command is aliased with -C flag it will force columnar output. It could also be some Darwin-specific thing (although I thought most of Darwin's userland was from FreeBSD).

j6p posted:

With that solved, though, can anyone produce a command to solve the former interpretation of the question?

I interpreted the question in two ways:
code:
ls -1 /home/*/k* | wc -l > k-users-files
or
code:
ls -1 /home/k* | wc -l > k-users-files
edit:
If you wanted to be absolutely correct the last one could be
code:
find /home/k* -prune -type d | while read entry ; do ls "$entry" ; done | wc -l > k-users-files
Otherwise you could list a non-directory entry beginning with k in the home directory. I don't know why you might have a non-directory entry in the home directory though.

DeciusMagnus fucked around with this message at Jul 13, 2008 around 17:08

PapaLazarou
May 11, 2008

Decadent Federation Swine!


I just attempted to install FreeBSD yesterday, and after my computer rebooted, I was plagued by the message "acpi_tz0: _TMP value is absurd, ignored (-247.7C)". After googling around, it seems like this is a fairly common error, but I was unable to find a solution. I'm running a VIA VB7001 motherboard, if that helps.

Anyone know anything about it?

complex
Sep 16, 2003



Lord Flashheart posted:

I just attempted to install FreeBSD yesterday, and after my computer rebooted, I was plagued by the message "acpi_tz0: _TMP value is absurd, ignored (-247.7C)". After googling around, it seems like this is a fairly common error, but I was unable to find a solution. I'm running a VIA VB7001 motherboard, if that helps.

Anyone know anything about it?

FreeBSD is just asking the motherboard for temperature information and is getting an illogical answer. The problem can either the ACPI implementation of the board (most likely), or how FreeBSD is interpreting the answer.

Are you running 6.3 or 7.0?

First, try a BIOS update from http://www.via.com.tw/en/products/m...herboard_id=490

Also see http://www.freebsd.org/doc/en_US.IS...acpi-debug.html for more options.

Of course, as long as it isn't spitting messages constantly and you don't care about temperature readings from the on-board sensors, it can also be ignored.

atticus
Nov 7, 2002

this is how u post~


I'm looking at the FreeBSD handbook now, and I'm not sure what the difference between this:

code:
# pkg_add nmap
and this

code:
# cd /usr/ports/security/nmap
# make install clean
is. I've installed some stuff using "pkg_add" and some stuff the other way, but everything still shows up when I run "pkg_info"

What gives? Or moreso, is there even a difference between "Packages" and "Ports" ???

DeciusMagnus
Mar 16, 2004

Seven times five
They were livin' creatures
Watch 'em come to life
Right before your eyes

atticus posted:

Or moreso, is there even a difference between "Packages" and "Ports" ???

Packages are compiled software while ports are sources to software that need to be built. Packages are usually faster than ports to install, but if you need to customize a build you'll have to use ports. Also, that last time I used pkg_add to install the software I wanted I found there was some software that didn't have any packages, but I can almost always find a port of some software I need.

atticus
Nov 7, 2002

this is how u post~


Cool, thanks for clearing that up. Another question - do most FreeBSD users find it really necessary to install that linux compatibility thing? Would the only advantage to this be for development/cross-platform testing?

porkface
Dec 28, 2000

Oregoons Godfather

atticus posted:

Cool, thanks for clearing that up. Another question - do most FreeBSD users find it really necessary to install that linux compatibility thing? Would the only advantage to this be for development/cross-platform testing?
With ports, you can customize your make config to compile everything specifically for your processor and often gain performance advantages.

The downside to that is that your install is less portable should you want to restore it to a new machine.

Yes, I install Linux compatibility on home or desktop machines so they have the flexibility to run things that may not be ported to FreeBSD yet. In the past that's included Java and Oracle, but those examples probably don't apply anymore. For a server, I only install it when it becomes necessary.

Adbot
ADBOT LOVES YOU

DeciusMagnus
Mar 16, 2004

Seven times five
They were livin' creatures
Watch 'em come to life
Right before your eyes

Speaking of Linux compatibility, I use Linux Firefox and the Flash 7 plug-in for Linux in an attempt to make Youtube work. I can see the video but the sound gets out of sync. Has anyone else had this problem? Has anyone been able to fix this? I tried using version 9 of Flash but it just crashes on Youtube.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply
«30 »