Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
kri kri
Jul 18, 2007



Achmed Jones posted:

What's the point of using browser plugins and send-to-SABnzbd buttons on websites? Why not just have SAB watch your browser's download folder for nzb files?

Categories

Adbot
ADBOT LOVES YOU

paradigmm
May 28, 2002

by Y Kant Ozma Post


Achmed Jones posted:

What's the point of using browser plugins and send-to-SABnzbd buttons on websites? Why not just have SAB watch your browser's download folder for nzb files?

SAB installed on different computer

Demented Guy
Apr 22, 2010

IF YOU ARE READING THIS IN AN NBA THREAD, LOOK TO YOUR RIGHT TO SEE MY EXPLETIVE RIDDEN, NONSENSICAL POST OF UTTER BULLSHIT


edit: nevermind

Demented Guy fucked around with this message at 00:38 on May 4, 2012

wolrah
May 8, 2006
what?


I've updated my nzbdstatus "fork" for this. New XPI here: https://github.com/downloads/wolrah...20504050130.xpi

And as paradigmm said, the browser extensions are great if you have SAB running on a different computer. SAB runs on my media server along with Sickbeard, Couch Potato, and Headphones. I can go to a NZB site from any computer in my apartment, click a download button, and have it end up in the right place.

bobfather
Sep 20, 2001

I will analyze your nervous system for beer money

Achmed Jones posted:

What's the point of using browser plugins and send-to-SABnzbd buttons on websites? Why not just have SAB watch your browser's download folder for nzb files?

When the HTPC is the only computer in the house, and it is administered by iPads and iPhones.

devmd01
Mar 7, 2006

Elektronik
Supersonik


I didn't want to open up my sab instance to the internet (even with a password), so I use both. Anything at home uses a browser plugin, and then if i'm off-network I have dropbox set to sync to my server, and one of the folders is the watch folder. Drop the NZB into the watch folder on my laptop away from the house, it syncs over and gets loaded.

Chumbawumba4ever97
Dec 31, 2000



YouTuber posted:

That's the network IP. You need your internet facing IP. Go here: http://www.whatismyip.com/

Type that ip in with the port number. If you can't connect it's likely the port is behind the wirewall. Type in 192.168.1.1 and usually it will pop up a password dialogue box. By default the username is blank and the password is "admin". In there look for port forwarding and enter the ports for Couch potato Sickbeard and Sanzbd.

Thank you. This is a very helpful reply but I still can't seem to get Qouch to work.

I got my real IP (let's say it's 188.43.42.337)

I logged into my router, and told it to create a new port forwarding rule. This rule shows the following:



I save, wait a few minutes, and try to connect with Quoch. It will not connect. In settings I have 188.43.42.337 (I even tried 188.43.42.337:8080) and all the other options appear to be correct.

Is there something I am missing here? I am complete idiot with networking, even though I am pretty decent with computers. Thanks so much for any help anyone can give.

Fcdts26
Mar 18, 2009


Hamburglar posted:

Thank you. This is a very helpful reply but I still can't seem to get Qouch to work.

I got my real IP (let's say it's 188.43.42.337)

I logged into my router, and told it to create a new port forwarding rule. This rule shows the following:



I save, wait a few minutes, and try to connect with Quoch. It will not connect. In settings I have 188.43.42.337 (I even tried 188.43.42.337:8080) and all the other options appear to be correct.

Is there something I am missing here? I am complete idiot with networking, even though I am pretty decent with computers. Thanks so much for any help anyone can give.

Under servers in qouch you put in the path correctly right? should just be /sabnzbd. I missed that the first time I set qouch up. Edit, I have mine setup for UDP/TCP also. Im not certain that will make a difference but try it.

Disgustipated
Jul 28, 2003

Black metal ist krieg

Hamburglar posted:

Thank you. This is a very helpful reply but I still can't seem to get Qouch to work.

I got my real IP (let's say it's 188.43.42.337)

I logged into my router, and told it to create a new port forwarding rule. This rule shows the following:



I save, wait a few minutes, and try to connect with Quoch. It will not connect. In settings I have 188.43.42.337 (I even tried 188.43.42.337:8080) and all the other options appear to be correct.

Is there something I am missing here? I am complete idiot with networking, even though I am pretty decent with computers. Thanks so much for any help anyone can give.
You need to forward TCP, not UDP.

MeKeV
Aug 10, 2010


It might be a NAT loopback issue? Some routers wont let you connect to a computer on the same network when connecting via the external IP address.


My router doesn't allow it, so I ended up just setting everything to internal ip addresses, no port forwarding, but connecting to my network via pptp VPN. It was easy peasy to set up and it's built right in to android, I don't know about IOS?


EDIT... unless you're not trying to connect from within the network in this instance, in which case ignore me.

MeKeV fucked around with this message at 16:40 on May 4, 2012

YouTuber
Jul 31, 2004

by FactsAreUseless


Achmed Jones posted:

What's the point of using browser plugins and send-to-SABnzbd buttons on websites? Why not just have SAB watch your browser's download folder for nzb files?

That's just an extra step. You need to plug all that data into your favored NZB site to make Sickbeard or Couchpotato work. It's easier for me to just click the SAB button instead of downloading the NZB then moving it from my real computer to my HTPC/Fileserver's watch folder.

Hamburglar posted:




There should be an option for TCP or both. Set it to both if you can.

MeKeV posted:



I get the feeling that Qouch isn't coded as well as it could be. The application outright didn't work until my data plan activated. Even running with the Wifi it would just pop the splash screen up then close immediately. Once my data plan activated the program was functional.

To be totally honest I've yet to get Sickbeard running for Qouch. I have Sabnzbd and Couchpotato running but Sickbeard refuses to cooperate.

YouTuber fucked around with this message at 17:36 on May 4, 2012

Chumbawumba4ever97
Dec 31, 2000



Thanks guys, but still no dice. Changed to TCP, didn't make any difference. Here is a screen shot of what's in my FiOS router now:



I am trying to connect externally from my iPhone (I could not get this thing working even ON the network, using 192.168.1.13 in Quoch). My Quoch settings are:

host or IP: 188.43.42.337
SABnzbd
Enabled ON
Use SSL: OFF
Port number: 8080
Path: sabnzbd
username (blank)
password (blank)
API Key: (auto detect)

I even turned off API key in SABnzbd on the computer to see if that could be the culprit but it's not because it still would not connect.

Would really appreciate anyone being able to help; it's pretty obtuse having to remote desktop from my laptop into my server to download anything. Would love to use this app.

YouTuber
Jul 31, 2004

by FactsAreUseless


If anyone has Sickbeard running on Qouch could they tell me what path they are using? I have mine blank and the rest of the information is either not used in the case of user/pass or auto detected. I have a feeling the path is the reason it won't connect to server for Sickbeard.

YouTuber fucked around with this message at 17:57 on May 4, 2012

EC
Jul 10, 2001

The Legend


I set it up on my iPad and it worked, I just had to go into Sickbeard's settings and enable the API. I just used the host name and it worked one (I have a DNS redirect in my router so I can use the external hostname internally, though).

Vykk.Draygo
Jan 17, 2004

I say salesmen and women of the world unite!

Hamburglar posted:

Thanks guys, but still no dice. Changed to TCP, didn't make any difference. Here is a screen shot of what's in my FiOS router now:



I am trying to connect externally from my iPhone (I could not get this thing working even ON the network, using 192.168.1.13 in Quoch). My Quoch settings are:

host or IP: 188.43.42.337
SABnzbd
Enabled ON
Use SSL: OFF
Port number: 8080
Path: sabnzbd
username (blank)
password (blank)
API Key: (auto detect)

I even turned off API key in SABnzbd on the computer to see if that could be the culprit but it's not because it still would not connect.

Would really appreciate anyone being able to help; it's pretty obtuse having to remote desktop from my laptop into my server to download anything. Would love to use this app.

I'm not positive but I think you have to set a username and password in order to connect remotely.

Chumbawumba4ever97
Dec 31, 2000



YouTuber posted:

188.43.42.337

It's just connecting directly to your IP with no direction. You need to specify the port by typing in

188.43.42.337:8080

Thanks, I feel dumb but I thought that's why I typed port 8080 down below that? Anyway, when I put what you said in, it just spit out a different error message: "Make sure you are using SABnzbd version 0.6 or higher" which I am.

Vykk.Draygo posted:

I'm not positive but I think you have to set a username and password in order to connect remotely.

Created one, rebooted the computer, placed it into Quoch, it doesn't work.

I *always* problems with ANYTHING related to routers/networking because I'm a goddamn idiot so I'm pretty sure it's me and not Quoch.

Chumbawumba4ever97 fucked around with this message at 18:22 on May 4, 2012

Disgustipated
Jul 28, 2003

Black metal ist krieg

Hamburglar posted:

Thanks, I feel dumb but I thought that's why I typed port 8080 down below that? Anyway, when I put that in, it just spit out a different error message: "Make sure you are using SABnzbd version 0.6 or higher" which I am.


Created one, rebooted the computer, placed it into Quoch, it doesn't work.

I *always* problems with ANYTHING related to routers/networking because I'm a goddamn idiot so I'm pretty sure it's me and not Quoch.
Can you get to it via the browser on your phone? If that doesn't work there's something else blocking you.

EDIT: What about from another PC on the network?

Chumbawumba4ever97
Dec 31, 2000



Disgustipated posted:

Can you get to it via the browser on your phone? If that doesn't work there's something else blocking you.


I just typed 188.43.42.337:8080 into Safari on iOS and no, it would not connect. (Sorry for turning this into the Hamburglar support thread)

whatismyip.com is saying something under my IP address about "Possible Proxy Detected: 1.0 PROXY" No idea if that's a problem?

Edit: I typed 188.43.42.337:8080 in the URL for a browser on a different computer on the network and got no connection.

Feenix
Mar 14, 2003
Sorry, guy.


Hamburglar posted:

(Sorry for turning this into the Hamburglar support thread)



This is helping me too. Same boat.

YouTuber
Jul 31, 2004

by FactsAreUseless


Hamburglar posted:

I just typed 188.43.42.337:8080 into Safari on iOS and no, it would not connect. (Sorry for turning this into the Hamburglar support thread)

whatismyip.com is saying something under my IP address about "Possible Proxy Detected: 1.0 PROXY" No idea if that's a problem?

Edit: I typed 188.43.42.337:8080 in the URL for a browser on a different computer on the network and got no connection.

Then it's not a Qouch issue it's a Firewall or Port Forwarding Issue.

wolrah
May 8, 2006
what?


I got in touch with duz and he added me to the project, so my updates to nzbdstatus are now on AMO. Unfortunately at the moment they're still hidden away in the "other versions" like all the 2.0 releases, but 2.0b4 is the current code as of now.

https://addons.mozilla.org/en-US/fi...tatus/versions/

TraderStav
May 19, 2006

It feels like I was standing my entire life and I just sat down


Even though I use the app, I cannot see Qouch and not read it as 'Cooch'. As in Coochie.

Chumbawumba4ever97
Dec 31, 2000



Feenix posted:

This is helping me too. Same boat.

Cool!

YouTuber posted:

Then it's not a Qouch issue it's a Firewall or Port Forwarding Issue.

It's definitely not a Qouch issue then but it still may be an sanzbdb issue, right? Because I just tried to go to 192.168.1.13:8080 in my browser from a computer on the same network and it didn't do anything.

EC
Jul 10, 2001

The Legend


I just spent an hour trying to get port forwarding working on my father-in-law's setup. RDC was working, and even though the firewall entry was setup the exact same way, SAB wasn't. After digging through firewall logs, I finally figured out that Cox has blocked incoming traffic on port 8080. Switched everything to 9000 and it started working.

So if y'all are having issues connecting, try a different port.

Incessant Excess
Aug 15, 2005

Cause of glitch:
Pretentiousness


wolrah posted:

I got in touch with duz and he added me to the project, so my updates to nzbdstatus are now on AMO. Unfortunately at the moment they're still hidden away in the "other versions" like all the 2.0 releases, but 2.0b4 is the current code as of now.

https://addons.mozilla.org/en-US/fi...tatus/versions/

I had no idea it got updated past 1.15 or whatever the last version I got through auto-update was, 2.0 is very cool and well worth the update. Your work is appreciated.

FISHMANPET
Mar 3, 2007

Sweet 'N Sour
Can't
Melt
Steel Beams


Hamburglar posted:

Cool!


It's definitely not a Qouch issue then but it still may be an sanzbdb issue, right? Because I just tried to go to 192.168.1.13:8080 in my browser from a computer on the same network and it didn't do anything.

Check the Config > General tab:


It sounds like sabnzbd is only listening from the local host, so in that first box you've got 192.168.1.13. Change it to 0.0.0.0 and it will accept connections from anything.

89
Feb 24, 2006

#worldchamps


So, Sickbeard has been working just fine. Except, a couple of days ago, out of the blue, it just stopped downloading stuff. Errors said it wasn't connecting to SABNZBD. So, I went into the settings in Sickbeard and changed the port it was looking for SABNZBD on from http://localhost:8085 or whatever it was to http://127.0.0.1 and when I test it, it says it is connected.

But, when it goes to download something in Sickbeard, I get error messages in the log and it doesn't download:

2012-05-04 15:31:13.016000 SEARCHQUEUE-RSS-SEARCH :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:15.022000 SEARCHQUEUE-RSS-SEARCH :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:26.624000 SEARCHQUEUE-BACKLOG-79488 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:36.470000 SEARCHQUEUE-BACKLOG-94571 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:48.070000 SEARCHQUEUE-MANUAL-SEARCH :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:53.852000 SEARCHQUEUE-BACKLOG-84912 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:05.480000 SEARCHQUEUE-BACKLOG-80379 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:16.607000 SEARCHQUEUE-BACKLOG-73244 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:28.830000 SEARCHQUEUE-BACKLOG-79274 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:39.287000 SEARCHQUEUE-BACKLOG-79274 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:44.362000 SEARCHQUEUE-BACKLOG-79274 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:49.366000 SEARCHQUEUE-BACKLOG-79274 :: Unknown failure sending NZB to sab. Return text is: File not found

What's up? It WAS working fine.

wolrah
May 8, 2006
what?


Biggest human being Ever posted:

I had no idea it got updated past 1.15 or whatever the last version I got through auto-update was, 2.0 is very cool and well worth the update. Your work is appreciated.

To make sure it's clear, most of the 2.0 work is duz's doing from early 2011, so far I've just tweaked a few things to bring it up to current. Thanks though.

Here's hoping AMO approves this one so the reviews aren't cluttered with people bitching about Newzbin and NZBs.org no longer working in 1.x.

Disgustipated
Jul 28, 2003

Black metal ist krieg

Hamburglar posted:

Cool!


It's definitely not a Qouch issue then but it still may be an sanzbdb issue, right? Because I just tried to go to 192.168.1.13:8080 in my browser from a computer on the same network and it didn't do anything.
Definitely not a Quoch issue, could be an issue with SABnzbd not listening on the right IP address like FISHMANPET posted.

What OS is the machine running SABnzbd running?

Chumbawumba4ever97
Dec 31, 2000



FISHMANPET posted:

Check the Config > General tab:


It sounds like sabnzbd is only listening from the local host, so in that first box you've got 192.168.1.13. Change it to 0.0.0.0 and it will accept connections from anything.

Did you ever know that you're my hero?
and everything I would like to be?
I can fly higher than an eagle,
'cause you are the wind beneath my wings


thankyouthankyouthankyouthankyouthankyouthankyouthankyou

I have NO CLUE how that changed to localhost, because I have sabnzbd on 3 computers in my house and the "media server" is the only one that didn't have all 0's. Really weird but I would have literally formatted the drat computer before thinking of that.

Thank you again, fishmanpet (and everyone else who gave ideas).

Beeftweeter
Jun 28, 2005


holy shit this os has cinepak?!?!?



I've been getting some strange issues with repairing failed downloads recently: things well inside of my server's retention have had missing parts (not that unusual), but when I click on retry, they'll actually re-download fully (sometimes from the same server ), but SABnzbd doesn't recognize this. After taking a look in the temp directory I saw what's clearly partial bits of the file (ex. 38 MB of a 50 MB RAR from the first failure; again, not that unusual), but then the same file, downloaded completely, as (for example, part 30 of something) filename.part30.rar.1, filename.part30.rar.2, etc. for however many times I mashed the retry button. If I manually rename all of the redownloaded parts, they extract and verify against the PAR sets, so it looks like SABnzbd just can't figure out what to do with them for some reason. Has this happened to anyone else?

e: edited for clarity

Beeftweeter fucked around with this message at 23:34 on May 4, 2012

Feenix
Mar 14, 2003
Sorry, guy.


Thanks to Hamburglar's tenacity in asking questions (and everyone else's help...) I, too, got all 3 working on Qouch. (CouchPotato, SAB and SB.)


My one concern is this: In Tomato, (on my iMac) I port-forwarded the necessary ports. I also am kind of a networking nimrod, but I'm GUESSING that my iMac's internal IP (192.168.1.xx) is going to change whenever the things refresh or whatever. Is there a simple way I can make it static without loving up EVERYTHING* in my house?

(*my iPhones, iPads, ps3, appletv, etc...)

(I know this isn't really a usenet question, and I apologize for that, but I figured you all already knew most of the story so you'd know why I was asking'.)

[edit] And despite having the EXACT same server credentials, Sickbeard won't connect on my iPad but will on my iPhone. The other 2 work fine on my iPad (and all 3 work on my iPhone.)

Feenix fucked around with this message at 01:06 on May 5, 2012

kri kri
Jul 18, 2007



http://www.textingthefridge.com/201...-on-tomato.html

FISHMANPET
Mar 3, 2007

Sweet 'N Sour
Can't
Melt
Steel Beams



That's hilariously complicated. Here's the easy/fun way to do it:
Go to Status > Device List. Find your entry, here's one for an iPad:

Click the Static button, and in the next screen put in a new name (if you want, if you don't change it, it will get the name of the computer). Whatever's in that name box is what gets put into DNS.


Then click the save button, and you're done. Now when you're on your network, you can use the hostname you picked instead of the IP to get to your computer.

SHIT POST MALONE
Feb 4, 2005

I was born down. You know this.


For some reason I can't get SABconnect++ to work with the new nzbs.org beta.

I feel like this guy because everything I've tried isn't getting it to work.

Restarted Chrome, reinstalled the extension, restarted sabnzbd... any other advice? It just won't send the nzbs over for whatever reason.

Nam Taf
Jun 25, 2005

I am Fat Man, hear me roar!



wolrah posted:

I got in touch with duz and he added me to the project, so my updates to nzbdstatus are now on AMO. Unfortunately at the moment they're still hidden away in the "other versions" like all the 2.0 releases, but 2.0b4 is the current code as of now.

https://addons.mozilla.org/en-US/fi...tatus/versions/

Can you please make it work for all versions of the new nzbs.org skins? It only works in default at the moment but I prefer dark classic.

Tide
Mar 27, 2010

by FactsAreUseless


Bucket Joneses posted:

For some reason I can't get SABconnect++ to work with the new nzbs.org beta.

I feel like this guy because everything I've tried isn't getting it to work.

Restarted Chrome, reinstalled the extension, restarted sabnzbd... any other advice? It just won't send the nzbs over for whatever reason.

This is happening to me as well. Have tried several fixes, but nothing is working.

Mister Fister
May 17, 2008


I'm on ancient versions of sickbeard and sabnzbd... do the new versions have the ability to install new updates by itself rather than having to download and install a fresh version (i know sickbeard used to do this at least)? THanks.

Feenix
Mar 14, 2003
Sorry, guy.


89 posted:

So, Sickbeard has been working just fine. Except, a couple of days ago, out of the blue, it just stopped downloading stuff. Errors said it wasn't connecting to SABNZBD. So, I went into the settings in Sickbeard and changed the port it was looking for SABNZBD on from http://localhost:8085 or whatever it was to http://127.0.0.1 and when I test it, it says it is connected.

But, when it goes to download something in Sickbeard, I get error messages in the log and it doesn't download:

2012-05-04 15:31:13.016000 SEARCHQUEUE-RSS-SEARCH :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:15.022000 SEARCHQUEUE-RSS-SEARCH :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:26.624000 SEARCHQUEUE-BACKLOG-79488 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:36.470000 SEARCHQUEUE-BACKLOG-94571 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:48.070000 SEARCHQUEUE-MANUAL-SEARCH :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:31:53.852000 SEARCHQUEUE-BACKLOG-84912 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:05.480000 SEARCHQUEUE-BACKLOG-80379 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:16.607000 SEARCHQUEUE-BACKLOG-73244 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:28.830000 SEARCHQUEUE-BACKLOG-79274 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:39.287000 SEARCHQUEUE-BACKLOG-79274 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:44.362000 SEARCHQUEUE-BACKLOG-79274 :: Unknown failure sending NZB to sab. Return text is: File not found
2012-05-04 15:32:49.366000 SEARCHQUEUE-BACKLOG-79274 :: Unknown failure sending NZB to sab. Return text is: File not found

What's up? It WAS working fine.

SAB/SickBeard worked great for me yesterday... tonight.. something similar to you...

May-04 22:40:58 ERROR SEARCHQUEUE-MANUAL-SEARCH :: Unable to connect to SAB: socket error

Anyone know what may be happening?

[edit] I posted a manual search log, my bad... this was more or less what I was getting all night...

May-04 21:56:13 ERROR SEARCHQUEUE-RSS-SEARCH :: Unable to connect to SAB: socket error
May-04 21:55:43 INFO SEARCHQUEUE-RSS-SEARCH :: Sending NZB to SABnzbd
May-04 21:55:41 ERROR SEARCHQUEUE-RSS-SEARCH :: Unable to connect to SAB: socket error
May-04 21:55:11 INFO SEARCHQUEUE-RSS-SEARCH :: Sending NZB to SABnzbd

Feenix fucked around with this message at 05:46 on May 5, 2012

Adbot
ADBOT LOVES YOU

The Gunslinger
Jul 24, 2004

Do not forget the face of your father.

Fun Shoe

Mister Fister posted:

I'm on ancient versions of sickbeard and sabnzbd... do the new versions have the ability to install new updates by itself rather than having to download and install a fresh version (i know sickbeard used to do this at least)? THanks.

Sickbeard and the new version of CouchPotato do this but SAB doesn't so far.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply