Register a SA Forums Account here!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
  • Post
  • Reply
Jan 13, 2007

Problem description: Background: We have a sharepoint online with office 365 plan. Files are accessed through onedrive via the sharepoint sync feature.

Once in a while a word file will become unopenable by word. I get the following error:

Other files in the folder open fine. I can see the file properties via explorer, can attach the file to an email, even tried 'type' in powershell and it spits out the expected gibberish. Acrobat seems to be able to read the file but stalls when it launches word to convert it.

But I don't think the file is actually corrupted. First, the repair options in word just give the same error. Second, the file opens fine if I copy it to my desktop. The file opens fine if I copy it to another folder on the onedrive/sharepoint library. The file works fine if I rename it in the same folder. If I rename the file, make some edits, and rename it back, it is not openable again. Other people can open the same file from the same location with no problems. I can open the file from other computers with the same onedrive sync setup and also have no problems.

I still get the error if I attempt to open the file directly from the sharepoint online library in chrome, edge, or IE. The file will open in Word Online but that also fucks up the document styles so I can't use that to edit. I also get the error when opening the file from windows explorer connected directly to the sharepoint using the IE "open with explorer" option. (This option is only available in IE and the whole reason we started using onedrive was to not have to use IE for accessing the sharepoint.)

The files also opened perfectly fine earlier in this project. More and more files are becoming unopenable as the project progresses. The only thing in common between the files is that they are on the same sharepoint library (different top-level folders, though) based on the same (docx) template file, and contain varying numbers of embedded full-page images (some only have a few pages, some have hundreds).

Attempted fixes: What have you tried to do to resolve the problem?

The behavior observed seems to point at some kind of caching issue somewhere between onedrive, word, and sharepoint. Most google results for the error message just point to a corrupted file and the standard steps for recovery, but the file is perfectly fine on the sharepoint side. I have cleared out every cache google and I could possibly think of, including deprecated ones. In the short term I've resorted to temporarily renaming the files so I can edit them, then naming them back so they match project naming conventions.

The problem persists through reboots, and also persisted through unlinking onedrive/sharepoint and relinking.

Things I haven't tried yet: Reinstalling word, office as a whole, onedrive, or windows. In the middle of a crunch and no time for downtime, and I can at least continue to work with the rename-edit-rename workaround, but as the problem seems to be growing, I'd like to stop it.

edited to add: This is for my job, but we're a small company and I am the most technical person here (on this topic), so there's no IT department to ask for help. I'm also the admin of the sharepoint site and 365 accounts.

Recent changes: Have you made any changes to your system/configuration recently that might have caused the problem?

Nothing I can think of. Office did get an update with a recent windows update, but that was several months ago and the problem only started in the past week. PC is up to date as of last Friday, when I rebooted/installed updates to try to fix.


Operating system: Windows 10 pro 64-bit (upgraded from Win 7 around the time Win 10 came out)

System specs: AMD FX-6350, 16 GB ram, Radeon R7 200 something GPU, 240 GB OS SSD and 2 TB spinning rust for bulk storage.

(Yes this is ancient, originally built in 2009. Yell at my boss who took our covid WFH money and got himself four 4K monitors instead of new workstations for us.)

Location: USA

I have Googled and read the FAQ: Yes

Roflex fucked around with this message at 19:59 on Aug 3, 2021


Jul 29, 2003

You could try a few more web browsers just to be 100% sure it isn't some browser issue. Safari or Firefox probably.

Roflex posted:

Things I haven't tried yet: Reinstalling word, office as a whole, onedrive, or windows.

Yes, the fact that the computer was upgraded from W7 to W10 leaves a lot of room for odd OS/Office issues to arise. Especially if the OS install is from 2009. So a full reinstall of the programs may be the simplest/quickest option at some point.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply