Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«98 »
  • Locked thread
Swilo
Jun 2, 2004
ANIME SUCKS HARD



Tabachinova posted:

I don't get the forums menu, it shows when the page is loading but when it's finished it disappears.
Under the General tab, turn "Hide Forum Header and Footer" off.

Adbot
ADBOT LOVES YOU

ryanbruce
May 1, 2002

The "Dell Dude"


Tabachinova posted:

I don't get the forums menu, it shows when the page is loading but when it's finished it disappears.

You probably have "remove SA footers/headers" enabled on the General tab.

Edit: Oh why hello there page 16! Serves me right for not checking to see if there was another page.

Tabachinova
May 6, 2007

You say...

You say you'd still rather wear the outfit.


Swilo posted:

Under the General tab, turn "Hide Forum Header and Footer" off.

ryanbruce posted:

You probably have "remove SA footers/headers" enabled on the General tab.

Edit: Oh why hello there page 16! Serves me right for not checking to see if there was another page.

sorry, i just didn't see it.

Swilo
Jun 2, 2004
ANIME SUCKS HARD



Opening mod threads in the archive will make SALR crash on that subforum of the live forums. It fixes itself if I reload FF or open a mod thread from a different subforum in the archives

Wasn't SALR disabled for archives a while back? I'm noticing some user coloring going on in there.

RedKazan
Apr 4, 2003



Swilo posted:

Opening mod threads in the archive will make SALR crash on that subforum of the live forums. It fixes itself if I reload FF or open a mod thread from a different subforum in the archives

Wasn't SALR disabled for archives a while back? I'm noticing some user coloring going on in there.

That error seems to manifest itself in a lot of places and I've been having trouble tracking it down. Thanks for the lead. Turns out there are no mod stars in the archives. When you went into a thread that SALR thought was posted by a mod and it didn't find the star next to their name, it stripped them of their mod status, which caused problems when it came to coloring them in the live forums. The same error occurred when you visited a thread by an admin in a forum that they are also a mod of, and then went back to the thread list. Both issues fixed. Mods/admins, as well as custom users, will be colored in the archives if (as far as your database knows) they are currently mods/admins in the live forums.

I don't really see a reason to disable SALR completely in the archives, some features work just fine there and are still useful (mouse gestures for one). If you do find errors in the archives (or anywhere) though, please let us know, as always.



P.S. here's a sneak peek of what I've been working on in the repository:



Harmonica
May 18, 2004

il cinema è la vita e viceversa

The ability to highlight quoted posts was something I really wanted (and failed to hack into Greasemonkey myself), so thank you very much for adding that to the latest incarnation(s).

Crash
Mar 29, 2003


RedKazan posted:

P.S. here's a sneak peek of what I've been working on in the repository:





Thanks for all the time you, duz, Tivac and anybody else I forgot to mention is spending on this project. This looks very promising...

Aratoeldar
Mar 21, 2005


Because of a problem with another extension I want to unintstall Firefox. How do I back up my SALR preferences?

withak
Jan 15, 2003


Fun Shoe

They are in prefs.js with all your other FF settings.

Aratoeldar
Mar 21, 2005


withak posted:

They are in prefs.js with all your other FF settings.

While it does back up some things it doesn't back up everything (Such as Custom User Highlighting and Notes).

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


Aratoeldar posted:

While it does back up some things it doesn't back up everything (Such as Custom User Highlighting and Notes).

Those are in salastread.sqlite

Aratoeldar
Mar 21, 2005


duz posted:

Those are in salastread.sqlite

Thank you very much. Besides packing up the info in prefs.js and salastread.sqlite file. Is there anything else I back up for SALR?

Is there any way to get a back up function like Forcastfox or Tab Mix Plus?

RedKazan
Apr 4, 2003



Aratoeldar posted:

Thank you very much. Besides packing up the info in prefs.js and salastread.sqlite file. Is there anything else I back up for SALR?

Is there any way to get a back up function like Forcastfox or Tab Mix Plus?

Yeah I've been working on that when I get time, we should have it sometime in the near future. I keep getting distracted by TF2 though

Swilo
Jun 2, 2004
ANIME SUCKS HARD



Crashing while showing a single post (/showthread.php?action=showpost&postid=#):

ryanbruce
May 1, 2002

The "Dell Dude"


Replicated on Firefox 2.0.0.4, OSX, SALR 1.99.070930

RedKazan
Apr 4, 2003



Swilo posted:

Crashing while showing a single post (/showthread.php?action=showpost&postid=#):



Fixed, thanks.

Son of Sam-I-Am
Feb 12, 2002




From time to time I still keep losing all my pinned subforums and the dropdown expandable forum list goes blank. It still says "Main - Discussion - The Finer Arts" etc. but it won't show any of the forum names.

Currently on the latest version, 1.99.070930, but this has been going on for months, off and on, with all the versions, to my knowledge. Maybe once or twice a week it'll happen. I am sorry but I have no way to replicate it. It seems totally random to me.

Right now my traditional fix of visiting the forums home, visiting a subforum, closing Firefox, and then repeating no longer works, even if I go through three or four iterations.

Yim
Feb 12, 2004
I TURNED 20 AND ALL I GOT WAS THIS STINKING CUSTOM TITLE

Komrade Hitlerstalin posted:

From time to time I still keep losing all my pinned subforums and the dropdown expandable forum list goes blank. It still says "Main - Discussion - The Finer Arts" etc. but it won't show any of the forum names.

Currently on the latest version, 1.99.070930, but this has been going on for months, off and on, with all the versions, to my knowledge. Maybe once or twice a week it'll happen. I am sorry but I have no way to replicate it. It seems totally random to me.


This just happened to me also, but this is the first time I've noticed this.

Mr. Fix It
Oct 26, 2000

"I never killed a man in my whole life!"

I had that happen to me to, but I think it was an issue with the forums: the drop down menu was messed up. When I checked it, it had the exact same listing of just the forum categories. Now the drop down is back to normal and so is my SALR menu.

Lollerich
Mar 25, 2004

The little doctors are back,
they want to play with you!


My menu has been broken all day, and still is. I supposed they changed something again and SALastread is making GBS threads itself.

Mister Bung
Jun 7, 2004

What about the children foo'?


Ditto on the broken menus.

Uptodate SALR and Firefox. Posting usually fixes it but it doesn't look like it's working this time.


Ok, this'll be the second post since update and menus are back. How odd.

Mister Bung fucked around with this message at Oct 14, 2007 around 15:11

Hidohebhi
Nov 19, 2006

"Do you know how hard it was to find 'a bangin' redhead'?"


edit: Posted on girlfriend's computer, hurf durf.

hooah
Feb 6, 2006
WTF?

Odd, I'm not having these menu problems. No idea what's going on differently.

RedKazan
Apr 4, 2003



We've had reports of the menu getting broken since around June, but like you said I can't find any way to replicate it. Personally I've never had the menu break. But I'll spend some time tonight looking at how the menu is built and see if anything sticks out. We've haven't packed an update in 2 weeks so I'm not sure why you guys are all having these problems today.

Lollerich
Mar 25, 2004

The little doctors are back,
they want to play with you!


Funny thing that.
I just noticed my menu works again.

I haven't done anything different than before. I know we should visit a thread or the forums list or whatever first to have the menu rebuilt and I did all that and it didn't help.

Now, out of the blue the menu is fixed. I just don't know what to say, man.

Mister Bung
Jun 7, 2004

What about the children foo'?


Lollerich posted:

Funny thing that.
I just noticed my menu works again.

I haven't done anything different than before. I know we should visit a thread or the forums list or whatever first to have the menu rebuilt and I did all that and it didn't help.

Now, out of the blue the menu is fixed. I just don't know what to say, man.

Mine just started working again too (after I posted a second time). Did you post? Perhaps twice?

Lollerich
Mar 25, 2004

The little doctors are back,
they want to play with you!


Mister Bung posted:

Mine just started working again too (after I posted a second time). Did you post? Perhaps twice?
I don't remember I think I've posted more than twice today.

Son of Sam-I-Am
Feb 12, 2002




RedKazan posted:

We've had reports of the menu getting broken since around June, but like you said I can't find any way to replicate it. Personally I've never had the menu break. But I'll spend some time tonight looking at how the menu is built and see if anything sticks out. We've haven't packed an update in 2 weeks so I'm not sure why you guys are all having these problems today.

When it does happen, it seems to happen in the wee hours, say after midnight Eastern. I don't recall it happening much outside of that time frame. And as soon as I visited SH/SC first thing just now, via forums home, it loaded everything again.

It might just be something with the way the forums operate at that time, if something isn't loading properly on the screen where it trawls all the info for the menu, or it gets confused when something changes. That's really the only thing I can think of that could cause it.

Would it be possible as a stopgap to have it retain the old structure if it can't find or load it? Most of the forums don't change name or forumid very often so it shouldn't break anything; the worst that can happen is you have an old name for FYAD or don't have the very newest subforum yet or something. I mean, in theory.

Edit: in fact, it might be useful to have a custom menu where you can rename forums to your own liking and just have it point to the forumid, in case people wanted to avoid spoilers in FYAD's title or anything like that.

Son of Sam-I-Am fucked around with this message at Oct 14, 2007 around 17:15

Xeltos
May 19, 2004

The Freshmaker

I didn't see anything in the thread about this (but at the same time I might have just missed it). But for some reason clicking the go to last read button takes me to the next page. Like, say the thread is 3 pages long and I got through one page and just started the second before having to leave for class or something, when i come back and click on the button it sends me to page 3.

I hope this makes sense

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


Xeltos posted:

I didn't see anything in the thread about this (but at the same time I might have just missed it). But for some reason clicking the go to last read button takes me to the next page. Like, say the thread is 3 pages long and I got through one page and just started the second before having to leave for class or something, when i come back and click on the button it sends me to page 3.

I hope this makes sense

When you load a page, the server marks all posts on that page as read. Use the little yellow page icon under avatars to set that post as the last read.

hooah
Feb 6, 2006
WTF?

What happened to the quick reply/quote/edit implementation? It's still checked in my configuration window, but I only see one button for each action, instead of the usual [Reply][>>].

Edit: And right after I did that, the reply button went to the SALR kind, but not the edit/quote buttons.

pik_d
Feb 24, 2006

follow the white dove



Is Ubuntu supported? I just installed it, and it seems like two things so far aren't working. First is that it doesn't seem to be scaling images. It's set to scale to a max of 800 pixel for width, but I came across something that was 12xx pixels wide with the dotted lines around it, but it wouldn't scale down when clicked. The second thing is highlighting when people quote me. This works in XPpro, so I know I've got the correct settings in my SA Control Panel, and it looks right in the SALR configuration page.

If you don't officially support Ubuntu, I can still manage since everything else seems to be in working order.

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


pik_d posted:

Is Ubuntu supported? I just installed it, and it seems like two things so far aren't working. First is that it doesn't seem to be scaling images. It's set to scale to a max of 800 pixel for width, but I came across something that was 12xx pixels wide with the dotted lines around it, but it wouldn't scale down when clicked. The second thing is highlighting when people quote me. This works in XPpro, so I know I've got the correct settings in my SA Control Panel, and it looks right in the SALR configuration page.

If you don't officially support Ubuntu, I can still manage since everything else seems to be in working order.

Since I run Ubuntu, I'd hope it's supported. I'll have to look into the image scaling as I havn't used that in a while. WRT highlighting quotes, check the value of extensions.salastread.username and make sure it contains your username.

pik_d
Feb 24, 2006

follow the white dove



duz posted:

Since I run Ubuntu, I'd hope it's supported. I'll have to look into the image scaling as I havn't used that in a while. WRT highlighting quotes, check the value of extensions.salastread.username and make sure it contains your username.

Hmm, you quoting me there turned purple. Not sure why it didn't earlier. I'll go check on a thread with big pictures. Maybe closing and opening Firefox did something? I don't know.

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


pik_d posted:

Hmm, you quoting me there turned purple. Not sure why it didn't earlier. I'll go check on a thread with big pictures. Maybe closing and opening Firefox did something? I don't know.

It can't highlight your quotes until it knows who you are and it doesn't know who you are until you visit the forum's home or your control panel. It could've been that.

pik_d
Feb 24, 2006

follow the white dove



duz posted:

It can't highlight your quotes until it knows who you are and it doesn't know who you are until you visit the forum's home or your control panel. It could've been that.

Makes sense. Still doesn't scale down images over 800pixels wide, even though I have it set to.

Horn
Jun 18, 2004

Penetration is the key to success

College Slice

Would it be possible to have a list on the forum pages of threads that you've read recently but aren't on the first page? I know you guys can't go out and check all the read threads and see if they have new posts if they're not on the first page but if something like this is implemented it'd make it easier to tracker some of the slower threads in GBS and other high traffic subforums.

pik_d
Feb 24, 2006

follow the white dove



Horn posted:

Would it be possible to have a list on the forum pages of threads that you've read recently but aren't on the first page? I know you guys can't go out and check all the read threads and see if they have new posts if they're not on the first page but if something like this is implemented it'd make it easier to tracker some of the slower threads in GBS and other high traffic subforums.

Go into the "Forum" tab in the SALR configurator and there's an option to "Show threads with new posts first". That sounds pretty close to what you want.

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


Horn posted:

Would it be possible to have a list on the forum pages of threads that you've read recently but aren't on the first page? I know you guys can't go out and check all the read threads and see if they have new posts if they're not on the first page but if something like this is implemented it'd make it easier to tracker some of the slower threads in GBS and other high traffic subforums.

SALR doesn't track what threads you've read so that can't be done.

Adbot
ADBOT LOVES YOU

Horn
Jun 18, 2004

Penetration is the key to success

College Slice

duz posted:

SALR doesn't track what threads you've read so that can't be done.

Oh shoot thats right. I forgot that was all server side now.

  • Locked thread
«98 »