Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«98 »
  • Locked thread
Gorilla Salsa
Dec 4, 2007

Post Post Post.


RedKazan posted:

That is pretty creepy!

I'm not doing it to be creepy or to or anything, I actually only have 2 "GIRL!" notes. I do it mostly so I can know more about the perspective of the poster. If someone posts a thread in GBS saying "Why are all the Wal*Marts full of rednecks", and that person replies with "I've never seen any rednecks in Wal*Mart", and I notice I have a user note saying that they live in California or something, I can understand why. Terrible example, but I think it'd also be useful for calling bullshit.

I don't really consider it creepy, because I don't go on pursuits for more information. If the information is there, I'll note it, but I'm not going to utilize that information to do anything creepy.

I'm not really doing a great job at defending myself here. gently caress.

EDIT: Put it this way, you can make a user note for me that says "Takes user notes of everybody". Then, if I make a totally stupid thread somewhere, you can reply with "aren't you the guy that takes notes of everybody", and flaming hilarity will ensue.

Gorilla Salsa fucked around with this message at Dec 28, 2007 around 06:09

Adbot
ADBOT LOVES YOU

wormil
Sep 12, 2002

Hulk will smoke you!

Jeffrey Salsa posted:

I would just like to thank the developers for the user note feature. I've been adding notes about almost every goon that I can find some information on. If someone mentions that they're a goonette, I add a note that says "GIRL!" ...

User note added: Creepy.

Just kidding. I add tons of user notes also.

RedKazan
Apr 4, 2003



Jeffrey Salsa posted:

I'm not really doing a great job at defending myself here. gently caress.
This.

Also you might want to lurk for a while before posting an "article" in Helldump.

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


New version out.
A bit of code clean up to help with speed and memory usage. Some fancy features added to the Who Posted list, RedKazan will explain more. Imageshack links should now work for those browsing the archives and want to see more than thumbnails.


If you can see the SA logo you have the latest version installed:

RedKazan
Apr 4, 2003



Known Issues
See the second post

New Features/Changes
- Reply counts on the Who's Posted? listing for threads now link to all of that poster's posts in that thread (the equilavant of the "?" link in posts).
- Threads will now have a link to the Who's Posted? list at the top next to the "Search thread:" box. Minimalists can disable this with the undocumented preference "replyCountLinkinThreads" which defaults to true.
- Clicking the "[show thread & close window]" link at the bottom of a Who's Posted? window that lead from inside a thread will now only close the window and not reload the thread at page 1.
- The Who's Posted? list will now color users just as they would be in a forums listing (except background) as well as sort them by priority in addition to post quantity. Users with custom coloring are listed first, followed by admins, then mods, then everyone else. This functionality can be disabled with the undocumented preference "sortReplyList" which defaults to true. The coloring can be disabled just like any other user coloring, by unchecking "Highlight interesting and important usernames" in the Users tab of the SALR options. This coloring is also affected by the "Don't make highlighted usernames bold" option.
- Single posts shown from the "1" links in the live forums will now be properly parsed and modified as any other normal post. In addition, the Up mouse gesture from these posts will no longer take you to a "null" thread.
- Usernames in the Killed By column in thread lists are now properly colored in the same manner as the Author column.

Bug Fixes
- Fixed a transparent "My Post is Quoted" option in the Colors tab overriding a custom background color DB entry for your own username in Users tab.
- Most broken .us links should now be working now. (They currently still don't in quoted text.)
- Fixed error when trying to attach scripts to the head section of the headless attachment.php page.
- Fixed broken JavaScript links in the Replies column of the Control Panel bookmarks listing (and anywhere else it might turn up).

Developmental Notes
A lot of reorganization, cleaning, and recoding that you can read about in the SVN changelog for revision 176.

Pictures!

Link added to top of threads. It would usually be just to the right of the search thread box, but that box has been disabled indefinately, so it is currently all by its lonesome:


How the replies count window will now look with user coloring and reply count sorting enabled ("Users of Interest" is anyone with a custom color in your database):

Revolvyerom
Nov 12, 2005

Hell yes, tell him we're plenty front right now.

Quick reply/quote/edit still gives this error whenever "Preview" is checked.


This is with a complete removal of SALR and all files it leaves behind, and reinstall. Since it was throwing a JavaScript error, I tried disabling NoScript, but that didn't change anything.
Firefox 3 Beta 2, Windows XP

Huh, and now quick edit/quote/reply buttons do absolutely nothing.
edit: OK, disregard that. The error window had popped up almost exactly where the image I posted was, and so I never even saw it. Hitting the "OK" in that window let me use the buttons again, albeit still with the error.
Edit2: A "scorched earth" policy fixed it. Uninstalled firefox. Deleted every file in every folder firefox was ever in. Reinstalled version 2.0, reinstalled SALR, it all works. Guess the problem was all me. Thanks for an awesome plugin.

Revolvyerom fucked around with this message at Dec 28, 2007 around 08:03

Idran
Jan 12, 2005


Grimey Drawer

I posted about this a while back, but it doesn't seem to be fixed yet, nor is it listed in known issues. Gesture navigation still looks to be broken in single-user thread views. The navigation box in the corner works right, but when you use the right-click navigation boxes when you're viewing a single user's posts in a thread to go to another page, it takes you to that page number in the all-users thread.

It's not a major issue by any measure, but I don't know if my reporting of it was noticed before or not. All the single-user stuff that just got updated reminded me of it, so I figured I might as well mention it again.

RedKazan
Apr 4, 2003



Revolvyerom posted:

Firefox 3 Beta 2, Windows XP
...
Edit2: A "scorched earth" policy fixed it. Uninstalled firefox. Deleted every file in every folder firefox was ever in. Reinstalled version 2.0, reinstalled SALR, it all works. Guess the problem was all me. Thanks for an awesome plugin.
More likely it was something that doesn't work for Firefox 3 yet. SALR hasn't been thoroughly tested with 3 yet, as neither I nor duz use it. It should be fixed when the time comes.

Idran posted:

I posted about this a while back, but it doesn't seem to be fixed yet, nor is it listed in known issues. Gesture navigation still looks to be broken in single-user thread views. The navigation box in the corner works right, but when you use the right-click navigation boxes when you're viewing a single user's posts in a thread to go to another page, it takes you to that page number in the all-users thread.
Yeah I noticed that a few days ago, it's on my todo list, it should be in the next update.

RedKazan fucked around with this message at Dec 28, 2007 around 14:43

raven77
Jan 28, 2006

Nevermore.

I like the new SALR features, guys. Thanks a lot for all the hard work, it's really awesome how helpful this extension is.

Lollerich
Mar 25, 2004

The little doctors are back,
they want to play with you!


I agree. Everything works flawlessly for me.

ryanbruce
May 1, 2002

The "Dell Dude"


duz posted:

If you can see the SA logo you have the latest version installed:

Can anyone else see the SA logo? I've updated SALR on both of my PCs and I'm not seeing it.. Guess I'm not in the cool kids club

raven77
Jan 28, 2006

Nevermore.

ryanbruce posted:

Can anyone else see the SA logo? I've updated SALR on both of my PCs and I'm not seeing it.. Guess I'm not in the cool kids club

Maybe try clearing your cache? Other than that, the only thing I can think of that would block it is if you have Adblock or another image blocking program, make sure that isn't on the list of sites to block...

RedKazan
Apr 4, 2003



Idran posted:

I posted about this a while back, but it doesn't seem to be fixed yet, nor is it listed in known issues. Gesture navigation still looks to be broken in single-user thread views. The navigation box in the corner works right, but when you use the right-click navigation boxes when you're viewing a single user's posts in a thread to go to another page, it takes you to that page number in the all-users thread.

It's not a major issue by any measure, but I don't know if my reporting of it was noticed before or not. All the single-user stuff that just got updated reminded me of it, so I figured I might as well mention it again.

This is now fixed in the repo and should be in the next update (whenever that is).

frozenphil
Mar 13, 2003

YOU CANNOT MAKE A MISTAKE SO BIG THAT 80 GRIT CAN'T FIX IT!


I haven't seen it listed anywhere, but what happened with highlighting threads you have posted in a different color? Is it brocken or do I not have the right options checked?

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


frozenphil posted:

I haven't seen it listed anywhere, but what happened with highlighting threads you have posted in a different color? Is it brocken or do I not have the right options checked?

http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404
http://forums.somethingawful.com/sh...ostid=331219404

Crash
Mar 29, 2003


ryanbruce posted:

Can anyone else see the SA logo? I've updated SALR on both of my PCs and I'm not seeing it.. Guess I'm not in the cool kids club

I'm not seeing it as well, although I apparently have the latest version, since all the new features regarding 'Who posted' work correctly.

Both image links in the source view (href: http://fi.somethingawful.com/is/my....aderlogomn1.png and img src: http://fi.somethingawful.com/is/img...rlogomn1.th.png) give a 404 error.

edit for another bug report:

Clicking your own 'Add coloring/note' link seems to be broken as well, it only goes to the Users configuration tab, without adding your own username like it does when you click the link of someone else.

Crash fucked around with this message at Dec 28, 2007 around 21:59

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


Crash posted:

I'm not seeing it as well, although I apparently have the latest version, since all the new features regarding 'Who posted' work correctly.

Both image links in the source view (href: http://fi.somethingawful.com/is/my....aderlogomn1.png and img src: http://fi.somethingawful.com/is/img...rlogomn1.th.png) give a 404 error.

Do you have convert links to images turned on?

ryanbruce
May 1, 2002

The "Dell Dude"


duz posted:

Do you have convert links to images turned on?

I do not. Will temporarily turn on and try again.

edit: That fixed it. Turning it back off anyways since this is a work PC.

ryanbruce fucked around with this message at Dec 28, 2007 around 22:25

RedKazan
Apr 4, 2003



Crash posted:

Clicking your own 'Add coloring/note' link seems to be broken as well, it only goes to the Users configuration tab, without adding your own username like it does when you click the link of someone else.

Weird. Fixed, thanks.

Crash
Mar 29, 2003


duz posted:

Do you have convert links to images turned on?
No I didn't, it works now after switching it on...

RedKazan posted:

Weird. Fixed, thanks.
Ok, thanks! And a big Thank You to you all for putting so much work into this. It's frightening how much my browsing experience now depends on this little addon.

killer ninjas
Mar 9, 2005


I can't remember. . . did we ever determine that thread starring (independent of any bookmarking) and thread ignoring are permanently broken, or is the fix still being investigated?

RedKazan
Apr 4, 2003



killer ninjas posted:

I can't remember. . . did we ever determine that thread starring (independent of any bookmarking) and thread ignoring are permanently broken, or is the fix still being investigated?

Thread starring works for the most part, it's just not very well interfaced and, for the most part, redundant (except for being able to star archived threads). Thread ignoring is broken, but not permanently. I haven't really looked at it much, I had other things I was working on.

Edit: Actually thread ignoring works fine for me. I don't really use it at all so I don't know if there are certain situations that break it, maybe someone that does use it can tell us what's going wrong.

RedKazan fucked around with this message at Dec 29, 2007 around 19:13

Revolvyerom
Nov 12, 2005

Hell yes, tell him we're plenty front right now.

I use thread ignore every now and then, and it's always worked for me, for what it's worth. And I'm the guy who can't seem to get anything to work right

Carnivean
Feb 14, 2004

by Peatpot


RedKazan posted:

Edit: Actually thread ignoring works fine for me. I don't really use it at all so I don't know if there are certain situations that break it, maybe someone that does use it can tell us what's going wrong.

If I read a thread I can't ignore it. Even if I unread it via the button, then refresh and then ignore it. Admittedly I haven't tested this on the latest version, but most recent versions have had the same problems.

Funking Giblet
Jun 28, 2004

Jiglightful!

Any chance of a right click forum navigator ala Goonmenu being added?

RedKazan
Apr 4, 2003



Carnivean posted:

If I read a thread I can't ignore it. Even if I unread it via the button, then refresh and then ignore it. Admittedly I haven't tested this on the latest version, but most recent versions have had the same problems.
Interesting! Fixed, thanks. This is why I rely on user reports, I don't use half of this stuff myself.

Revolvyerom
Nov 12, 2005

Hell yes, tell him we're plenty front right now.

Edit: nevermind

killer ninjas
Mar 9, 2005


Revolvyerom posted:

I use thread ignore every now and then, and it's always worked for me, for what it's worth.

I can ignore a thread and it immediately disappears from the forum index page (as it used to do).

But as soon as I refresh the page, THERE'S the ignored thread staring back at me. Plain as day.


So yes, still broken for me.




ETA: OKAY! I just figured out how to get the code to work. . . for ME anyhow:

* Apparently, I first open the thread to be ignored, and choose "Ignore this thread" from the SALR rightclick context menu.

* Second, I return to the index page and again select "Ignore this thread" from the SALR rightclick context menu, I can get the thread to permanently be ignored and remove itself completely from the index page.


Whew! That's a lot of work, having to DOUBLE the ignoring process to get it to function.

But hopefully it should give you developers somewhere to start with.





Carnivean posted:

If I read a thread I can't ignore it. Even if I unread it via the button, then refresh and then ignore it.
Strangly, I just noticed this process works for me. I can't ignore read threads. But if I mark it UNREAD, ignoring the thread works as usual.

Weird. Just weird.

killer ninjas fucked around with this message at Dec 31, 2007 around 09:04

Carnivean
Feb 14, 2004

by Peatpot


killer ninjas posted:

Strangly, I just noticed this process works for me. I can't ignore read threads. But if I mark it UNREAD, ignoring the thread works as usual.

Weird. Just weird.

Refresh and you'll probably find that it has unignored itself.

killer ninjas
Mar 9, 2005


Carnivean posted:

Refresh and you'll probably find that it has unignored itself.

Nope, surprisingly the second method is working for me. Unread threads will stay ignored.

RedKazan
Apr 4, 2003



killer ninjas posted:



Any problems you're having with ignore may have already been fixed, there was a bit of code in the ignoring function that shouldn't have been there and it may have been doing more than preventing you from ignoring threads you have read.

To find out for yourself, download this and this from the repository and replace them on your computer (just search for them).

Combat Pretzel
Jun 23, 2004

No, seriously... what kurds?!

Not sure what SALR is doing with the thread list of a (sub)forum, but what it does brings the rendering in Firefox 3b2 in its knees. Any highlighting in threads themselves doesn't decimate rendering speeds though.

What I have activated is simply thread highlighting.

--edit: It appears the culprit is the forum navigator, that bogs down everything. The page navigator in threads has also a slight degrading effect, but it's barely noticable (only if you're sensitive to frame rates).

Combat Pretzel fucked around with this message at Dec 31, 2007 around 20:34

biznatchio
Mar 31, 2001



Buglord

Toiletbrush posted:

--edit: It appears the culprit is the forum navigator, that bogs down everything. The page navigator in threads has also a slight degrading effect, but it's barely noticable (only if you're sensitive to frame rates).

I've noticed Firefox 3 seems a lot slower in general if there are fixed-position elements on the page. It's a pretty crap regression.

Tagra
Apr 7, 2006

If you gaze long into an abyss, the abyss will gaze back into you.



My OP highlighting isn't working, and actually hasn't for awhile now. Mods and Admins work just fine but never the OP. I checked that it's all enabled in options, and it all seems to be in order. Since I see screenshots on this very page with "thread poster" highlighting appearing to be functional, I must assume this is some problem on my end... everything else in SALR seems to be working just fine though and I haven't received any error messages anywhere.

Using 1.99.071227. I've been letting it update manually but I just updated it through the link in the OP just to make sure.

Firefox 2.0.0.11

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


Tagra posted:

My OP highlighting isn't working, and actually hasn't for awhile now. Mods and Admins work just fine but never the OP. I checked that it's all enabled in options, and it all seems to be in order. Since I see screenshots on this very page with "thread poster" highlighting appearing to be functional, I must assume this is some problem on my end... everything else in SALR seems to be working just fine though and I haven't received any error messages anywhere.

Using 1.99.071227. I've been letting it update manually but I just updated it through the link in the OP just to make sure.

Firefox 2.0.0.11

It's enabled in the forums as well? If you disable SALR, is the OP labeled?

edit:test

duz fucked around with this message at Jan 16, 2008 around 23:58

Tagra
Apr 7, 2006

If you gaze long into an abyss, the abyss will gaze back into you.



duz posted:

It's enabled in the forums as well? If you disable SALR, is the OP labeled?

Holy poo poo, that got incorporated into the forums too?

Well I feel stupid now. It's working! Thank you.

PovRayMan
Dec 25, 2002

Never get Freudian on a man holding a pickle.

1.99.071227 on 2.0.0.11

Ever since the latest update was pushed I haven't been able to hold right click to access the prev/next options or even see the lower right corner navigator. As far as I understand both options are enabled with checks next to them.

Shredder
Sep 14, 2000



Just bumping this because I had to go back a whopping 6 pages to find this and search sucks balls.

Why isn't this stickied anyway?

Aratoeldar
Mar 21, 2005


Shredder posted:

Just bumping this because I had to go back a whopping 6 pages to find this and search sucks balls.

Why isn't this stickied anyway?

It's called using your forum bookmarks. Shock! Surprise! Gasp!

Adbot
ADBOT LOVES YOU

zeldadude
Nov 24, 2004

OH SNAP!


I keep doing quick edit but it makes a new post. Is this a bug or am I just going crazy? Actually I know I'm not going crazy because I took a screenshot of the edit window before I posted it and it STILL made a new post.

  • Locked thread
«98 »