Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«98 »
  • Locked thread
pik_d
Feb 24, 2006

follow the white dove



I'm not sure why you guys keep trying to delete stuff to fix it. It'll come back on it's own when the forum links are in the drop down menu at the bottom of the page. It make take a few refreshes, or even closing and restarting Firefox, but I've had it come back in my SA menu whenever it was back in the drop down menu on the forums.

Yes it sucks, but just ride it out, duz said he's fix it in the next update and then we'll (hopefully) never have to worry about it again.

Adbot
ADBOT LOVES YOU

JingleBells
Jan 7, 2007

Oh what fun it is to see the Harriers win away!


duz posted:

It's because they keep disappearing from the dropdown at the bottom of the page. I'll try to come up with something better.

Would it not be possible to get the forums list off the main forums home page?
So if the user wants an updated forums list they just have to visit the main page, or would that take too much time/resources?

From what I can see the hierarchy is kept via classnames so you could theoretically build the forums tree off the set of .category, .forum and .subforum classes, or am I barking up the wrong tree?

grrowl
Jan 17, 2007

I LOVE 4CHAN YIFF YIFF YIFF

JingleBells posted:

Would it not be possible to get the forums list off the main forums home page?
So if the user wants an updated forums list they just have to visit the main page, or would that take too much time/resources?

From what I can see the hierarchy is kept via classnames so you could theoretically build the forums tree off the set of .category, .forum and .subforum classes, or am I barking up the wrong tree?

yeah i'm thinking along the same lines, and was going to code up a prototype for this tomorrow if duz doesn't get around to it... the forums home works like this
code:
<th class="category">category</th><td><a class="forum">main forum link</a> <div class="subforums"><a>subforum</a><a>subforum</a></div></td>
I suppose it wouldn't be too hard to parse, it would be easier if they did it a little more consistently

edit: basically i think we split it up by categories then parse out all the forums and subs from there I guess. i don't think there's an easier way to step through pages in javascript?

grrowl fucked around with this message at Jul 25, 2008 around 09:44

edgeman83
Jul 13, 2003


I believe the problem is, though, that the plugin can't access pages that the user hasn't already accessed, probably by some agreement with the SA admins. So, I suppose the parsing the forum's home page would be fine if it was done only when the user visits that page.

Hmmm, that would had some hassle to the using it, but then the user could choose when to update the menu listings. How often do the forum's urls change, anyway?

Son of Sam-I-Am
Feb 12, 2002


pik_d posted:

I'm not sure why you guys keep trying to delete stuff to fix it. It'll come back on it's own when the forum links are in the drop down menu at the bottom of the page. It make take a few refreshes, or even closing and restarting Firefox, but I've had it come back in my SA menu whenever it was back in the drop down menu on the forums.

Yes it sucks, but just ride it out, duz said he's fix it in the next update and then we'll (hopefully) never have to worry about it again.

I don't know if anyone is deleting anything to fix it, all I meant was the extension deletes everything in the menu when the forums dropdown isn't working. Sorry for my poor phrasing.

Volte
Oct 4, 2004

woosh woosh

Muldoon

The forums home doesn't show all subforums, just the first level. The only other place I can see that maintains a full forum list is the Posting Gloryhole "per forum" stats page. If it can't be automatically requested, at least it could be manually visited in a pinch. Of course, it would also have to be made not to delete itself if the quickjump list was empty.

biznatchio
Mar 31, 2001



Buglord

Crotch Bat posted:

This has been an unholy pain in the rear end. Not bitching at you biz, take your time and whatnot, this is just loving frustrating.

Well certainly don't bitch at me. I haven't been active in SALR development for quite a while now due to lack of free time.

grrowl
Jan 17, 2007

I LOVE 4CHAN YIFF YIFF YIFF

Volte posted:

The forums home doesn't show all subforums, just the first level. The only other place I can see that maintains a full forum list is the Posting Gloryhole "per forum" stats page. If it can't be automatically requested, at least it could be manually visited in a pinch. Of course, it would also have to be made not to delete itself if the quickjump list was empty.

Oh snap, I didn't realise that. I suppose the admins shouldn't have a problem with us adding a "Refresh forum listing" item in the SALR menu, which loads the gloryhole in the background and updates it. To be honest i'm not really sure how that kind of thing gets achieved in firefox since most of the code seems to load in-page, and the actual code that makes the SA menu work confuses and frightens me. Hopefully duz gets around to it soon.

In tangentially related news, I spent 20 minutes coding this greasemonkey script that might emulate the goon stickits plugin that I have never used, so give it a shot if you like, bugs and feedback welcome: http://userscripts.org/scripts/show/30559

Chamberpothead
Nov 6, 2005



In the meantime, people really cheesed off by it might try simply locking saforumlist.xml until there's an SALR update, maybe?

e: No, don't. It seems to break too many things.

Chamberpothead fucked around with this message at Jul 25, 2008 around 18:29

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


Groggie posted:

Yeah I knew that, but the thing that doesn't really work for me is that the note goes under their username in bold, so it can't be anything lengthy like "Owner of https://www.blahblahblah.com website" or something like that.

What if it cut off after a certain amount of letters and you'd have to click it to see the rest? That way you can have your long notes without it spilling all over the screen.

grrowl posted:

Oh snap, I didn't realise that. I suppose the admins shouldn't have a problem with us adding a "Refresh forum listing" item in the SALR menu, which loads the gloryhole in the background and updates it. To be honest i'm not really sure how that kind of thing gets achieved in firefox since most of the code seems to load in-page, and the actual code that makes the SA menu work confuses and frightens me. Hopefully duz gets around to it soon.

It scares me too. I'll have to figure something out.

Xenomrph
Dec 9, 2005

AvP Nerd/Fanboy/Shill


For some reason, when I reply to threads, the SALR reply box pops up and I can type out my post and everything, but the actual "Submit" button is greyed out sometimes. This has been happening intermittently since I uninstalled SALR and reinstalled it using the build in the first sentence of the OP (the 0623 build, I think it was). Any thoughts?

Anarcho-Commissar
May 22, 2002

"The means of production being the collective work of humanity, the product should be the collective property of the race. Individual appropriation is neither just nor serviceable. All belongs to all."
- Pyotr Kropotkin



Xenomrph posted:

For some reason, when I reply to threads, the SALR reply box pops up and I can type out my post and everything, but the actual "Submit" button is greyed out sometimes. This has been happening intermittently since I uninstalled SALR and reinstalled it using the build in the first sentence of the OP (the 0623 build, I think it was). Any thoughts?

Similarly, I have to hit "Submit" twice to actually get it to work.


(Formerly Colonial Air Force)

grrowl
Jan 17, 2007

I LOVE 4CHAN YIFF YIFF YIFF

Xenomrph posted:

For some reason, when I reply to threads, the SALR reply box pops up and I can type out my post and everything, but the actual "Submit" button is greyed out sometimes. This has been happening intermittently since I uninstalled SALR and reinstalled it using the build in the first sentence of the OP (the 0623 build, I think it was). Any thoughts?

Are you sure you're not navigating on your forum page? When you click the 'reply' button, you can't change the page you're replying to or it'll grey out the button and change the text to "Detatched (S)".

Commissar posted:

Similarly, I have to hit "Submit" twice to actually get it to work.

known FF3 bug, i think you can get around it by submitting with alt+s, which is quicker once you get into the hang of it anyway

Zorilla
Mar 23, 2005

GOING APE SPIT

grrowl posted:

known FF3 bug, i think you can get around it by submitting with alt+s, which is quicker once you get into the hang of it anyway

The bug applies to keyboard shortcuts as well. My muscle memory is already used to it, so hopefully, this doesn't mean a bunch of double posts when it gets fixed.

Biaxident
Sep 4, 2003

GLOCK: Explosive Firepower!


grrowl posted:

known FF3 bug, i think you can get around it by submitting with alt+s, which is quicker once you get into the hang of it anyway

I have to click submit twice on FF2. What now, mister mattress man?

Zorilla
Mar 23, 2005

GOING APE SPIT

Biaxident posted:

I have to click submit twice on FF2. What now, mister mattress man?

Maybe a minor revision to the 2.0.0.x tree carried the bug over from 3? I dunno.

grrowl
Jan 17, 2007

I LOVE 4CHAN YIFF YIFF YIFF

Well poo poo, now I just look like an idiot

Zorilla on page 38 or something posted:

Yeah, I think this is happening to buttons totally unrelated to SALR as well. Hopefully this means there's nothing wrong on this end and an update to Firefox 3 will fix it.

this was my source! I looked around on the bugzilla but didn't run into anything so I don't even know if it has been pinned down by the mozilla crew.

grrowl
Jan 17, 2007

I LOVE 4CHAN YIFF YIFF YIFF

gently caress totally wrong thread

grrowl fucked around with this message at Jul 27, 2008 around 13:28

Munkaboo
Aug 4, 2002

If you know the words, you can join in too
He's bigger! faster! stronger too!
He's the newest member of the Jags O-Line crew!


What do you have to do to get the SA quickmenu back? All the subforums and pinned forums disappeared.

Son of Sam-I-Am
Feb 12, 2002


Munkaboo posted:

What do you have to do to get the SA quickmenu back? All the subforums and pinned forums disappeared.

Wait until the forumside dropdown returns.

Hung Yuri
Aug 29, 2007



Somehow the quickmenu just fixed itself? I didn't even close my browser

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


Gvaz posted:

Somehow the quickmenu just fixed itself? I didn't even close my browser

It randomly checks for the drop down and builds the menu when it sees it. I need to hurry up and finish working on the new version.

d[-.-]b
Aug 1, 2004

my fav champ that hero who cats a spell that make all bad guy fall down and say my dick BIG


Feature request: Option to remove all spoiler tags in a certain thread and/or subforum. I hate using the mouse when I'm reading a thread, so hovering over spoilers is a major pain. If I already saw The Dark Knight, it would be cool if I could just read the thread without having to do that. Not sure how it would work or even if it could, but I'd sure appreciate it.

m2pt5
May 18, 2005

THAT GOD DAMN MOSQUITO JUST KEEPS COMING BACK


d[-.-]b posted:

Feature request: Option to remove all spoiler tags in a certain thread and/or subforum. I hate using the mouse when I'm reading a thread, so hovering over spoilers is a major pain. If I already saw The Dark Knight, it would be cool if I could just read the thread without having to do that. Not sure how it would work or even if it could, but I'd sure appreciate it.

Workaround: Take the contents of this text file and paste it into a bookmark. When on any SA page with spoilers, activating that bookmark will light up all the spoiler tags until you mouse over them again.

pik_d
Feb 24, 2006

follow the white dove



Alternatively, press Ctrl+A.

It works!

d[-.-]b
Aug 1, 2004

my fav champ that hero who cats a spell that make all bad guy fall down and say my dick BIG


m2pt5 posted:

Workaround: Take the contents of this text file and paste it into a bookmark. When on any SA page with spoilers, activating that bookmark will light up all the spoiler tags until you mouse over them again.

Hey, that's pretty cool. Thanks.

pik_d posted:

Alternatively, press Ctrl+A.

It works!

I hate reading in those colors.

Codiusprime
Mar 17, 2006


Nevermind

Codiusprime fucked around with this message at Jul 29, 2008 around 00:15

mobn
May 23, 2005

by Ozmaugh


duz posted:

It randomly checks for the drop down and builds the menu when it sees it. I need to hurry up and finish working on the new version.

Mine disappeared for three days recently despite multiple browser closings and forums reloadings. It finally reappeared this morning.

ClydeUmney
May 13, 2004

One can hardly ignore the Taoist implications of "Fuck it, Dude. Let's go bowling."



Is there any chance at some point of fixing the quick reply window so that applying vB code doesn't result in your cursor being thrown back to the top of the page again? It's fairly frustrating, because I tend to type my post then format it, and it gets old trying to scroll through everything again. If it's a limitation of Firefox, no biggie.

Also, I asked at some point about adding [list] functionality to the quick preview window - is that doable at all?

Aratoeldar
Mar 21, 2005


I don't know if it is something I am doing wrong or something else. I do not have a smile list with the reply box anymore.

grrowl
Jan 17, 2007

I LOVE 4CHAN YIFF YIFF YIFF

ClydeUmney posted:

Is there any chance at some point of fixing the quick reply window so that applying vB code doesn't result in your cursor being thrown back to the top of the page again? It's fairly frustrating, because I tend to type my post then format it, and it gets old trying to scroll through everything again. If it's a limitation of Firefox, no biggie.

Also, I asked at some point about adding [list] functionality to the quick preview window - is that doable at all?

That's really odd, I was sure I fixed that when i updated the code for it. It doesn't happen if you have text selected so that's the workaround. Also i'm not sure if anyone realises this but you can use hotkeys to add vb code to the window: ctrl+b for bold, ctrl+i for italics, ctrl+s for strikethroughs, etc.

I'll get on to fixing this silly cursor bug soon.

Crash
Mar 29, 2003


grrowl posted:

Also i'm not sure if anyone realises this but you can use hotkeys to add vb code to the window: ctrl+b for bold, ctrl+i for italics, ctrl+s for strikethroughs, etc.


Wow, never knew about this handy feature! Also, I'm not getting this cursor bug. (FF3.0.1 with latest SALR)

grrowl
Jan 17, 2007

I LOVE 4CHAN YIFF YIFF YIFF

Crash posted:

Wow, never knew about this handy feature! Also, I'm not getting this cursor bug. (FF3.0.1 with latest SALR)

yeah, I only coded it in during the last month or so, along with nested quotes in the live preview. To replicate, type a bunch of text or whatever, put the caret in the middle of the text, and invoke any of the vB commands. The code will insert in the right place, but the caret will move to the end of the line. (which isn't the top of the page, i assume is was a mis-type).

My own replication is FF 3.0.1 on XP but theoretically it should be the same for all platforms. Selection code in javascript is a bastard.

edit: also, ctrl+[plus] is superscript, ctrl+[minus] is subscript, ctrl+u is underline, ctrl+p is spoiler, amd ctrl+f is fixed-width.

grrowl fucked around with this message at Jul 31, 2008 around 15:57

Disgustipated
Jul 28, 2003

Black metal ist krieg

Wow that's a pretty neat feature.

pik_d
Feb 24, 2006

follow the white dove



I really like the feature where if you post in a thread the reply count box is yellow, but it seems to be really messed up. I just posted in a thread, then went back to the thread listing and the box was yellow. I noticed that in the time it took me to get from just having posted to going to the thread listing there had been another reply, so I went back to see it. After revisiting the thread I went back to the thread listing, and the reply count box wasn't yellow anymore.

I've had issues before with the yellow disappearing, but never that fast. I could understand it if it goes away in a week or so due to being cycled out for lack of space to remember all the thread ID's or something, but that just seemed ridiculous to have it go away in less than a minute.

How many other people have had issues with the yellow going away? Has anyone been able to tell what kind of behavior kills it?

Duz, I'm sorry that I've brought up so much stuff (I think I have the most posts of a non-SALR developer here), but it's simply because I like SALR so much.

Edit: Woah wait I am confused. I went to the configure SALR thing, and it tells me that the yellow is for visited threads with new replies, however I have some threads (this one for example) that seem to stay yellow even when there are no new replies. What is the yellow really for then?

pik_d fucked around with this message at Aug 4, 2008 around 06:06

Aratoeldar
Mar 21, 2005


pik_d posted:

What is the yellow really for then?

It is supposed to be for threads that you have posted in. It should only be in the reply number box. It has never worked for me since they fixed it.

Aratoeldar fucked around with this message at Aug 4, 2008 around 14:12

jess
May 26, 2005

you fit into me
like a hook into an eye

a fish hook
an open eye

Yeah, it's stopped working for me too. It shows up for a little bit, but disappears.

Crop Top Skank
Apr 4, 2007



I've never seen the yellow. I even made sure the SALR setting had the right name for me and everything

brc64
Mar 21, 2008

I wear my sunglasses at night.

snide posted:

I've never seen the yellow. I even made sure the SALR setting had the right name for me and everything
It's kind of random for me. It only ever appears in threads I've posted in (which is correct), but it's inconsistent on which ones I've posted in that it highlights. There might be 5 threads on a page I've posted in, but only 2 will be highlighted. I figure it's tracking the highlight info locally rather than keying off of some forum-tracked value, which might explain the discrepancy (it wouldn't know about threads I posted in before the feature went live, nor would it know about ones I've posted in from home when I'm at work).

I pretty much just ignore the highlighting. Cool feature, but limited functionality for me.

Adbot
ADBOT LOVES YOU

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


Yeah, it's acting screwy. At least it's sort of working at all, it wasn't working for the longest time. I'm trying to get an update out this week that'll fix it and stop the menu from disappearing and adding more keyboard navigation.

  • Locked thread
«98 »