Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«98 »
  • Locked thread
ATwoSlotToaster
Nov 6, 2004

You're toast!

Just wondering if there will be an update for Firefox 3.6 in the mix or should I contemplate downgrading to use SALR again. Keep up the great work!

Adbot
ADBOT LOVES YOU

Alereon
Feb 6, 2004

Dehumanize yourself and face to Trumpshed

College Slice

ATwoSlotToaster posted:

Just wondering if there will be an update for Firefox 3.6 in the mix or should I contemplate downgrading to use SALR again. Keep up the great work!
It's been supported for awhile, you need to download SALR from the link in the first post in this thread

ATwoSlotToaster
Nov 6, 2004

You're toast!

Alereon posted:

It's been supported for awhile, you need to download SALR from the link in the first post in this thread

Oh ok, I've just been trying to 'find updates' through the addon menu in Firefox, I didn't realize I could re-download the entire thing. Thanks!

The Werle
Aug 8, 2005

Fireworks for Christmas is absolutely American


Firefox 3.6 killed my baby! But it got better.

Whats involved in making your add-on auto-update versus having to do it manual? Just whether mozilla will host your files?

astral
Apr 26, 2004

Out there.


The Werle posted:

Firefox 3.6 killed my baby! But it got better.

Whats involved in making your add-on auto-update versus having to do it manual? Just whether mozilla will host your files?

From the previous page,

astral posted:

Note that the auto-update probably won't work since bountysource's security certificate expired, but you should be able to manually download/install it.

There's also a way to self-sign it so it wouldn't require a secure connection, but it requires more looking-into and it might not even (easily) work with the way we have things set up for SALR.

astral fucked around with this message at Mar 13, 2010 around 18:47

HEY MAN TV ON PC
Jul 14, 2009


Whenever I try to view a thread from the FYAD goldmine, I think something in the forum style conflicts with SALR. Firefox always drops down a message that says this, with an "OK" button at the bottom:

[JavaScript Application]
SALastRead application err: message: userNameBox is null
fileName: chrome://browser/content/browser.xul -> chrome://salastread/content/salastreadOverlay.js
lineNumber: 1232
stack: handleShowThread([object XPCSafeJSObjectWrapper])@chrome://browser/content/browser.xul -> chrome://salastread/content/salastreadOverlay.js:1232
SALR_onLoad([object Event])@chrome://browser/content/browser.xul -> chrome://salastread/content/salastreadOverlay.js:226

name: TypeError

astral
Apr 26, 2004

Out there.


HEY MAN TV ON PC posted:

Whenever I try to view a thread from the FYAD goldmine, I think something in the forum style conflicts with SALR. Firefox always drops down a message that says this, with an "OK" button at the bottom:

[JavaScript Application]
SALastRead application err: message: userNameBox is null
fileName: chrome://browser/content/browser.xul -> chrome://salastread/content/salastreadOverlay.js
lineNumber: 1232
stack: handleShowThread([object XPCSafeJSObjectWrapper])@chrome://browser/content/browser.xul -> chrome://salastread/content/salastreadOverlay.js:1232
SALR_onLoad([object Event])@chrome://browser/content/browser.xul -> chrome://salastread/content/salastreadOverlay.js:226

name: TypeError

Just to confirm, you're getting that error while trying to view any threads in this forum? What versions of SALR (snag this info from the addons window) and Firefox are you using?

On a most-likely-unrelated note, I do see some issues with hiding/showing avatars that I could take a look at later.

HEY MAN TV ON PC
Jul 14, 2009


astral posted:

Just to confirm, you're getting that error while trying to view any threads in this forum? What versions of SALR (snag this info from the addons window) and Firefox are you using?

On a most-likely-unrelated note, I do see some issues with hiding/showing avatars that I could take a look at later.

I'm only getting it for archived threads that are from 2008 or older.
This one triggers it: http://forums.somethingawful.com/sh...hreadid=1545943
In fact, the show/hide avatar button doesn't even appear under usernames. Neither do the Ban History and Add Coloring/Note links. The blue pagenav stuff is still in the lower right, though.

astral
Apr 26, 2004

Out there.


HEY MAN TV ON PC posted:

I'm only getting it for archived threads that are from 2008 or older.
This one triggers it: http://forums.somethingawful.com/sh...hreadid=1545943
In fact, the show/hide avatar button doesn't even appear under usernames. Neither do the Ban History and Add Coloring/Note links. The blue pagenav stuff is still in the lower right, though.

Please provide your SALR and browser versions.

HEY MAN TV ON PC
Jul 14, 2009


astral posted:

Please provide your SALR and browser versions.

Right. Firefox 3.6, SALR v 1.99.100116... mac os 10.5.8, if that makes a difference.

astral
Apr 26, 2004

Out there.


HEY MAN TV ON PC posted:

Right. Firefox 3.6, SALR v 1.99.100116... mac os 10.5.8, if that makes a difference.

Thanks. I'll look into this when I have some free time; I don't have a mac to test with (and I don't get the JS error on windows/ff3.6) but I should be able to see what's going wrong.

Schrute Nation
May 29, 2007
Ha,Ha...Thought you could keep me out didja?

I've been having issues with SALR for a long time now and figured that the problem would solve itself but it hasn't. It started during the last update (I think) and I've noticed that few people had a problem in the last page, but I could not fix it. I'm using the latest version of FireFox and got the addon from the link in the OP.

Here is what the debugger popup says:
  • SALastRead application err: code: 8
  • INDEX_SIZE_ERR: 1
  • DOMSTRING_SIZE_ERR: 2
  • HIERARCHY_REQUEST_ERR: 3
  • WRONG_DOCUMENT_ERR: 4
  • INVALID_CHARACTER_ERR: 5
  • NO_DATA_ALLOWED_ERR: 6
  • NO_MODIFICATION_ALLOWED_ERR: 7
  • NOT_FOUND_ERR: 8
  • NOT_SUPPORTED_ERR: 9
  • INUSE_ATTRIBUTE_ERR: 10
  • INVALID_STATE_ERR: 11
  • SYNTAX_ERR: 12
  • INVALID_MODIFICATION_ERR: 13
  • NAMESPACE_ERR: 14
  • INVALID_ACCESS_ERR: 15
  • VALIDATION_ERR: 16
  • TYPE_MISMATCH_ERR: 17
  • message: Node was not found
  • result: 2152923144
  • name: NS_ERROR_DOM_NOT_FOUND_ERR
  • filename: chrome://browser/content/browser.xul -> chrome://salastread/content/salastreadOverlay.js
  • lineNumber: 3025
  • columnNumber: 0
  • location: JS frame :: chrome://browser/content/browser.xul -> chrome://salastread/content/salastreadOverlay.js :: SALR_buildForumMenu :: line 3025
  • inner: null
  • data: null

I hope this helps.

EDIT: To be more descriptive many functions (Thread navigator, submenu, and quick edit and keyboard shortcuts) have been disabled. However, I've got a few functions that still work (Configure SALR option) for example. I was re-anchoring a thread when the initial error pop-up appeared.

Schrute Nation fucked around with this message at Apr 4, 2010 around 02:51

Revolvyerom
Nov 12, 2005

Hell yes, tell him we're plenty front right now.

SALR Version: 1.99.100116
Firefox Version: 3.6
Windows 7 x64

Something I'd noticed for some time (months), but hadn't thought to mention. The drop-down menus for page numbers in the bottom left corner extend down, rather than up, for me. Obviously this means I can choose page 1, 2, and anything else is off-screen.

Sonic Dude
May 6, 2009


astral posted:

Thanks. I'll look into this when I have some free time; I don't have a mac to test with (and I don't get the JS error on windows/ff3.6) but I should be able to see what's going wrong.
Same SALR version, same Firefox version, Mac OS 10.6.2
I don't get a JavaScript error in the example thread, but the under-post extra links are gone.

There were a bunch of Java updates for 10.5.x. I wonder if that's the cause of the JS error. Have you run those, HEY MAN TV ON PC?

Alereon
Feb 6, 2004

Dehumanize yourself and face to Trumpshed

College Slice

Java and JavaScript are different things, JavaScript is part of your web browser and doesn't get updated. I wonder if some of you guys that are having issues have stored profile data from old versions of SALR that is causing problems? Try creating a new Firefox profile and see if your issues go away. Also make sure "Don't display error popups" is checked under Debugging Info on the General tab of SALR Configuration.

If a new profile fixes the problem, you can copy the places.sqlite and cookies.sqlite files from the old profile and that should keep your bookmarks, history, and cookies.

astral
Apr 26, 2004

Out there.


Alereon posted:

make sure "Don't display error popups" is checked under Debugging Info on the General tab of SALR Configuration.

No wonder I didn't see it; I totally forgot I had that option checked, thanks. I'll have some time to fix it this coming weekend.

When I do that, I'll also commit the code for the bookmark-coloring stuff I talked about a page or so back (if you're interested, it'd be the chart I posted here). I actually got that working a while back, but got sidetracked with another project which I'll eventually get around to finishing (a different way of handling the dynamic CSS stuff). I do have to say, though, that it's pretty nice being able to have certain bookmarked threads stand out if there are new posts:



Edit: added image

astral fucked around with this message at Mar 24, 2010 around 19:09

Ak Gara
Jul 29, 2005

That's just the way he rolls.

Hi, I recently upgraded from Firefox 2 to Firefox 3 (youtube kept bugging me) and now I can't seem to find the bookmark button at the bottom of threads. (SALR is still awesome though, keep up the hard work!)

Firefox 3.6.2
SALR 1.99.100116
XPSP2.

Also, it's probably not SALR related, but why can't I see images in posts that are made using [/TIMG] tags?

Ak Gara fucked around with this message at Mar 25, 2010 around 18:56

ryanbruce
May 1, 2002

The "Dell Dude"


Upgrade to XP SP3 and get all the other Windows Updates available. There is pretty much no reason to be running SP2 any longer.

As for the other issues, I'm not really sure. I'm running the same builds you are and don't have the issue.. Are you running NoScript or any other similar script blocking addons?

Ak Gara
Jul 29, 2005

That's just the way he rolls.

Huh, weird. After changing Theme, and back again, the bookmark button is there. Maybe unrelated... SALR seems to be running fine now.

HEY MAN TV ON PC
Jul 14, 2009


Okay, I was on vacation for about a week - I downloaded the latest version, but it's showing up as 1.99.100116 instead of 1.99.090126. Anyway, I set my forum-side preferences to what's shown in the OP, but I still get the error popup in the example thread I linked. For now I'm gonna shut off the popups, as it was just getting obnoxious when browsing old threads, and I don't really care about the missing ban history/coloring/etc. links.
Thanks all

astral
Apr 26, 2004

Out there.


HEY MAN TV ON PC posted:

Okay, I was on vacation for about a week - I downloaded the latest version, but it's showing up as 1.99.100116 instead of 1.99.090126. Anyway, I set my forum-side preferences to what's shown in the OP, but I still get the error popup in the example thread I linked. For now I'm gonna shut off the popups, as it was just getting obnoxious when browsing old threads, and I don't really care about the missing ban history/coloring/etc. links.
Thanks all

1.99.100116 is the latest SALR version. I finally had the time to look into this problem - it appears that SALR's archives handling needs a bit of an overhaul. I'm working on it now.

Slightly related, but since FYAD threads in the archives seem to use the standard template instead of the FYAD template, should we still have SALR color the post backgrounds in with the FYAD colors, or should we drop back to the standard post coloring?

HEY MAN TV ON PC
Jul 14, 2009


astral posted:

should we still have SALR color the post backgrounds in with the FYAD colors, or should we drop back to the standard post coloring?

I like the FYAD colors, mainly because otherwise I get briefly confused by the discrepancy between the page appearance and posting style.

astral
Apr 26, 2004

Out there.


Update! v1.99.100326 (this build is NOT up on addons.mozilla, so don't try to get it there!)

And in more good news, auto-updating is working again since bountysource renewed their certificate!

Changes:
  • Bookmark color support! SALR now respects the red and yellow stars you can set your bookmarked threads to. Completely-read bookmarked threads will still show up as blue (or whatever you have set for your 'Visited thread with no new posts'). Red and yellow starred threads with new posts will show up as their respective colors.
  • Fixed SALR not playing nicely with archived FYAD threads.

astral fucked around with this message at Mar 27, 2010 around 06:26

fishmech
Jul 16, 2006

~death to capitalism~
Upgrade your OS



Salad Prong

astral posted:

Note that the auto-update won't work

Bullshit! Firefox popped up a window when I started it up just now that told me an update was available for SALR and it just installed!

astral
Apr 26, 2004

Out there.


fishmech posted:

Bullshit! Firefox popped up a window when I started it up just now that told me an update was available for SALR and it just installed!

Oh-ho! It would seem they renewed their certificate 13 days ago.

power crystals
Jun 6, 2007

Who wants a belly rub??

Top Cop

Since this update whenever I "un-read" a thread or whatever hitting the red X button in the thread list is called, if there's posts I haven't read the background color does not disappear (so it's still greenish, if that's even still the default). If there are no unread posts it does work correctly. Refreshing fixes it, so it's not really a problem, but hey it's a bug.

astral
Apr 26, 2004

Out there.


power crystals posted:

Since this update whenever I "un-read" a thread or whatever hitting the red X button in the thread list is called, if there's posts I haven't read the background color does not disappear (so it's still greenish, if that's even still the default). If there are no unread posts it does work correctly. Refreshing fixes it, so it's not really a problem, but hey it's a bug.

Working on it, thanks.

The next update will fix the "Search Forums" link in the SALR menu, too.

sildenafil
Dec 17, 2004

They're just jealous.


astral posted:

The next update will fix the "Search Forums" link in the SALR menu, too.

Looking forward to it, thanks for all the hard work astral.

astral
Apr 26, 2004

Out there.


Update! v1.99.100328 (this build is NOT up on addons.mozilla, so don't try to get it there!)

Changes:
  • Made 'search' link in the SALR menu point to the new search.
  • Fixed a CSS problem where the wrong color would be displayed when forgetting about a thread that still had some unread posts
  • Added avatar hide/show support for forums with the FYAD template
  • Stopped the Firefox right-click menu from showing up when right-clicking SALR menu links

power crystals
Jun 6, 2007

Who wants a belly rub??

Top Cop

Well that was fast and it seems fixed to me so thanks!

astral
Apr 26, 2004

Out there.


The next update will add [video] tag support for quick replies as well as support for the forums-based preview of a post edit (which is new in SAVB-2.0.12d) from the quick edit window.

astral fucked around with this message at Mar 31, 2010 around 19:56

astral
Apr 26, 2004

Out there.


Update! v1.99.100329 (this build is NOT up on addons.mozilla, so don't try to get it there!)

Changes:
  • Added video tag support for quick post
  • Enabled "Preview" button in quick edit window for the forum-based edit post preview

HEY MAN TV ON PC
Jul 14, 2009


astral posted:

Update!

Whoa, fast update! How long has SALR had live preview? Great feature; I'll definitely be using it a lot.

frozenphil
Mar 13, 2003

YOU CANNOT MAKE A MISTAKE SO BIG THAT 80 GRIT CAN'T FIX IT!


astral posted:

Update! v1.99.100329 (this build is NOT up on addons.mozilla, so don't try to get it there!)

Changes:
  • Added video tag support for quick post
  • Enabled "Preview" button in quick edit window for the forum-based edit post preview

It auto-updated for me.

Is there a reason that using ctrl + b to put bold tags in a post doesn't work when I am in the advanced reply window and instead opens my bookmarks sidebar? It works fine when I use the quick reply window or use any other ctrl combo (like for italics or underline).

Do I just need to change the bookmark sidebar hotkey in Firefox? This is a recent thing, like a few SALR updates ago.

astral
Apr 26, 2004

Out there.


HEY MAN TV ON PC posted:

Whoa, fast update! How long has SALR had live preview? Great feature; I'll definitely be using it a lot.

Long enough that I don't remember when it didn't; it's one of my favorite features.

frozenphil posted:

It auto-updated for me.

That comment is saying more that if you download the version from addons.mozilla.org, it isn't going to be the latest version and you'd still have to update from it (so you might as well grab it straight from the bountysource link).

frozenphil posted:

Is there a reason that using ctrl + b to put bold tags in a post doesn't work when I am in the advanced reply window and instead opens my bookmarks sidebar? It works fine when I use the quick reply window or use any other ctrl combo (like for italics or underline).

Do I just need to change the bookmark sidebar hotkey in Firefox? This is a recent thing, like a few SALR updates ago.

What do you mean by 'advanced reply window'? Those control hotkeys for tags is something SALR does for its quick reply window, but we don't do (and haven't done, to my knowledge) any of that for the normal (forum side) reply window.

astral
Apr 26, 2004

Out there.


Update! v1.99.100330 (this build is NOT up on addons.mozilla, so don't try to get it there!)

Changes:
  • YouTube video embedder enhancements - you can now select your embedded player size and default quality. The options can be found in the "Threads" pane of the SALR preferences. If you don't like the specified sizes, there is a 'custom' size field. If you really liked the old player size for some reason, it was 450x370. For the quality option, note that YouTube provides no currently known working method for requesting the 480p video be embedded by default (unless the video uploader has a special yt: tag on the video, in which case you get the 480p version by default. How backwards is that?), so your choice is either 360p or 720p. Hopefully this will change. At least we can change the player size.

astral fucked around with this message at Mar 31, 2010 around 02:46

biznatchio
Mar 31, 2001



Buglord

astral posted:

Long enough that I don't remember when it didn't; it's one of my favorite features.

My memory's a bit foggy, but I'm pretty sure that was functionality I added into SALR; so it's been in there a long rear end time.

Ak Gara
Jul 29, 2005

That's just the way he rolls.

Okay I know I said it was working but then I upgraded to the latest 100330 and now it's not working again.

The rate thread and book mark button are like non-SALR again. I don't know if it's me or SALR. Any ideas?

astral
Apr 26, 2004

Out there.


Ak Gara posted:

Okay I know I said it was working but then I upgraded to the latest 100330 and now it's not working again.

The rate thread and book mark button are like non-SALR again. I don't know if it's me or SALR. Any ideas?

Those are handled by forums-based javascript, much like the timg tag in posts you said you were also having trouble with. The symptoms you describe make it sound like you are having trouble loading the forums' javascript, you have some kind of javascript blocker active for the forums, or that you have javascript disabled.

Adbot
ADBOT LOVES YOU

frozenphil
Mar 13, 2003

YOU CANNOT MAKE A MISTAKE SO BIG THAT 80 GRIT CAN'T FIX IT!


astral posted:


What do you mean by 'advanced reply window'? Those control hotkeys for tags is something SALR does for its quick reply window, but we don't do (and haven't done, to my knowledge) any of that for the normal (forum side) reply window.

Yeah, I meant the normal reply window. Your answer makes sense. Thanks.

  • Locked thread
«98 »