Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«98 »
  • Locked thread
duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


Carnivean posted:

Just to be clear on which version I have, it was the xpi posted in this thread. If you've got a later SVN on bountysource, you might have it licked.

I pushed out an update over the weekend, make sure you're using that version (070915).

Adbot
ADBOT LOVES YOU

hooah
Feb 6, 2006
WTF?

I made a new thread for the first time in quite a while today, and noticed that the thread tags in the quick post window are squished horizontally to the point where they're almost squares. Also, I don't have

Not sure if this has been covered; I searched all the pages for "tag" and didn't find anything relevant.

Also:

rin posted:

Actual thread tracking is handled by the forums now.

But the forums' way of doing it doesn't seem to work consistently. Many times it'll take me to the first new post as it should, but it will also often leave me in the middle of a bunch of stuff I've already seen. Or put me in the middle of a bunch of posts I haven't seen.

In short, I liked the way SALR handled it better.

withak
Jan 15, 2003


Fun Shoe

Turn on the option to re-anchor the page after loading images.

W.T. Snacks
Jul 14, 2004

a cat in a sammich is a sammichcat :o

I don't have time to read through all the last pages, but skimming and ctrl+f'ing for "error" didn't return anything, so I thought I'd mention this.
On my subscriptions page, I'm getting an error when it hits certain threads (still not sure of the criteria that causes it yet), but it's a "newPosts has no properties" error on line 747 of the overlay.

Sorry if this has been mentioned before!

Edit: As of the latest version, 070915

hooah
Feb 6, 2006
WTF?

withak posted:

Turn on the option to re-anchor the page after loading images.

This has been on. Although, I've only had a currently-working version of SALR for a day or so; maybe I'm just mis-remembering when this happens. I'll check it out in more detail over the next few days.

Carnivean
Feb 14, 2004

by Peatpot


duz posted:

I pushed out an update over the weekend, make sure you're using that version (070915).

That's the one I'm using, and getting the problem on.

Slippery
May 16, 2004



Muscles Boxcar

I too am having a problem where I have the old buttons, but once I post in a forum, they revert to the new built in style. I am using the latest version and have XP SP2 and Firefox.

jacoby
Jul 24, 2004



Browsed the thread and didn't see a recent answer to this: Quoted images are still showing up as empty spaces for me. I know that it wasn't working, I updated at some point and it started working again, then another update it stopped again. Right now I have the latest version (070915) and as I said, not getting anything.

Is there something I need to do other than updating SALR?

Thanks.

|||||||
Aug 19, 2004

I'm not Chemmy



Posting an image

|||||||
Aug 19, 2004

I'm not Chemmy

||||||| posted:



Posting an image

Quoting an image

Give a screenshot of what you see.

calandryll
Apr 25, 2003

Ask me where I do my best drinking!


Pillbug

jacoby posted:

Browsed the thread and didn't see a recent answer to this: Quoted images are still showing up as empty spaces for me. I know that it wasn't working, I updated at some point and it started working again, then another update it stopped again. Right now I have the latest version (070915) and as I said, not getting anything.

Is there something I need to do other than updating SALR?

Thanks.

I think it deals with waffleimages more than SALR. I get it sometimes when I'm using IE at work.

Also does anyone have an edit to have the X image appear after the jump to last post?

Carnivean
Feb 14, 2004

by Peatpot


||||||| posted:

Quoting an image

Give a screenshot of what you see.

sildenafil
Dec 17, 2004

They're just jealous.


Carnivean posted:



I get the same thing.

Atrus
Dec 5, 2003

"The ending has not yet been written."

Ask me about CONTRIBUTING TO THE DEATH OF VIDEOGAMES

Carnivean posted:


I get the same thing as well.

ryanbruce
May 1, 2002

The "Dell Dude"


Atrus posted:

I get the same thing as well.

Me too. Should we not be?

PurDunamis
Jun 17, 2005



||||||| posted:

Give a screenshot of what you see.
No quoted image, Is there any diagnostic info you would like me to provide?

Only registered members can see post attachments!

Chick3n
Jun 26, 2005
My mum says I’m cool.

PurDunamis posted:

No quoted image, Is there any diagnostic info you would like me to provide?

Do you have any other SA extensions installed? Under Tools > Error Console, you should be able to see if there are any javascript errors which could break the code.

PurDunamis
Jun 17, 2005



After a little bit of testing looks like it's nothing to do with SALR, and is caused by NoScript. If I allow somethingawful.crwdcntrl.net then quoted images show and are resized to thumbnails, if somethingawful.crwdcntrl.net is blocked then I get a blank space the size of the original quoted image.

|||||||
Aug 19, 2004

I'm not Chemmy

PurDunamis posted:

After a little bit of testing looks like it's nothing to do with SALR, and is caused by NoScript. If I allow somethingawful.crwdcntrl.net then quoted images show and are resized to thumbnails, if somethingawful.crwdcntrl.net is blocked then I get a blank space the size of the original quoted image.

Good enough I kind of figured that.

porktree
Mar 23, 2002

You just fucked with the wrong Mexican.


PurDunamis posted:

After a little bit of testing looks like it's nothing to do with SALR, and is caused by NoScript. If I allow somethingawful.crwdcntrl.net then quoted images show and are resized to thumbnails, if somethingawful.crwdcntrl.net is blocked then I get a blank space the size of the original quoted image.
I don't have NoScript installed and quoted images always show up as links and not thumbnailed images (they show up like the screen cap). I've always thought this was good, after all I've read the thread and seen the image, I don't need it shown to me again.

hooah
Feb 6, 2006
WTF?

hooah posted:

This has been on. Although, I've only had a currently-working version of SALR for a day or so; maybe I'm just mis-remembering when this happens. I'll check it out in more detail over the next few days.

It's working now. I hadn't changed the option in the forums config, just in the SALR config.

RedKazan
Apr 4, 2003



TangyRaptor on page 4 posted:

How can I clear my starred threads? A lot of them have moved into archives and since I can not access archives, I can not unstar that thread. I tried uninstalling SALR and reinstalling it (I seem to remember unintentionally clearing them before) but that didn't work.

Thanks.

I may be blind but I hadn't seen a resolution for this yet so I thought I'd contribute something. This svn patch adds a button to the page of archived threads you have starred to unstar them, as seen here:



It's not the most elegant way of going about it but it works for people that just want to clean up their stars until something better comes along to manage them.

I also wrote another patch for my own personal entertainment that other people might enjoy having, it adds a Ban History link in the Profile bar after Post History, as seen here (red circle not included):



I'm no JS master so if something can be done better feel free to fix it up.

Edit: Fixed a typo in my first patch that somehow didn't manage to break it , link is updated

RedKazan fucked around with this message at Sep 22, 2007 around 06:00

Lollerich
Mar 25, 2004

The little doctors are back,
they want to play with you!


That ban history thing is sweet. Thanks!

Edit: Just patched my version and it's really sweet

Lollerich fucked around with this message at Sep 21, 2007 around 14:55

Polluxx Troy
Mar 12, 2005

...authorities here are on alert...

What am I doing wrong?

RedKazan
Apr 4, 2003



Polluxx Troy posted:

What am I doing wrong?



Well, the right arrow is disabled because you're on the last page of a thread. The left arrow though, dunno, it works for me just fine in this thread and on that page. Are both arrows disabled on previous pages? Does it do this for other threads? Are you using the current version?

Edit: Also, does your nav bar work?

RedKazan fucked around with this message at Sep 21, 2007 around 15:33

Biaxident
Sep 4, 2003

GLOCK: Explosive Firepower!


RedKazan posted:

I also wrote another patch for my own personal entertainment that other people might enjoy having, it adds a Ban History link in the Profile bar after Post History, as seen here (red circle not included):



I'm no JS master so if something can be done better feel free to fix it up.

Please pardon my ignorance, but I think this is a great idea and I'd like to add it to my version. Trouble is, I don't know how. Can anybody point me in the right direction here?

"To my mind it is wholly irresponsible to go into the world incapable of preventing violence, injury, crime, and death. How feeble is the mindset to accept defenselessness. How unnatural. How cheap. How cowardly. How pathetic." - Ted Nugent

Chick3n
Jun 26, 2005
My mum says I’m cool.

RedKazan posted:

Edit: Also, does your nav bar work?

Those menus rely on the Page/Forum Navigator, if you have them disabled, the feature won't work.

Lollerich
Mar 25, 2004

The little doctors are back,
they want to play with you!


Biaxident posted:

Please pardon my ignorance, but I think this is a great idea and I'd like to add it to my version. Trouble is, I don't know how. Can anybody point me in the right direction here?
There's probably a way using some patch tool, but gently caress that, I'm not installing any of that just to add a few lines of code

I did this:
- download the latest version of the salastread.xpi and save it somewhere where you can find it
- rename the file ending to zip
- extract the file salastreadOverlay.js from chrome/content/salastread/ in the zip file
- open with a text editor like notepad++ and search for "//add user coloring/note links"
- above that line add
code:
//ban history link
var banHistLink = doc.createElement("li");

var banHistAnchor = doc.createElement("a");
		banHistAnchor.href = "/banlist.php?userid=" + posterId;
		banHistAnchor.title = "Show poster's ban/probation history.";
		banHistAnchor.innerHTML = " Ban History";
banHistLink.appendChild(banHistAnchor);
banHistLink.appendChild(doc.createTextNode(" "));
profileLink.parentNode.parentNode.appendChild(banHistLink);
- save the file
- overwrite the file in the zip
- rename to xpi
- drag and drop the xpi file in your browser window to install

Biaxident
Sep 4, 2003

GLOCK: Explosive Firepower!


Works perfectly. Thank you Lollerich.

poopiehead
Oct 6, 2004



Extremely, extremely, extremely minor issue. >) and >) render as something similar to < and > in the live preview but aren't recognized by the forums.

RedKazan
Apr 4, 2003



Lollerich posted:

- download the latest version of the salastread.xpi and save it somewhere where you can find it
- rename the file ending to zip
- extract the file salastreadOverlay.js from chrome/content/salastread/ in the zip file

- overwrite the file in the zip
- rename to xpi
- drag and drop the xpi file in your browser window to install

An even easier way in the future is to just edit the active salastreadOverlay.js that's already on your computer. In Windows XP it's stored in "C:\Documents and Settings\(your user name)\Application Data\Mozilla\Firefox\Profiles\(your firefox profile)\extensions\{fc6339b8-9581-4fc7-b824-dffcb091fcb7}\chrome\content\salastread". Note the \Application Data\ folder is hidden. If you're using a portable version of Firefox or you have another OS just search for "salastreadOverlay.js". Installing the .xpi just unzips everything for you to that folder, and this way you won't override any other changes you may have made.

Slippery
May 16, 2004



Muscles Boxcar

Thanks RedKazan and lollerich, that ban history thing is neat as poo poo. I really enjoy it. I think it should be incorporated into the next official version!

Hey, also, I have a question. My threads are showing a mixture of native SA forum buttons and Last Read (old style) buttons. What is up with this and is there a fix? It seems to switch randomly and doesn't seem related to whether I have posted in the thread.

Jethro
Jun 1, 2000

I was raised on the dairy, Bitch!

poopiehead posted:

Extremely, extremely, extremely minor issue. >) and >) render as something similar to < and > in the live preview but aren't recognized by the forums.
Actually, it's seeing them as > and <, I would assume because of the ; at the end of & lt ; and & rt ; Same thing happens with &)

RedKazan
Apr 4, 2003



Slippery posted:

Thanks RedKazan and lollerich, that ban history thing is neat as poo poo. I really enjoy it. I think it should be incorporated into the next official version!

Hey, also, I have a question. My threads are showing a mixture of native SA forum buttons and Last Read (old style) buttons. What is up with this and is there a fix? It seems to switch randomly and doesn't seem related to whether I have posted in the thread.



Threads you read on other computers will show up with the default forums buttons and threads you read on your current computer should (hopefully) show up with the buttons of your choosing, but it seems to be a little wonky right now. I'll post a workaround patch for this later.

Slippery
May 16, 2004



Muscles Boxcar

RedKazan posted:

Threads you read on other computers will show up with the default forums buttons and threads you read on your current computer should (hopefully) show up with the buttons of your choosing, but it seems to be a little wonky right now. I'll post a workaround patch for this later.

Oh, got it, that makes sense. Thanks a lot for the explanation, and thanks again for the ban history thing.

RedKazan
Apr 4, 2003



This patch fixes the following issues (as far as I can tell):

-Switching Go To Last Read and Unread does not work yet
-Always show Go To Last Read does not work yet
-Custom icons don't show up for threads you read on other computers

Let me know if anything still doesn't work for you. The last fix is simple enough, it just looks for the icons on the page and changes them, whether the thread is in your database as read or not. I put the option for swapping the icons back in under the Forums tab in the Features group. Threads not in your database will still not be highlighted though. You could fix that with the same theory: look for the icons the forums have built in, if you find them, color the thread accordingly. You could even force it being added to the database as read (and inversely you could remove a thread from the database if you don't find any icons), but I didn't want to step on any of the devs toes if they wanted to do it a different way.

Note to devs: I didn't add an entry for the swap icon pref under importOldData() because I couldn't find and old copy of the extension to see if there even was one. Someone with better knowledge of that can add one if needed.

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


RedKazan posted:



Go join the project on Bounty Source so I can give you commit access.

RedKazan
Apr 4, 2003



duz posted:

Go join the project on Bounty Source so I can give you commit access.

I'm in the community as Mithros.

duz
Jul 11, 2005

Excellent. The Arkham Asylum shower cam is operational once more.


RedKazan posted:

I'm in the community as Mithros.

You've got commit access. The xpi and the update file are locked so don't try changing those.

Adbot
ADBOT LOVES YOU

The Remote Viewer
Jul 9, 2001


I'm probably going to get flamed to death for this, but I don't care.

Maybe it's time to consider putting this old horse down. Most of the core functionality has been subsumed by the forum itself, and what's left breaks often and stays broken for days or weeks at a time. The days when something broke and a fix came out within hours appear to be over.

  • Locked thread
«98 »