Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
Strabo4
Jun 1, 2007

Oh god, I am 'sperging all over this thread too!


Running 7100 64bit right now. I haven't encountered a single bluescreen yet and almost every program has worked. I had XP Pro previously and it feels a lot faster and smoother than it. Looking forward to being able to buy it.

Adbot
ADBOT LOVES YOU

Strabo4
Jun 1, 2007

Oh god, I am 'sperging all over this thread too!


4 Day Weekend posted:

I was initially running on 4GB, but it bugged out so I switched to 2x1GB. I can honestly not tell any difference.

I have 8GB of ram (it was some good ram on a really loving good sale) and I don't think I've ever gone over half. It tends to stay around 37% usage, even with 64+ processes running at once.

Strabo4
Jun 1, 2007

Oh god, I am 'sperging all over this thread too!


Sounds like Home Premium will be more than adequate for the average user. Good job Microsoft for not making this a confusing fuckup of features.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply