Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
  • Post
  • Reply
DONT DO IT
Jun 5, 2008

this level will be fun guys


I've got a question for you... For whatever reason, my 2000 Audi S4 has been running rich for the past 2 years. It never warms up despite having the thermostat changed (twice!). That would explain why it runs rich.. However, none of the local shops (or even the Audi dealership) have been able to diagnose the root problem. The biggest issue is it starts like rear end whether it is warm or not. As the battery inevitably dies, it just gets harder and harder. But just for fun, if I use ethanol fuel it starts right up. Too bad the ethanol fuel worsens my already terrible fuel mileage and idles like poo poo. It's not water in the tank, as after two bottles of Heet you'd expect some sort of change. It doesn't seem to be carbon buildup either, as I used the three bottles of a $25 dollar per bottle treatment (forgot the brand) as recommended by the last mechanic that worked on it. Any ideas?

All of this crap is why I bought a 400 dollar Volvo.

I sound bitter.

Adbot
ADBOT LOVES YOU

DONT DO IT
Jun 5, 2008

this level will be fun guys


my1999gsr posted:

OK, this is a little tougher to diagnose. First, we need to figure out why it never warms up. Do you have any faults or a MIL light on? Also, has your S4 been in for the ignition coil recall yet? That it idles poorly is pretty strange - does it idle better when you've got a tank full of ethanol?

No CELs, though the last time I VAG'd it I think I got "signal to warm up catalyst too low" or something similar (can't remember exactly, but it was a fault with the warm up catalyst). I told the local dealership this and got, "Well, it could be anything." Thanks, Audi.

The 2 coil packs were replaced in trying to diagnose the failed ignition control modules, which were also both replaced at an independent shop. But no, it hasn't been in specifically for a recall, and none were mentioned whenever I went to the dealership.

As for the fuel, I'm not sure. It might though, as it does tend to feel "worse" the lower my fuel gets.

drat nice job on the replies by the way. Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply