Register a SA Forums Account here!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
  • Post
  • Reply
Aug 7, 2004

Is SCCM an addon for the Domain Controller? The place I work at is a bit strange in that we have full control over a section of our AD but we can't make higher level changes. We can put management tools on our servers no problem so I just want to confirm that it is possible.


Aug 7, 2004

peak debt posted:

It may need to do a schema modification depending on what has been used before. The SCCM installer has a quick prerequisite checker that will tell you if that needs to be done. If the schema is ok, you can manage software deployment just by having administrative control over the clients, updating with a group policy and image deployment by having admin control over the DHCP server.

Bleh no admin control over DHCP. Just over the AD for our area of the university and of course all of our clients. If we are lucky one of the larger groups will have implemented this already and we can ride their coat tails as far as schema changes, otherwise it becomes a way larger pain in the rear end since it is unlikely they will change something that affects 30k machines to make our lives easier with 1500ish.

Are there lots of things that have to be done on the DHCP server to get the deployment end up and running? We have a decent relationship with the network group so if it is a one time configuration issue we might be ok but if it is something that has to be done with each new client probably not. Currently we can request static IP addresses and poo poo from them based on MACs so if that is all that is needed we are ok.

Demonachizer fucked around with this message at Jul 13, 2010 around 18:00

Aug 7, 2004

Office 2010 deployment using GPOs.

Has anyone gotten this to work? I am kind of at my wits end because I have done exactly what they say to do at but can only get an error code 5 out of the log files (I can't find reference to what error code 5 is). For some reason it seems that MS decided not to include a way to deploy this as an MSI.

The way we do it currently for all software is we have a share that has "Everyone" with read access. What it seems like though is that because when this runs as a startup script it isn't running in the context of a user account it never hits our share. We can't do this as a logon script because our users are not admins...

If you have succeeded with this please let me know. I want to deploy 2010 to about 700 machines in the next couple months...

Aug 7, 2004

quackquackquack posted:

Error 5 is usually a permissions error, or sometimes 'file not found' in my experience.

Post the command you are calling to install Office.

When you run it as a startup script, you're running it as the computer account, not the user account, so make sure (iirc) that 'domain computers' have read access to the folder containing your installation files.

EDIT: Oh, and PS, 'domain computers' is a member of 'domain users', so you can use that instead of 'everyone' for your NTFS permissions on the share that contains your installation files and catch both logon and startup scripts.

We actually don't have a domain computers group and since we are a part of a university there is no feasible way of getting one as they probably have reasons on their end to not use it.

So I tried running it with the following in both the sharing section with read access and under file permissions with the same:

Authenticated Users
The computer itself that I am testing with
Anonymous Users

The code I have used is this from MS:

REM *********************************************************************
REM Environment customization begins here. Modify variables below.
REM *********************************************************************

REM Get ProductName from the Office product's core Setup.xml file, and then add "office14." as a prefix. 
set ProductName=Office14.PROPLUS

REM Set DeployServer to a network-accessible location containing the Office source files.
set DeployServer=\\FS\Office2010SourceFiles

REM Set ConfigFile to the configuration file to be used for deployment (required)
set ConfigFile=\\FS\Office2010SourceFiles\ProPlus.WW\config.xml

REM Set LogLocation to a central directory to collect log files.
set LogLocation=\\FS\Office2010LogFiles

REM *********************************************************************
REM Deployment code begins here. Do not modify anything below this line.
REM *********************************************************************

IF NOT "%ProgramFiles(x86)%"=="" (goto ARP64) else (goto ARP86)

REM Operating system is X64. Check for 32 bit Office in emulated Wow6432 uninstall key
reg query HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432NODE\Microsoft\Windows\CurrentVersion\Uninstall\%ProductName%
if NOT %errorlevel%==1 (goto End)

REM Check for 32 and 64 bit versions of Office 2010 in regular uninstall key.(Office 64bit would also appear here on a 64bit OS) 
reg query HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\%ProductName%
if %errorlevel%==1 (goto DeployOffice) else (goto End)

REM If 1 returned, the product was not found. Run setup here.
start /wait %DeployServer%\setup.exe /config %ConfigFile%
echo %date% %time% Setup ended with error code %errorlevel%. >> %LogLocation%\%computername%.txt

REM If 0 or other was returned, the product was found or another error occurred. Do nothing.

I finally got it to work with:
net use \\$Server\$Share /user:$Server\$User $Password
start /wait \\$Server\$Share\setup.exe
echo %date% %time% Setup ended with error code %errorlevel%. >> c:\%computername%.txt
I will edit in the net use to the MS script and see if it works.

Demonachizer fucked around with this message at May 27, 2011 around 13:20

Aug 7, 2004

What should I be looking at if I want a method to maintain a configuration across a shitload (relative) of server 2003 application servers in a Citrix farm?

Essentially, I have around 60 Citrix application servers that need to be the same. I get them from someone else in a certain state (server installed and some other things). What I want to do is essentially use a master instance and have all the other servers conform to it. This would be file system, registry aside from areas that are unique to an installation (hostname etc.). I also would like to be able to update the master instance and have it cascade through the rest in some easy fashion. Is this something that can be addressed with puppet? Unfortunately, this is not a virtual environment, or I would just try to figure out a way to just spin up new servers and add them to the farm/application from a template when updates are needed.

Resources I have available to me is a KACE box and potentially SCCM but I need to work that out. We essentially can use most any Microsoft software for free (well not free technically but we have a site license for almost anything).

Demonachizer fucked around with this message at Feb 20, 2014 around 12:03

Aug 7, 2004

Anyone have any info on storage sizing for a server 2008 R2 print server that has to handle at most 100 printers today and probable growth of maybe 50 in the next 5 years? I can get info on everything else but this. I am trying to decide if I can wedge it into a vSphere environment that is semi space limited or if I need to wait for an upcoming environment.

I am hoping that I won't run into any issues sizing it at around 100gb per instance with two instances total. This is kind of a learning experience because in the past we just assigned IP printers through a janky GPO.

Aug 7, 2004

I hope this is the right place to ask this.

I need to prepopulate an OU with a bunch of computer objects. Normally I would do this manually and specify in the "The following user of group can join this computer to a domain" to be a service account that I use to join machines.

I would like to instead do this with powershell. I think I should use the New-ADComputer cmdlet but I am not sure how to specify the joiner. This is kind of vital because my service account is not a member of default: Domain Admins by design.

Anyone ever do this?


Aug 7, 2004


You probably want to use get-acl and set-acl to set permissions on the adcomputer object you create.

Yeah I think that is probably it. I actually ended up just delegating creation to that OU and using add-computer with the -OUPath variable and the service account as the joiner and it worked out a-ok. I will figure out the get-acl set-acl thing for my records though since that will be way easier.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply