Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«252 »
  • Post
  • Reply
Nam Taf
Jun 25, 2005

I am Fat Man, hear me roar!



xamphear posted:

Yeah, and it's broken. It doesn't stop youtube or twitch from autoplaying, which both seem like pretty major sites you'd want to test on.

Itís not broken thereís just multiple settings that donít really make sense. Changing them in fact does bring back the actual options screen toggle, too.

Have a read of both this (including comments) and this and youíll be able to set it up.

Mine asks for permission and I distinctly remember it asking on YouTube.

Adbot
ADBOT LOVES YOU

Harik
Sep 9, 2001

From the hard streets of Moscow
First dog to touch the stars



Plaster Town Cop

What in firefox keeps the display awake?

Under linux, running "xset dpms force standby" causes the screen to instantly come back on if firefox is running, and it never actually blanks when I leave it idle. Kill firefox, my monitor sleeps like it's supposed to.

It's probably some autoplay video pending focus but gently caress me if I'm going to janitor my tabs to find the one keeping it awake when i would rather firefox lost the ability to gently caress with my screen entirely.

astral
Apr 26, 2004

Out there.


Harik posted:

What in firefox keeps the display awake?

Under linux, running "xset dpms force standby" causes the screen to instantly come back on if firefox is running, and it never actually blanks when I leave it idle. Kill firefox, my monitor sleeps like it's supposed to.

It's probably some autoplay video pending focus but gently caress me if I'm going to janitor my tabs to find the one keeping it awake when i would rather firefox lost the ability to gently caress with my screen entirely.

How many tabs do you have open?

mike12345
Jul 14, 2008

"Whether the Earth was created in 7 days, or 7 actual eras, I'm not sure we'll ever be able to answer that. It's one of the great mysteries."





Harik posted:

What in firefox keeps the display awake?

Under linux, running "xset dpms force standby" causes the screen to instantly come back on if firefox is running, and it never actually blanks when I leave it idle. Kill firefox, my monitor sleeps like it's supposed to.

It's probably some autoplay video pending focus but gently caress me if I'm going to janitor my tabs to find the one keeping it awake when i would rather firefox lost the ability to gently caress with my screen entirely.

I've had the same problem, and the only fix was quitting firefox.

Harik
Sep 9, 2001

From the hard streets of Moscow
First dog to touch the stars



Plaster Town Cop

astral posted:

How many tabs do you have open?

Enough that I'm not sitting around and counting them. Less than earlier because I finished one thing I was working on and nuked the entire tab-tree at once.

Somewhere north of 150 I think. I keep trying to use bookmarks instead but that requires so much more janitoring then open tabs, use the address bar to jump to the one you want, close when done.

E: And something I closed was doing it, I can sleep the display again with firefox open. It's infuriating.

Harik fucked around with this message at Mar 11, 2019 around 20:51

astral
Apr 26, 2004

Out there.


Harik posted:

Enough that I'm not sitting around and counting them. Less than earlier because I finished one thing I was working on and nuked the entire tab-tree at once.

Somewhere north of 150 I think. I keep trying to use bookmarks instead but that requires so much more janitoring then open tabs, use the address bar to jump to the one you want, close when done.

E: And something I closed was doing it, I can sleep the display again with firefox open. It's infuriating.

Ahh. Do you use the bookmarks toolbar? If not, you might give it a try - it adds some convenience for things like that. You can make folders there too. You can also limit a search to bookmarks only by putting an * before your search, e.g.
code:
* coolprojectidea

Harik
Sep 9, 2001

From the hard streets of Moscow
First dog to touch the stars



Plaster Town Cop

astral posted:

Ahh. Do you use the bookmarks toolbar? If not, you might give it a try - it adds some convenience for things like that. You can make folders there too. You can also limit a search to bookmarks only by putting an * before your search, e.g.
code:
* coolprojectidea

That's what I mean about janitoring: When I'm done I have to go remove the bookmarks again instead of closing an entire tab-tree. I keep bookmarks of the stuff I reference all the time, but tabs are short-lived. Thanks for the asterisk hint though, I didn't know that shortcut.

The bookmarks toolbar has stuff I use constantly on it. cyberchef, landing pages for python, STL, atmel and nordic documentation, etc.

Anyway, it's not really the topic: how do I prevent websites from keeping my monitor on?

Klyith
Aug 3, 2007

GBS Pledge Week


Harik posted:

Anyway, it's not really the topic: how do I prevent websites from keeping my monitor on?

Janitor your tabs. The most likely suspects are video players so you could start with all the tabs for youtube and similar sites.


If you were on widows you could use powercfg /requestsoverride to prevent firefox itself from blocking power changes, but apparently linux has no equivalent to that. So it seems like you're boned.

Harik
Sep 9, 2001

From the hard streets of Moscow
First dog to touch the stars



Plaster Town Cop

Klyith posted:

Janitor your tabs. The most likely suspects are video players so you could start with all the tabs for youtube and similar sites.


If you were on widows you could use powercfg /requestsoverride to prevent firefox itself from blocking power changes, but apparently linux has no equivalent to that. So it seems like you're boned.

Actually it does:
code:
$ systemd-inhibit
WHO                 UID USER  PID  COMM            WHAT                         
Libvirt             0   root  3192 libvirtd        shutdown                     
ModemManager        0   root  2540 ModemManager    sleep                        
slack               574 harik 4927 slack           sleep                        
xfce4-power-manager 574 harik 4802 xfce4-power-man handle-power-key:handle-suspe

4 inhibitors listed.
There's another one on dbus for screensaver as well.

So I need to wait for it to break me again and find out which it's taking, then I can find it in the source. Not a rabbithole I wanted to go down but oh well.

xamphear
Apr 9, 2002

SILK FOR CALDÉ!

Nam Taf posted:

Itís not broken thereís just multiple settings that donít really make sense. Changing them in fact does bring back the actual options screen toggle, too.

Have a read of both this (including comments) and this and youíll be able to set it up.

Mine asks for permission and I distinctly remember it asking on YouTube.

Thanks for these links, I'll check them out and make sure my settings are in line.

Edit: Yeah, I was right in line with the best practices laid out there. I still get videos (with sound!) autoplaying on Youtube and Twitch. It's never the initial page I go to, it's after clicking around a bit. It even shows the little "autoplay blocked" icon in the address bar, while the video starts right up and blares out my speakers.

xamphear fucked around with this message at Mar 18, 2019 around 14:34

pairofdimes
May 20, 2001

blehhh


Heads up, but if you had enabled scrolling in the tab bar = changing tabs through userchrome.css/bindings.xml, like this, Firefox 66 breaks that and won't even load correctly as long as those changes are present.

I thought the update failed or my profile was corrupted but it was just those tweaks.

Megillah Gorilla
Sep 22, 2003

One Potato to rule them all,
One Potato to find them,
One Potato to bring them all
And in the darkness bind them.




Bread Liar

Goddammit Mozilla, just let me keep the poo poo I like

Belan
May 7, 2007


Unless I'm missing something Firefox 66 did not add/fix scroll anchoring? At least here pages load just like they did before.

Nalin
Sep 28, 2007



Hair Elf

Belan posted:

Unless I'm missing something Firefox 66 did not add/fix scroll anchoring? At least here pages load just like they did before.

The problem is that SA has this CSS:
code:
div#container {
 overflow:hidden
}
That div covers the whole entire page and it breaks scroll anchoring.

Firefox cannot set an anchor point inside a nested scrollable frame, and overflow:hidden creates a scroll frame. So the whole entire page is one giant nested scrollable frame.

Related: https://bugzilla.mozilla.org/show_bug.cgi?id=1520581

TalkLittle
Jun 23, 2004



Slouch Watcher

Just learned when you right-click an image, you can then Ctrl-click or middle-click the "View image" context menu item to open in a new tab. This was surprising to me because the context menu looks OS-styled and I didn't think it would support different mouse buttons.

astral
Apr 26, 2004

Out there.


TalkLittle posted:

Just learned when you right-click an image, you can then Ctrl-click or middle-click the "View image" context menu item to open in a new tab. This was surprising to me because the context menu looks OS-styled and I didn't think it would support different mouse buttons.

Yeah, it's great.

In case you didn't know, this combination makes it even better: if a website disables/uses their own context menus, you can hold the shift key as you right-click and Firefox's context menu will appear.

Geemer
Nov 4, 2010

What is it with Japan and ridiculous hair colors?



Buglord

astral posted:

Yeah, it's great.

In case you didn't know, this combination makes it even better: if a website disables/uses their own context menus, you can hold the shift key as you right-click and Firefox's context menu will appear.


I knew about the other stuff but this is really great to know.

Toast Museum
Dec 3, 2005

30% Iron Chef


Geemer posted:


I knew about the other stuff but this is really great to know.

Seriously. I can't believe I've been oblivious to such a useful feature for so long. That deserves to be much better-known.

Volguus
Mar 3, 2009


Toast Museum posted:

Seriously. I can't believe I've been oblivious to such a useful feature for so long. That deserves to be much better-known.

If you press Alt-F the old style menu still shows up. That menu usually has pretty much you ever need. While I had no idea about the shift right-click, the main menu was always right there and I always made a point to the websites that intercepted my right-click to steal their images and read their html, just because.

Nalin
Sep 28, 2007



Hair Elf

Volguus posted:

If you press Alt-F the old style menu still shows up. That menu usually has pretty much you ever need. While I had no idea about the shift right-click, the main menu was always right there and I always made a point to the websites that intercepted my right-click to steal their images and read their html, just because.

You can also just tap Alt. Or, right click the space above the tabs and enable "Menu Bar". I always keep the menu bar enabled as it provides a little extra space to click and drag the window around with.

Dylan16807
May 12, 2010


Nalin posted:

The problem is that SA has this CSS:
code:
div#container {
 overflow:hidden
}
That div covers the whole entire page and it breaks scroll anchoring.

Firefox cannot set an anchor point inside a nested scrollable frame, and overflow:hidden creates a scroll frame. So the whole entire page is one giant nested scrollable frame.

Related: https://bugzilla.mozilla.org/show_bug.cgi?id=1520581

Hmm, but SA still doesn't scroll anchor if I use userContent.css to disable that line.

Nalin
Sep 28, 2007



Hair Elf

Dylan16807 posted:

Hmm, but SA still doesn't scroll anchor if I use userContent.css to disable that line.

Set this to true:
layout.css.scroll-anchoring.highlight

If the whole page highlights when you scroll (you may also have to move your mouse), then something else in the CSS is causing the whole page to be identified as a target.

Firefox currently lacks the ability to choose an anchoring point inside a scrollable frame.

Dylan16807
May 12, 2010


Nalin posted:

Set this to true:
layout.css.scroll-anchoring.highlight

If the whole page highlights when you scroll (you may also have to move your mouse), then something else in the CSS is causing the whole page to be identified as a target.

Firefox currently lacks the ability to choose an anchoring point inside a scrollable frame.

It seems to highlight individual posts, is that good or bad?

How can you tell what counts as a scrollable frame? Inspecting the page shows that the modification worked and that it did get rid of the high level overflow:hidden.

Nalin
Sep 28, 2007



Hair Elf

Dylan16807 posted:

It seems to highlight individual posts, is that good or bad?

How can you tell what counts as a scrollable frame? Inspecting the page shows that the modification worked and that it did get rid of the high level overflow:hidden.

I'm not sure then! Highlighting just a single post should mean that it found an anchor point that it can use to resist page flow changes.

There were some bugs about calculating things incorrectly, especially dealing with DOM elements that get added dynamically. Maybe it's the typical Twitter embed poo poo causing problems?

astral
Apr 26, 2004

Out there.


Firefox's Content Blocking solves the Twitter thing for me at least.

Reiche
Jan 28, 2009

I like my coffee with cream and lsd.


So apparently FF is blocking auto play with the newest update? Except the opposite is happening and everything is auto playing for me now. None of my settings have changed as far as I can tell but I can't even look at any threads on SA that have .mp4s because they're all set to auto play. I have an older laptop that can't handle multiple videos playing at once without everything freezing up. Usually I can just play and then pause one video at a time as I'm scrolling down a thread.

Do I have any options I can try?

astral
Apr 26, 2004

Out there.


Reiche posted:

So apparently FF is blocking auto play with the newest update? Except the opposite is happening and everything is auto playing for me now. None of my settings have changed as far as I can tell but I can't even look at any threads on SA that have .mp4s because they're all set to auto play. I have an older laptop that can't handle multiple videos playing at once without everything freezing up. Usually I can just play and then pause one video at a time as I'm scrolling down a thread.

Do I have any options I can try?

Already have the settings from the 'Block autoplay by default' section of the solution here?

https://support.mozilla.org/en-US/questions/1238033

The Dark One
Aug 19, 2005

I'm your friend and I'm not going to just stand by and let you do this!


Do you have this box ticked?

Reiche
Jan 28, 2009

I like my coffee with cream and lsd.


astral posted:

Already have the settings from the 'Block autoplay by default' section of the solution here?

https://support.mozilla.org/en-US/questions/1238033
I did, but it suggested also switching media.autoplay.allow-muted to false and that seems to have fixed my issues with media on SA! That stopped Twitter from autoplaying videos as I scroll past which is great too.


The Dark One posted:

Do you have this box ticked?


I do currently have this box ticked, I'm guessing I want that? YouTube is still autoplaying but that's less of a problem rather than a personal preference to keep videos from starting when I send a video to a new tab.

Thanks for the help!

Reiche fucked around with this message at Mar 23, 2019 around 08:28

Dylan16807
May 12, 2010


Nalin posted:

I'm not sure then! Highlighting just a single post should mean that it found an anchor point that it can use to resist page flow changes.

There were some bugs about calculating things incorrectly, especially dealing with DOM elements that get added dynamically. Maybe it's the typical Twitter embed poo poo causing problems?
It's definitely the twitter embeds causing problems in some manner. But I'd still rather have them turned on than have to click through to twitter, so I'll just hope it gets fixed sometime soon.

Megillah Gorilla
Sep 22, 2003

One Potato to rule them all,
One Potato to find them,
One Potato to bring them all
And in the darkness bind them.




Bread Liar

I know what you mean, gently caress Twitter.

I just wish there was a way to display images from Twitter in their entirety, without them being cut off.

Geemer
Nov 4, 2010

What is it with Japan and ridiculous hair colors?



Buglord

Megillah Gorilla posted:

I know what you mean, gently caress Twitter.

I just wish there was a way to display images from Twitter in their entirety, without them being cut off.

Don't think it works from embeds, but if you drag them onto the tab bar so they open in a new tab, you can append :orig to them and get as close to uncompressed as Twitter offers. Note: they're still compressed to hell.

I use a userscript that automates the appending, but maybe there's also one floating around that makes the thumbnails useful.

Dodoman
Feb 26, 2009



A moment of laxity
A lifetime of regret


Lipstick Apathy

Is there any download manager for firefox with an auto retry feature? My google skills have failed me because I've come up with zilch so far, and none of the ones listed on AMO look legit.

Artelier
Jan 23, 2015


So I just got onto Quantum and I love everything but I have one major issue: it doesn't detect my webcam, which I use to keep in contact with people on FB.

I am going insane trying to get it to work. I've given permissions, revoked them, gave them again, safe mode, reset Firefox, uninstall firefox, got rid of all the appdata stuff, reinstalled, reinstalled again on beta branch, nothing seems to work. It just tells me that I haven't given it permission (even though it's definitely marked on all relevant pages).

Anything else I can do? Is there an even more resetter reset available?

Right now the only solution I have is to open another browser just for webcam purposes.

EDIT: Using a Logitech C922, if that matters. Reinstalled whatever I got for that too, still nothing.

Also, what infuriates me is that this problem only applies to the Firefox on my main comp. The desktop in the family house and the laptop can access the webcam no problem. Aaaaa

Artelier fucked around with this message at Mar 26, 2019 around 14:58

Geemer
Nov 4, 2010

What is it with Japan and ridiculous hair colors?



Buglord

Check the Windows 10 privacy settings? Doesn't that have an entry for webcam access?

Im_Special
Jan 2, 2011

Look At This!!! WOW!
It's F*cking Nothing.


But it works on his other browsers, so it's a Firefox thing. My only suggestion would be to go into about:config and search the word "camera" or similar like "permission" and make sure the settings for those look right, looking at mine I see a "permissions.default.camera" entire set to "2" which is probably disabled/revoked, so maybe you could try setting them to default or "0", "1", "3", etc. and see if that helps any.

Geemer
Nov 4, 2010

What is it with Japan and ridiculous hair colors?



Buglord

I thought the Win 10 stuff was per app, so maybe Firefox isn't setting the permission on install on his computer for some weird reason.

Ola
Jul 19, 2004



Yeah, probably a permissions thing. Win-button, type "camera", Camera Privacy Settings, tick relevant things on. I don't see Firefox in there, but "Desktop App Web Viewer" is probably the API that browsers use.

dud root
Mar 30, 2008


Any recommendations for a Youtube downloader extension? I've tried a couple but they dont do 1080p

Adbot
ADBOT LOVES YOU

overmind2000
Nov 6, 2007

I'm an alien.


dud root posted:

Any recommendations for a Youtube downloader extension? I've tried a couple but they dont do 1080p

I'm partial to YouTube Video and Audio Downloader, which can do 1080p. The instructions don't tell you this exactly but after it downloads ffmpeg you need to point it to the exact location of the exe file, otherwise it will download the video and audio separately.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply
«252 »