Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
  • Post
  • Reply
sobkas
Oct 11, 2012


Ddraig posted:

Ok, I think I've figured out the problem. It's more to do with Misery's weird class system than anything else. To install:

Make sure you're properly patched up to 2.0.2 QF. This is the 2.0.2 patch with the quick fix applied ontop of it, not just one or the other.

Then copy the folders from the "base" folder in the hotfix into the misery gamedata folder. Overwrite everything.

Then start up the game, and change your class at least once using the ingame system. If it's installed properly, it should have "rev 2" somewhere in the version on the main menu.
You mean rev. B?

Ddraig posted:

This is a pain in the rear end, but I blame MDT. If you still get any crashes, tell me what the error log says and I'll try my best to fix them.

e: I'm incorporating the Unofficial CoP patch with the hotfix aswell, which is a patch that should be the standard for any CoP mod.

Are You also incorporated a "Various weapon fixes for Misery" aka Weapon_addon_for_Misery2.0.2.zip?
It would be nice.

sobkas fucked around with this message at Oct 9, 2013 around 00:10

Adbot
ADBOT LOVES YOU

sobkas
Oct 11, 2012


Ddraig I have problem with a Missery, patched with Your hotfix.
After I try to examine Stingray 5 in the swamp in Zaton(not helicpoter 5, sorry ), nothing happens. No cut-scene, no completed quest, nothing.
Do you know anything about it?

sobkas fucked around with this message at Nov 13, 2013 around 09:56

sobkas
Oct 11, 2012


Ddraig posted:

Where is Helicopter 5 located? I'll look into it.

I could swore that I have started from a clean, fully patched Misery(with your addons).
But after playing for some time, all the saves that I have checked show this problem, while new game don't.
New game time again.
Thanks for Your time, but it looks like it's my fault.
Sorry.

sobkas
Oct 11, 2012


gggiiimmmppp posted:

Where's the misery ammo in Jupiter now? The medic doesn't sell anything violent.

I have the same problem, does anyone knows how to fix it?
I have installed a Ddraig hotfix already.

edit:
He doesn't restock, after buying everything from him he doesn't put new stuff for sell.
Even after a reload.

edit 2:I have a question.
Does "configs/scripts/jupiter/jup_b202_stalker_medic.ltx" need a "trade" set to "configs/misc/trade/trade_jup_b202_stalker_medic.ltx" ?

Trader in zaton does, so it looks strange that one in jupiter doesn't.
edit 3:
I have checked it and it fixes the problem, might need more testing but for now there is my patch:
http://goo.gl/EufSV7
I think that tremor need a similar patch:
http://goo.gl/ndC0wx

If have any problems with a patch
http://docs.moodle.org/dev/How_to_apply_a_patch

sobkas fucked around with this message at Dec 2, 2013 around 01:34

sobkas
Oct 11, 2012


Justin Time! posted:

So in Misery 2.0.2 with the Hotfix patch, the Evolution-9 silencers don't work for my GSh-18, even though it is 9x19 mm and I have upgraded it to have a silencer affinity, what gives?

EDIT: Apparently a 9x18 mm silencer works on the GSh-18, even though it uses 9x19 mm ammo.

Misery 2.0.2 fixes this as in:

quote:

Following weapons now use proper types of silencers:
GSH-18,...
Are you using a savefiles line that started before You patched misery to 2.0.2?

In file
configs/weapons/upgrades/w_gsh18_up.ltx
what value is in silencer_name?
Is it wpn_addon_silencer_9x18 or wpn_addon_silencer_9x19?

edit:

ddraig what you think about :
http://forums.somethingawful.com/sh...6#post422563788

sobkas fucked around with this message at Dec 3, 2013 around 16:02

sobkas
Oct 11, 2012


Ddraig posted:

The version of the Hotfix I made includes a weapon overhaul. I believe silencers were changed during this.


File configs/weapons/upgrades/w_gsh18_up.ltx was only changed in Misery patch 2.0.2
So I would say, no it wasn't, at least for gsh18.

Ddraig posted:

This is the final version. Medics should now trade properly. Can't guarantee that they'll do so in existing save games, but new ones will work normally.


I tested it with an existing savegame and it worked.
I think I will update trade_jup_b202_stalker_medic.ltx to make him provide more medical supplies.

sobkas fucked around with this message at Dec 3, 2013 around 17:21

sobkas
Oct 11, 2012


Justin Time! posted:

Well, it is wpn_addon_silencer_9x18 in my config, but I'm pretty sure I installed the 2.0.2 + QF before installing the Hotfix. Also, I started a new save just for the Hotfix too!

There is something wrong with Your Misery install. I think, that patch 2.0.2 didn't applied properly. Maybe You should start with clean COP and try again?

sobkas
Oct 11, 2012


Acquire Currency! posted:

Ddraig, was it you or someone else that had a music fix for Misery? I'd kinda like having the whole song play instead of 20 seconds of it.

There is a music mix:
http://forums.somethingawful.com/sh...4#post419567870
I had some problems with it...

Filenames of ogg files contain characters that somehow breaks sound_theme.script. Renaming them and then correcting sound_theme.script fixed this problem for me.

sobkas fucked around with this message at Dec 15, 2013 around 07:29

sobkas
Oct 11, 2012


Missing Name posted:

Huh, that's odd... I got them to work with my install. What kind of characters were verbotten?

If I remember correctly: spaces, apostrophes, periods. Only numbers, letters and underscores didn't caused any problems.
Take a look at this script: http://goo.gl/gzymJB .

edit:
On the side note, does anyone have a crash while changing ots33 to 9x19?

sobkas fucked around with this message at Dec 23, 2013 around 13:28

sobkas
Oct 11, 2012


You can download Lost Alpha http://www.moddb.com/mods/lost-alpha from:

Part1: http://www.moddb.com/downloads/start/68782/all
Part2: http://www.moddb.com/downloads/start/68784/all
Part3: http://www.moddb.com/downloads/start/68780/all
Part4: http://www.moddb.com/downloads/start/68776/all
Manual: http://www.moddb.com/downloads/start/68745/all
OST: http://www.moddb.com/downloads/start/68768/all

sobkas fucked around with this message at Apr 27, 2014 around 15:37

Adbot
ADBOT LOVES YOU

sobkas
Oct 11, 2012


I have a specific problem and I need to prevent BugTrap.dll from catching crashes(so I can use gdb to debug). Is there a way to do that?
Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply