Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«462 »
  • Post
  • Reply
OwlFancier
Aug 22, 2013

You see it works on two levels because the collective noun for owls is a parliament and also he's an idiot.


bigperm posted:

What about 1.8 makes you want to play it over 1.7.10?

Much nicer world gen, I like building on hills and 1.8 worldgen gives you a lot of plateus to build on.

Adbot
ADBOT LOVES YOU

Alkydere
Jun 7, 2010
Capitol: A building or complex of buildings in which any legislature meets.
Capital: A city designated as a legislative seat by the government or some other authority, often the city in which the government is located; otherwise the most important city within a country or a subdivision of it.

OwlFancier posted:

There don't appear to be any useful mods like tinkers, or any of the factory style mods available for 1.8 either.

I don't get why everyone has such a hard on for 1.7

Because a lot was changed in the back-end to make the game run better, therefore modders look at it and go "More work? Ew."

bigperm
Jul 10, 2001
some obscure reference

El Generico posted:

Frankly it sounds like the performance improvements would be worth it in and of themselves.

I can't play any of these big modpacks without my FPS chugging and stuttering, and I've got a perfectly fine gaming PC.

Fastcraft and CoFHTweaks are basically backports of the 1.8 optimizations. They do similar things but one may work better than another for you. Fastcraft works better for me.

OwlFancier posted:

Much nicer world gen, I like building on hills and 1.8 worldgen gives you a lot of plateus to build on.

If you like hills, check out Alternate Terrain Generation. It was too hilly for me.

bigperm fucked around with this message at May 30, 2015 around 04:02

Digirat
Sep 14, 2011

stinking
rat-vole
rodent
piece of
TRASH


Against better judgment I reinstalled this with the latest version of OMP-i, all mods enabled, and the game crashes anytime I click "mod options" which is kind of a problem because there's over 200 mods and I'm probably going to want to change some of them. Is this a feature of the pack or have I done something wrong.

SugarAddict
Oct 11, 2012


Gestalt Intellect posted:

Against better judgment I reinstalled this with the latest version of OMP-i, all mods enabled, and the game crashes anytime I click "mod options" which is kind of a problem because there's over 200 mods and I'm probably going to want to change some of them. Is this a feature of the pack or have I done something wrong.

You can remove mods, you simply won't be able to play on the server. You could ask the modpack author for SP configs as well.

30.5 Days
Nov 19, 2006

Love me!


McFrugal posted:

Are you using 2.0.3a? I thought the HQM party issues were sorted out with NoTimeFix.

Wylker & Maiden were really key to us getting a lot of stuff fixed up for 2.0.4e, including the NoTimeFix. They're doing the smart thing where there's a 3 week lag time on videos.

Maiden
Mar 18, 2008



I'm enjoying blightfall, it's encouraged me to get serious with a mod I've ignored since TC2, where it was total rear end and put me off the mod for years. Pretty dissapointed that TC5's current future is going back to TC2

Truga
May 4, 2014


Lipstick Apathy

Uhhh anyone knows how botania mana fabricator from the technomancy mod works?

e: nvm figured it out, just put a mana spreader above it.

I finished my controller script for OC. I think someone here wanted it. I'm in the process of tuning the pid values, then I'll post it on pastebin or somesuch.

Truga fucked around with this message at May 30, 2015 around 15:50

MacGyvers_Mullet
Sep 5, 2006

The guilty pay the price.


SugarAddict posted:

Have you played with the graphics settings or the java runtime strings at all?

What specific runtime strings would you recommend? I've tried several different ones and they had a negligible effect on performance. I can get used to 1.7 as long as I don't boot up any 1.6 packs for a few days, but if I dip back into 1.6 to play my old Agrarian Skies 1 map or something it's staggering how much worse 1.7 runs across the board.

The FPS counter will tell me it's running at a stable 150 in 1.7, but it's a stuttery mess any time I look around or move. It's a mess I can get used to and convince myself isn't a problem after a few hours, but it's not even remotely close to the wonderfully fluid 144 fps I got in every single 1.6 modpack. I have a GTX 970 and an i5-4690k, so it's not a system requirements issue.

OwlFancier
Aug 22, 2013

You see it works on two levels because the collective noun for owls is a parliament and also he's an idiot.


bigperm posted:

If you like hills, check out Alternate Terrain Generation. It was too hilly for me.

Hmm, that looks interesting. I also like the lighting fixes from 1.8 seeing as I spend most of my time building things but that looks quite nice.

Are there any lightweight-ish themed modpacks about? Something without a million different but similar mods, but still with a few things that make building a bit easier and give you ways to get materials by building nifty machines?

Essentially I'm after something like the old industrialcraft or thaumcraft mods.

Threep
Apr 1, 2006

It's kind of a long story.

MacGyvers_Mullet posted:

What specific runtime strings would you recommend? I've tried several different ones and they had a negligible effect on performance. I can get used to 1.7 as long as I don't boot up any 1.6 packs for a few days, but if I dip back into 1.6 to play my old Agrarian Skies 1 map or something it's staggering how much worse 1.7 runs across the board.

The FPS counter will tell me it's running at a stable 150 in 1.7, but it's a stuttery mess any time I look around or move. It's a mess I can get used to and convince myself isn't a problem after a few hours, but it's not even remotely close to the wonderfully fluid 144 fps I got in every single 1.6 modpack. I have a GTX 970 and an i5-4690k, so it's not a system requirements issue.
Stuttering messes are usually memory related, with a beefy system are you maybe giving it too much memory? On a typical modpack 2GB is plenty. edit: 2GB for a typical HQM pack, 3GB for most kitchensink packs and 4GB if you're trying to run every mod ever

Most JVM flags people recommend don't actually do anything, especially on Java 8, but try this:
code:
-XX:+UseConcMarkSweepGC -XX:+UseFastAccessorMethods -XX:+AggressiveOpts
Also as mentioned make sure to use either Fastcraft or CoFHTweaks. 1.7 should be smooth as butter on a system like yours except when there's badly behaved mods involved.

edit: dug out the correct flags for Java 8

Threep fucked around with this message at May 30, 2015 around 16:59

Doorknob Slobber
Sep 10, 2006





MacGyvers_Mullet posted:

What specific runtime strings would you recommend? I've tried several different ones and they had a negligible effect on performance. I can get used to 1.7 as long as I don't boot up any 1.6 packs for a few days, but if I dip back into 1.6 to play my old Agrarian Skies 1 map or something it's staggering how much worse 1.7 runs across the board.

The FPS counter will tell me it's running at a stable 150 in 1.7, but it's a stuttery mess any time I look around or move. It's a mess I can get used to and convince myself isn't a problem after a few hours, but it's not even remotely close to the wonderfully fluid 144 fps I got in every single 1.6 modpack. I have a GTX 970 and an i5-4690k, so it's not a system requirements issue.

I've found that sometimes, specific mods cause weird issues and I'll have a lot of FPS problems until I just remove one mod. Its weird, but maybe try removing mods you don't really want to use until it calms down?

Truga
May 4, 2014


Lipstick Apathy

http://pastebin.com/adKG8q39

It's not very good, but it works for now. Also, not tested with passive reactor but should work. You can plug n reactors and turbines to it.

Also, that ez nuke script looks cool. Unfortunately, CC isn't in omp-i, and I don't think I'm good enough at this yet to fix it.

Truga fucked around with this message at May 30, 2015 around 17:34

MacGyvers_Mullet
Sep 5, 2006

The guilty pay the price.


Thanks for the advice - I'm running the OMP-i pack at 4GB, which has fastcraft installed. I tried the arguments and bumped it down to 3GB, but they didn't make much of a difference. As for the FPS, that's the thing that's so weird about it - my FPS is really high according to the game, like 150+ high, but it's not smooth at all. When I cap it at something lower like 60 FPS it looks like it's running at 15 even though Minecraft insists it's a stable 60. I might try disabling packs one at a time, but it's been this way with every single modpack I've tried in 1.7.

It's playable if I leave the framerate uncapped because 150 FPS looks and feels like 30-45 FPS with some micro-stuttering, but I can't help but feel like something is really broken on my end if 60 FPS looks like 15.

Khorne
May 1, 2002

Goonstone Champ x2

MacGyvers_Mullet posted:

What specific runtime strings would you recommend? I've tried several different ones and they had a negligible effect on performance. I can get used to 1.7 as long as I don't boot up any 1.6 packs for a few days, but if I dip back into 1.6 to play my old Agrarian Skies 1 map or something it's staggering how much worse 1.7 runs across the board.

The FPS counter will tell me it's running at a stable 150 in 1.7, but it's a stuttery mess any time I look around or move. It's a mess I can get used to and convince myself isn't a problem after a few hours, but it's not even remotely close to the wonderfully fluid 144 fps I got in every single 1.6 modpack. I have a GTX 970 and an i5-4690k, so it's not a system requirements issue.
if the pack has journeymap and a million other mods (including fastcraft) try removing journeymap and seeing what happens. I have a similar system and journeymap tanks my fps from like 200 down to 5-20.

If you want to have journeymap enabled you need to disable caves, and go into the advanced options and raise every delay by a ton for whatever reason. Even then, sometimes it will cause minecraft to run at 0-1 fps while you explore. And it will definitely tank your fps down to like 40-50 if you have a base and mine out a ton of stuff near it even with caves off. Like if you're in the same base for 40-80 hours journeymap alone will wreck your fps. It won't be the machines you built, it will just be that dumb minimap mod.

People always say it's the webmap, but webmap on or off doesn't impact my fps at all. I can literally run a 200+ mod server for 4 people + minecraft on my computer and get relatively normal fps in minecraft, but if I have journeymap on and no server we're going down to single digits eventually.

I like journeymap's functionality, but until that is fixed I just remove it from any pack that has it as soon as I find somewhere I want to build a base at. It might just have a bad interaction with one of the more popular mods, but it has happened to me in a ton of different mod packs. For whatever reason it just goes nuts and dominates my cpu.

Khorne fucked around with this message at May 30, 2015 around 18:04

Threep
Apr 1, 2006

It's kind of a long story.

MacGyvers_Mullet posted:

Thanks for the advice - I'm running the OMP-i pack at 4GB, which has fastcraft installed. I tried the arguments and bumped it down to 3GB, but they didn't make much of a difference. As for the FPS, that's the thing that's so weird about it - my FPS is really high according to the game, like 150+ high, but it's not smooth at all. When I cap it at something lower like 60 FPS it looks like it's running at 15 even though Minecraft insists it's a stable 60. I might try disabling packs one at a time, but it's been this way with every single modpack I've tried in 1.7.

It's playable if I leave the framerate uncapped because 150 FPS looks and feels like 30-45 FPS with some micro-stuttering, but I can't help but feel like something is really broken on my end if 60 FPS looks like 15.
Minecraft's frame limiting is very broken, don't use it.

If you're playing single player you could try using something like Admin Commands to force full generation of the immediate area and see if it's worldgen giving you trouble.

Khorne posted:

I like journeymap's functionality, but until that is fixed I just remove it from any pack that has it as soon as I find somewhere I want to build a base at. It might just have a bad interaction with one of the more popular mods, but it has happened to me in a ton of different mod packs. For whatever reason it just goes nuts and dominates my cpu.
There's a beta Journeymap that's supposed to be much more optimized.

Khorne
May 1, 2002

Goonstone Champ x2

Threep posted:

There's a beta Journeymap that's supposed to be much more optimized.
Nice. It seems like a well thought out mod that doesn't have the annoying anti-features of the other popular minimap mods. I've never had any issues with it beyond the inevitably taking a chainsaw to my fps thing.

Cantorsdust
Aug 9, 2008

Infinitely many points, but zero length.

Top Cop

This is an esoteric question, but if anywhere knows the answer, it's here. When I mine Artifice's recolored ores, they are supposed to drop the corresponding non-colored ore, eg dark-colored copper ore block drops normal copper ore. Problem is, they're dropping Forestry copper ore when I'm trying to configure it so that only Thermal Expansion copper ore is generated so that I don't have to do any bullshit converting or stacking. Is there any way to change this?

Syenite
Jun 21, 2011

oh, what a day


Grimey Drawer

Cantorsdust posted:

This is an esoteric question, but if anywhere knows the answer, it's here. When I mine Artifice's recolored ores, they are supposed to drop the corresponding non-colored ore, eg dark-colored copper ore block drops normal copper ore. Problem is, they're dropping Forestry copper ore when I'm trying to configure it so that only Thermal Expansion copper ore is generated so that I don't have to do any bullshit converting or stacking. Is there any way to change this?

Short-term answer: Try making the forestry jar come after the TE ones alphabetically

Long-term answer: in the works

Musluk
May 23, 2011

AGDQ 2018 Awful Block Survivor Victim



Lipstick Apathy

Maiden posted:

I'm enjoying blightfall, it's encouraged me to get serious with a mod I've ignored since TC2, where it was total rear end and put me off the mod for years. Pretty dissapointed that TC5's current future is going back to TC2

I tried the same, but Thaumcraft changed a lot since I last played, so I got stumped instead.

THE PENETRATOR
Jul 27, 2014

by Lowtax


Which mod is it that puts a button in crafting that lets you swap between ore-dictionary outputs so you don't have to have awful stack issues?

Cantorsdust
Aug 9, 2008

Infinitely many points, but zero length.

Top Cop

Shukaro posted:

Short-term answer: Try making the forestry jar come after the TE ones alphabetically

Long-term answer: in the works

No luck. I get what you mean, looks like the mod defaults to the first mod that comes alphabetically. Problem is that I think mod names are internal, and renaming ThermalDynamics/foundation/etc to aThermal... doesn't work. The mod name is still Thermal Foundation in this case.

edit: but thanks for the rapid reply anyway!

Taffer
Oct 15, 2010



alternate answer: remove forestry

Cantorsdust
Aug 9, 2008

Infinitely many points, but zero length.

Top Cop

Taffer posted:

alternate answer: remove forestry

I would, but bees...

Also I'd have to remove Galacticraft and Tinker's Construct too before it would get down to Thermal Foundation.

Falcon2001
Oct 10, 2004

Eat your hamburgers, Apollo.

If two recipes have the same output, is there a way to force one or the other? In OMP-i, both copper pipes and temperate fluiducts have the same recipe.

Syenite
Jun 21, 2011

oh, what a day


Grimey Drawer

Falcon2001 posted:

If two recipes have the same output, is there a way to force one or the other? In OMP-i, both copper pipes and temperate fluiducts have the same recipe.

You have to use minetweaker/modtweaker for that.

Threep
Apr 1, 2006

It's kind of a long story.

Falcon2001 posted:

If two recipes have the same output, is there a way to force one or the other? In OMP-i, both copper pipes and temperate fluiducts have the same recipe.
Use a recipe changing tool (mainly MineTweaker) to change one of the recipes.

http://minetweaker3.powerofbytes.co...l:Basic_Recipes

Falcon2001
Oct 10, 2004

Eat your hamburgers, Apollo.

Thanks for the quick response, I'm just going to make the opaque ones instead :p

Killer-of-Lawyers
Apr 22, 2008


I really hope that pid script that cycles every tick doesn't bring the tps to a screaming halt on omp's server. It's bad as is.


Also hello Wylker, I'll let you know when the playlist is up. Love you, kissy kissy.

taiyoko
Jan 10, 2008



Gestalt Intellect posted:

Against better judgment I reinstalled this with the latest version of OMP-i, all mods enabled, and the game crashes anytime I click "mod options" which is kind of a problem because there's over 200 mods and I'm probably going to want to change some of them. Is this a feature of the pack or have I done something wrong.

I only had that problem when I'd try to use the mod options while a world was running. Opening the mod options from the main menu was fine. TBH, there's not a lot that you can configure from it anyway, most of it you're still going to need to exit Minecraft and edit config files to make changes.

Interesting that even with setting Morph's option to make it that if you're morphed into a hostile mob then other hostile mobs don't attack doesn't work on spiders. Disguised as a zombie, zombies and skeletons leave me be, but spiders? Nope. I think that might be working as designed, though.

Falcon2001
Oct 10, 2004

Eat your hamburgers, Apollo.

Is anyone else unable to get Steam Dynamos to output energy in OMP-i? It's got water/etc and has stored it, but won't output to a leadstone energy cell or cable.

bigperm
Jul 10, 2001
some obscure reference

Falcon2001 posted:

Is anyone else unable to get Steam Dynamos to output energy in OMP-i? It's got water/etc and has stored it, but won't output to a leadstone energy cell or cable.

Sometime it will hold RF if it doesn't have any fuel. Add some fuel and it will dump it all out.

Otherwise make sure the energy cell is accepting (blue) on the side connected to the dynamo.

Weembles
Apr 19, 2004



Falcon2001 posted:

Is anyone else unable to get Steam Dynamos to output energy in OMP-i? It's got water/etc and has stored it, but won't output to a leadstone energy cell or cable.

I know they worked fine a couple of days ago, but I haven't used them at all since I got my reactor working.

THE PENETRATOR
Jul 27, 2014

by Lowtax


Falcon2001 posted:

Is anyone else unable to get Steam Dynamos to output energy in OMP-i? It's got water/etc and has stored it, but won't output to a leadstone energy cell or cable.

They don't output their energy unless they are actively burning fuel or have > 2,000 mB of steam.

Falcon2001
Oct 10, 2004

Eat your hamburgers, Apollo.

Thanks, that was it. Weird.

Cerepol
Dec 2, 2011



Cicadalek posted:

I always end up using TC in packs like Hexxit/ OMP Sigma because it's a good way to get armor that can repair itself instead of just falling apart in one battle tower.

I feel like a lot of mods offer decent options for weapons, but armor is just vanilla armor with different values. What does an "endgame" armor setup look like in something like Sigma?

A bit late but the blood magic ultimate armour is very expensive but is ridiculous. You can customize it. My favorite is aside from invincibility and haste and speed and flying it also fine night vision and rapid plant growth. Feels great to go anywhere and have plants pop up to maturity

MacGyvers_Mullet
Sep 5, 2006

The guilty pay the price.


Threep posted:

Minecraft's frame limiting is very broken, don't use it.

If you're playing single player you could try using something like Admin Commands to force full generation of the immediate area and see if it's worldgen giving you trouble.

There's a beta Journeymap that's supposed to be much more optimized.

Thanks again for helping me troubleshoot the FPS issues. I wasn't able to fix the problem myself (I couldn't figure out how to get COFH tweaks into the OMP-i pack myself yesterday without it crashing), but when I booted up OMP-i this afternoon and ran the update that replaced fastcraft with COFH Tweaks the problem evaporated.

I did a couple of tests alternating between fastcraft, COFH tweaks, and neither with no other mods installed. Fastcraft got rid of a lot of the chunk generation lag, but once it was generated it made minecraft report a high framerate, but after using an external program to record the framerate it was exceeding my monitor's 144 hz limit but bottoming out at 15 FPS for about a quarter of a second every couple of seconds, which is probably why I was being driven crazy by the stuttering, and why it didn't look anything like a real 144 FPS. It was driving me crazy enough that I was considering just migrating back to 1.6 until now.

COFH tweaks is so much better. I'm glad someone finally made a replacement for that hacked-together, closed source shitshow.

Inexplicable Humblebrag
Sep 20, 2003



Falcon2001 posted:

Thanks, that was it. Weird.

I have been vexed by it before but it's probably a bit more efficient and nicer on servers. Like, presumably the network won't keep polling them for "hey, got any energy? got any energy?" unless they are actually active.

StealthArcher
Jan 10, 2010

Setzer...

It was nice to meet you.


Goodbye.


Nap Ghost

So Mine/ModTweaker doesn't seem able to modify Thermex recipes for the machines anymore. Anybody ever worked with adding them another way? *is* there another way?


E: Yes, this was tried with most recent updates with both, B:AllowRecipeOverwrite=true is set for all the relevant machines.

Adbot
ADBOT LOVES YOU

Truga
May 4, 2014


Lipstick Apathy

After the last omp i update that replaced fastcraft with CoFHtweaks one of my friends now gets like 3fps everywhere. Also, I get a choppier experience as world keeps loading and unloading when I'm looking around myself.

Are there any configs/settings I should be looking at to try and fix these issues?

These things also keep popping up:



Should I completely nuke my settings?

Truga fucked around with this message at May 31, 2015 around 20:00

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply
«462 »