Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«26 »
  • Post
  • Reply
Happy_Misanthrope
Aug 3, 2007

"I wanted to kill you, go to your funeral, and anyone who showed up to mourn you, I wanted to kill them too."

FCKGW posted:

Do you have any guides you used? I'm trying to get an Intel NUC up and running myself and failing spectacularly

Yeah, basically this. Note it's centered around Mojave, but the follow-up post details the changes necessary for Catalina.

What problems are you running into specifically? I did have some post issues such as a purple screen and the occasion prohibited sign with booting that I figured out that you may run into, but that should be enough to get you to a working desktop at least.

Adbot
ADBOT LOVES YOU

Binary Badger
Oct 11, 2005

Trolling Link for a decade



Should stick with Mojave, all Catalina will do is make you wait for Mac vendors to upgrade all their software to 64-bit, which for some packages ain't never gonna happen.

There's already one financial software vendor with a popular Mac app who says they tried a mighty effort to upgrade their 32-bit program to 64-bit but just couldn't do it (or their eyeballs fell out ah--ooogah style when they saw how much they'd have to pay the software architects to do the upgrade.)

Mojave is at least still receiving security updates and is fairly stable; Catalina is like a Jenga game being played during intermittent earthquake activity, you don't know when it'll suddenly collapse / seize up for whatever reason.

FCKGW
May 21, 2006

aaaaaaaaaa
AAAAAAAAAAA
HHHHHHHHH!!!!!!!!



Happy_Misanthrope posted:

Yeah, basically this. Note it's centered around Mojave, but the follow-up post details the changes necessary for Catalina.

What problems are you running into specifically? I did have some post issues such as a purple screen and the occasion prohibited sign with booting that I figured out that you may run into, but that should be enough to get you to a working desktop at least.

Perfect, thanks. I had initial issues booting off a USB drive but it looks like it was just a bad drive or something. Got it installed but trying to get the EFI copied over and booting off the SSD without the USB plugged in failed as well.

Iím just gonna blow it up and use this guide instead.

Happy_Misanthrope
Aug 3, 2007

"I wanted to kill you, go to your funeral, and anyone who showed up to mourn you, I wanted to kill them too."

Binary Badger posted:

Mojave is at least still receiving security updates and is fairly stable; Catalina is like a Jenga game being played during intermittent earthquake activity, you don't know when it'll suddenly collapse / seize up for whatever reason.

Well, not on my build just yet but I haven't done anything particularly taxing yet. Probably actively used it for ~30 hours total, never one crash. We'll see as time goes on.

Happy_Misanthrope
Aug 3, 2007

"I wanted to kill you, go to your funeral, and anyone who showed up to mourn you, I wanted to kill them too."

Could never get the IoGear BT adapter working so just got this one, works great.

Happy_Misanthrope fucked around with this message at 03:29 on Feb 13, 2020

Chris Knight
Jun 5, 2002

And I'm only saying this because I care.

There are a lot of decaffeinated brands on the market today that are just as tasty as the real thing.



Fun Shoe

You can check the chipset in the system information report.

e: wrong name

Chris Knight fucked around with this message at 21:44 on Feb 16, 2020

FCKGW
May 21, 2006

aaaaaaaaaa
AAAAAAAAAAA
HHHHHHHHH!!!!!!!!



I wanted to download a program from tonymacx86 but they have that stupid thing where you have to create a forum account to download a file.
I didn't want to give my email to a random forum () so I used a login posted to bugmenot instead
Tonymacx86 not only killed the bugmenot account they also IP banned anyone that used that login for account sharing so I can't even begrudingly create a new account to download the file.

Some of these tech forum overlords man

Some Goon
Jan 6, 2013

A golden helix streaked skyward from the Helvault. A thunderous explosion shattered the silver monolith and Avacyn emerged, free from her prison at last.



10minutemail my man.

Djarum
Apr 1, 2004

I promise, that one day, everything's going to be better for you.


Soiled Meat

Tonymac has been a lovely place for years. I am kind of surprised anyone still posts there since the guy who runs it has basically been a open shitlord for years.

KOTEX GOD OF BLOOD
Jul 7, 2012



Fallen Rib

the thread OP refers to tonymac as "tonycrap" and it's cheesy but he's right.

LODGE NORTH
Jul 30, 2007




!
___



Also worth noting that following the Vanilla Guide isn't hard at all. It's a fair bit of steps, but honestly, getting into macOS is the easy part - it's figuring out why x doesn't work that's the "hard" part. And using a distro or someone else's config just makes it harder to figure out.

Binary Badger
Oct 11, 2005

Trolling Link for a decade



OpenCore rules, finally I can play Netflix in Safari and get hardware acceleration on my 5,1 enough so 4K vids in Google Chrome run smooth as butter with only slight buffering with my Pulse 580 Nitro.

~Coxy
Dec 9, 2003

R.I.P. Inter-OS Sass - b.2000AD d.2003AD

Trying to get the Catalina installer to boot, looking at the verbose boot log I can't even get past the pre-boot step.
(Apologies for the vagueness, not sure what it's called but it's a clearly different type of logging and it's trying to get the boot volume .dmg)

Am I missing something simple?
Z370, 8700, latest clover and 10.15.4 boot USB.

otter
Jul 23, 2007
word.

~Coxy posted:

Trying to get the Catalina installer to boot, looking at the verbose boot log I can't even get past the pre-boot step.
(Apologies for the vagueness, not sure what it's called but it's a clearly different type of logging and it's trying to get the boot volume .dmg)

Am I missing something simple?
Z370, 8700, latest clover and 10.15.4 boot USB.

What graphics are you using? Ram configuration?
Some 370 boards are picky about memory configuration during install.
Can you be more detailed on your specs?
Manufacturer and model?
Amount of ram, what slots they are in? (Believe it or not, this can matter)
is it actually halting?
What does the error say if you have one?

~Coxy
Dec 9, 2003

R.I.P. Inter-OS Sass - b.2000AD d.2003AD

Thanks for the reply, if it makes any difference I have High Sierra working fine at the moment.

What graphics are you using? Intel iGPU
Can you be more detailed on your specs?
Manufacturer and model? Gigabyte Z370XP SLI
Amount of ram, what slots they are in? (Believe it or not, this can matter) 2x8GB slots 1&3
is it actually halting? Yes, last log line is that weird ++++++++++++++++++++++++++++++++++++++++++++++++++
What does the error say if you have one? Couldn't find any google-able errors. It's the weird log where things are preceded with [EB|xxxxxxx] I can try to capture a legible photograph...

---

VVV good point, it was F5 which is well out of date so I will update it to latest (F15.)

~Coxy fucked around with this message at 04:37 on Apr 1, 2020

otter
Jul 23, 2007
word.

~Coxy posted:

Thanks for the reply, if it makes any difference I have High Sierra working fine at the moment.

What graphics are you using? Intel iGPU
Can you be more detailed on your specs?
Manufacturer and model? Gigabyte Z370XP SLI
Amount of ram, what slots they are in? (Believe it or not, this can matter) 2x8GB slots 1&3
is it actually halting? Yes, last log line is that weird ++++++++++++++++++++++++++++++++++++++++++++++++++
What does the error say if you have one? Couldn't find any google-able errors. It's the weird log where things are preceded with [EB|xxxxxxx] I can try to capture a legible photograph...

Also, what bios version do you have installed? That can cause these halts in the install. I had to roll back on mine from the newest one to a few versions back.

~Coxy
Dec 9, 2003

R.I.P. Inter-OS Sass - b.2000AD d.2003AD

Boot log:

mayodreams
Jul 4, 2003


Hello darkness,
my old friend


I'm getting the same problem with the catalina installer on my x570 build using the configs from amd-osx.

OC 5.5
Catalina 15.4

~Coxy
Dec 9, 2003

R.I.P. Inter-OS Sass - b.2000AD d.2003AD

Maybe it's a 10.15.4 thing specifically?
I might try to find a download of say 10.15.2.

otter
Jul 23, 2007
word.

~coxy are you also using opencore?
I installed using clover and 10.15.1. I did not encounter these issues.

~Coxy
Dec 9, 2003

R.I.P. Inter-OS Sass - b.2000AD d.2003AD

I was using Clover but will give OpenCore a shot also.

~Coxy
Dec 9, 2003

R.I.P. Inter-OS Sass - b.2000AD d.2003AD

Downloaded 10.15.2.app and re-built my USB. The installer booted easily with Clover, I haven't actually tried installing it yet but obviously that will be my next step.

So to mayodreams I suggest downloading an old version of Cata installer.

mayodreams
Jul 4, 2003


Hello darkness,
my old friend


I came to the same realization too. Using the older version of Catalina and doing my config from scratch in OC 5.6 worked.

I have a few things to sort, but I just wanted to know if it worked or not. My only supported GPU is a GTX 680 that I had to mod the firmware to even boot EFI, and its pretty pokey on a modern version of Mac OS with only 2gb of VRAM and a 4k monitor.

otter
Jul 23, 2007
word.

i had been stuck at 10.15.1 and super frustrated that I couldn't update. So I finally ended updating clover and once I did that, bang! updated to 10.15.2 and then 10.15.4 incrementally with no problems whatsoever.

~Coxy
Dec 9, 2003

R.I.P. Inter-OS Sass - b.2000AD d.2003AD

All upgraded.

I had issues booting into my upgraded disk with 5700XT installed. (black screen after boot)
This seems to have been caused by having an old Clover on the same disk, even though that Clover wasn't being used to boot.
I booted into a fresh install of Catalina on another disk (no black screen issues), upgraded Clover on the EFI partition on my system disk, and was fine after that.

mayodreams
Jul 4, 2003


Hello darkness,
my old friend


I ended up doing a deep dive into OpenCore today and have a way better understanding of how this stuff works now.

I also found there is an open source project to control AIO coolers and some fan controllers that works in Catalina, which is amazing for my NZXT heavy setup.

Now I'm just waiting for RDNA2 and Ampere (or whatever NV is calling it) to see what my next step is because even though HS works with my 1080, a lot of stuff doesn't, like liquidctl.

otter
Jul 23, 2007
word.

i just want to be able to install Sierra in Virtualbox. It has not been going well. I need to transfer my old system to a virtual machine so i can keep all my installed apps and whatnot / keep my ability to print.

~Coxy
Dec 9, 2003

R.I.P. Inter-OS Sass - b.2000AD d.2003AD

I'm having trouble with builtin audio. As far as I can tell the issue might be that AppleALC kext isn't being loaded?

I run `kextstat | grep -v com.apple` and it's not listed. (Neither is WhateverGreen, although Lilu is.)
I have confirmed that the latest version is installed in /EFI/CLOVER/kexts/10.15

Trawling forum posts shows some people with no success until they put the kext into /S/L/E, which obviously involves disabling SIP.
Would prefer to remain vanilla...

Pardot
Jul 25, 2001


What's the process for trying out open core from a working clover system? Would it be possible to put the open core efi on a usb drive and try booting form that over and over instead of the clover efi on my internal drive?

~Coxy
Dec 9, 2003

R.I.P. Inter-OS Sass - b.2000AD d.2003AD

I haven't used OpenCore but I can't see why that wouldn't work.

Pardot
Jul 25, 2001


Just for context: I'm new to this, just built mine in January. Had been having some hard lock ups that my have been due to the newish rx5700xt not having the best drivers on 10.15.3 and before. My upgrade to 10.15.4 was mostly good and has seemed to have solved that. However the upgrade failed at some last step and it left the install partition around. But after booting it showed that it had upgraded. Then after the first reboot after that, it could no longer boot because it could no longer decrypt the filevault drive. I had to manually decrypt the drive from the recovery partition terminal.

I'd like to go back to full disk encryption, and it seems like one of the selling points of open core is that it handles that better, but idk.

KOTEX GOD OF BLOOD
Jul 7, 2012



Fallen Rib

In case someone ITT is interested, I'm selling an osxwifi PCI-E card for native wifi and bluetooth.

Crunchy Black
Oct 24, 2017

CASTOR: Uh, it was all fine and you don't remember?
VINDMAN: No, it was bad and I do remember.




This isn't *really* hackintoshy but I figured this would be the most knowledgable place to ask, am I going to nuke my install on my 3,1 if I let it upgrade to Catalina? SSD, 32GB RAM, APFS (non-encrypted).

Moogs
Jan 25, 2004

Proceeds the Weedian... Nazareth

I recently sold my Vive, so there was no reason to have my GTX 1070 in my Hackintosh anymore. I replaced it with an RX 580 and upgraded to Catalina (had been stuck on High Sierra because Apple stopped supporting Nvidia cards) and a LOT of my minor issues are fixed -- Airplay audio doesn't randomly pause anymore, Airplay video actually works.

However, I haven't yet been able to reactivate all my USB ports. On High Sierra I had both USBInjectAll.kext and XHCI-200-series-injector.kext installed, but they don't seem to be doing the trick in Catalina. Are kexts related to the version of OSX you have installed, or should those work if I can remember the right patches to apply in Clover? I set my machine up 2+ years ago so I'm a bit foggy on what exactly I did... Build is below, any thoughts are appreciated!

Binary Badger
Oct 11, 2005

Trolling Link for a decade



Crunchy Black posted:

This isn't *really* hackintoshy but I figured this would be the most knowledgable place to ask, am I going to nuke my install on my 3,1 if I let it upgrade to Catalina? SSD, 32GB RAM, APFS (non-encrypted).

What's on there right now? You should just download dosdude1's Catalina patcher which will create and patch a USB installer for you and do a clean install by booting from that USB it creates.

LODGE NORTH
Jul 30, 2007




!
___



Moogs posted:

I recently sold my Vive, so there was no reason to have my GTX 1070 in my Hackintosh anymore. I replaced it with an RX 580 and upgraded to Catalina (had been stuck on High Sierra because Apple stopped supporting Nvidia cards) and a LOT of my minor issues are fixed -- Airplay audio doesn't randomly pause anymore, Airplay video actually works.

However, I haven't yet been able to reactivate all my USB ports. On High Sierra I had both USBInjectAll.kext and XHCI-200-series-injector.kext installed, but they don't seem to be doing the trick in Catalina. Are kexts related to the version of OSX you have installed, or should those work if I can remember the right patches to apply in Clover? I set my machine up 2+ years ago so I'm a bit foggy on what exactly I did... Build is below, any thoughts are appreciated!



People usually use USBMap now.

This guy has a video, but as with most videos, some things may be a little different now vs when he made it.

https://www.youtube.com/watch?v=j3V7szXZZTc

Adbot
ADBOT LOVES YOU

Moogs
Jan 25, 2004

Proceeds the Weedian... Nazareth

LODGE NORTH posted:

People usually use USBMap now.

This is awesome, thanks. Somehow in doing a good bit of Googling on the subject, I had never come across this tool, but it helped a lot and was one of the easier tools I've seen in the Hackintosh world.

Hoping that limiting USB ports will fix the stutter I've been seeing over Bluetooth after the system has been on for more than 12 hours or so!

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply
«26 »