Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
«73 »
  • Post
  • Reply
`Nemesis
Dec 30, 2000



Dinosaur Gum

MarcusSA posted:

It still doesnít make any sense though

Iím just trying to understand the reasoning behind it because it only affects the mobile users.

They're fyad-lites, nothing has to make sense 🙂

Adbot
ADBOT LOVES YOU

...!
Oct 5, 2003

You were all (w)right! I shall now consume the world.


What wouldn't make sense is forcing people who regularly use those subforums to constantly turn off caps just for the convenience of people who don't post there much and want to insist on using caps.

The solution is to learn not to use capital letters in yospos, etc., nerd.

Disable the shift keys altogether for those subforums, IMO.

...! fucked around with this message at 04:20 on Feb 22, 2020

MarcusSA
Sep 23, 2007



Grimey Drawer

...! posted:

What wouldn't make sense is forcing people who regularly use those subforums to constantly turn off caps just for the convenience of people who don't post there much and want to insist on using caps.

The solution is to learn not to use capital letters in yospos, etc., nerd.

Disable the shift keys altogether for those subforums, IMO.

That is dumb though!

Its ok I thought it was a bug and its not so I'll just fix the capitalization my self!

Grace Baiting
Jul 20, 2012

Audi famam illius;
Cucurrit quaeque
Tetigit destruens.





MarcusSA posted:

That is dumb though!

Its ok I thought it was a bug and its not so I'll just fix the capitalization my self!
_________________/
ⓜⓐⓡⓒⓤⓢⓢⓐ

abbazabba
Aug 3, 2005
<img alt="" border="0" src="https://fi.somethingawful.com/customtitles/title-abbazabba.gif" /><br />what the crap


Iím seeing weird behavior on YouTube videos- I swear I used to be able to tap on the video and it would open in the app, but now the only way I can get them to play in the YT app is to tap Share, then double-tap the url.

Any ideas?



Ps: THANK YOU for fixing the rotation crashing issue! (At least on my 6s+)

stuffed crust punk
Oct 8, 2004

by LITERALLY AN ADMIN


Awful 4.0 40005 latest iOS

Backgrounding the app and then foregrounding it removes the back button. Not a big deal because I have swipe-right for forums list enabled, but it's a bit tedious if I'm a few thread links deep

Mister Facetious
Apr 21, 2007


You're Goddamned right I support Medicare for all.







How do I attach an image for uploading directly if I don't feel like using imgur?

Keith Atherton
Feb 7, 2006
DOES NOT RESPECT THE RUN



Slippery Tilde

Mister Facetious posted:

How do I attach an image for uploading directly if I don't feel like using imgur?

Since you have platinum long press and choose [img] > From Library and it brings up your photos. I think it goes through imgur but you don't have to deal with the app

pokeyman
Nov 26, 2006

That elephant ate my entire platoon.

Pillbug

Nice I ignored y'all for over a month this time! (Sorry.)

The MUMPSorceress posted:

OK random other thing but can you make gang tags/longvatars show up in the main thread view? Put it behind an option if you have to. It makes me sad I can't see my wizard lady next to my posts

That would be awesome, I'll put it on the list.

Nondevor posted:

Also related to avatar stuff - I didnít realize this until recently, but apparently the default one for new users has changed. On PC itís currently Stupid Newbie with a picture of someone getting punched, but Awful app still shows it as the Trump avatar.

Clearing my cache didnít change any of the displays, so itíd be nice if that was updated eventually!

I haven't paid attention, did this work itself out?

Jeffrey of YOSPOS posted:

I might be able to fix that from my end.

❤️

jackhunter64 posted:

Noticed an issue with the new long press menu on the bookmark page, the Profile option is slightly off the edge of the popup window and can be grabbed and slid around. It's possibly because I'm on an iPhone SE, the same issue doesn't happen when long pressing in the forum page. Happens in dark mode too, screenshotted in light mode for ease of viewing:



Whoops. That menu's long overdue for a rework, so I'll put this on that list

heeheex2 posted:

it'd be nice to have data/wifi toggles for stuff so i don't have to manually turn all the post options off/on every time

Which options are you toggling?

Krazyface posted:

Is there some way I can disable swipe-to-go-back? It seems overly sensitive, and often takes me out of a page without warning because my thumb just absently brushed the screen. I don't want to use this feature ever, the back button is enough for me.

There isn't currently a way to disable that. It is pretty finicky though, often too easy or too hard to do and it doesn't match other apps. I need to figure out what we're doing wrong there.

power crystals posted:

If I leave the app and come back it seems to add a back button that does nothing, at least on ipad. Latest app/iOS as far as I know and this seems recent.

I noticed that too. The code that used to do that was causing crashes when rotating on iOS 13, and what I forgot when I fixed it is that this is why that code was there in the first place. I'll add it to the list!

Midjack posted:

The graphic quotes in this post shows up black on gray background using the OLED dark theme. Clicking on the graphic brings it up with the expected white background.

https://forums.somethingawful.com/s...6#post501987498

I'll take a look.

History Comes Inside! posted:

Tapping any links currently just opens the browser but doesn't load anything, and there's no way to back out of it except force closing the app.

iOS 13.3 and v4.0 of the app

It can be worked around by setting safari as the default browser but I prefer having it in awful with the done button to just make it go away and put me straight back in the thread.

Edit: it just does this



Haven't seen this one pop up in awhile! Good to know it's still a thing. Sorry to say I don't have any bright ideas, but I'll +1 it on the list.

MarcusSA posted:

Ok this is a weird bug and Iíll see if I can explain it correctly.

If I quote someone from a thread and then start to type the first letter is not being capitalized correctly. It doesnít matter how many times I hit return it doesnít do it.

Now! If I just make a new reply no quote the first letter is capitalized correctly.

I have restarted the app and it still does it.

Weird right?

Weird!

email posted:

Any chance we could get the ability to open links in Brave?

Sure!

Bust Rodd posted:

I got an Autoban for posting a thread with a forbidden thread tag. I only post from my phone and the iPhone app doesn't have a warning that tells you "You will be automatically banned for using this tag!" anywhere in the app, so I basically just got owned for $10-40 bucks (if I have to rebuy all my upgrades). Can you please add that warning so phone posters don't GET GOT?

Nah.

OK, a less dismissive response: since the website does it, I'll consider it. Maybe buried somewhere in Settings. Come to think of it, I'm not sure there's a link to the rules anywhere in the app, should probably add one.

Keith Atherton posted:

Maybe a known issue but when scrolling a forum thread list and I trigger the "load next bunch of thread titles" point the view does a disorienting auto scrolling thing and I find myself having to scroll back up to figure out where I was focused

It's meant to just magically load in the next page, but I think it gets confused if any threads changed pages in the meantime. Also possible the "magically load more" bit is hosed. I'll take a look.

Stare-Out posted:

Yeah Iím not quite sure why thread lists arenít divided into pages like threads are, or, the actual forums are.

I'm not really sure how it would work, and unlike posts nobody refers to "that thread on page 3", so it didn't make sense. Though I can see the appeal compared to a broken-rear end "magically load more".

NFX posted:

A couple of days ago my login expired, and when I logged back in a handful of settings were reset. I think it was mostly color schemes etc. is this on purpose?

It's on purpose but not great. I wanted "log out" to double as an "erase everything" button. I think it's reasonable when you specifically ask to log out, but you didn't. It would be nice on session expiry to show some kind of "log back in?" screen that doesn't forget everything if you're the same user. So I'ma add that to the list!

ulvir posted:

is it just on my phone, or might there be an issue with previously stickied threads still hanging around at the top? it's not too big of a deal in general, but places like byob where stickied threads are cycled pretty regularly, this messes up pretty much everything wrt thread sorting

It's not just you, gotta figure this one out. I'll +1 it on the list and thanks for the thorough report!

power crystals posted:

Iím not 100% sure of this and itís not like this is something I can really reproduce, but I think that the last time my phone refreshed the forum list it had one announcement (the transphobia one) and now it has one again (the fast food forum one), but because it missed the narrow window where there were two it failed to mark the new announcement as unread.

Good luck testing that

Announcements really suck. It's impressive how painful their implementation is. Honestly everything else is a piece of cake to scrape.

`Nemesis posted:

I guess the Android app has a search function on the smilies thing, and that sounds really cool and useful.

It's on the list!

Ugly In The Morning posted:

Sometimes when Iím going to a thread from my bookmarks, the ďprevious postĒ button doesnít appear so I have to go back a page and then forward to the one I was on. Is this a known issue?

Does it show up if you scroll down then back up a bit, possibly lifting your finger in between those steps? Or does it just refuse to appear?

teen witch posted:

Weird quirk: not sure if itís the apps or the site itself, but spoilers...donít work with emojis!



They sure don't! I'll add it to the list.

Subjunctive posted:

Handoff from beta app to macOS web browser mis-encodes the page number, so you go to the start of the thread instead of where you were. It has an extra specific wrapping the page number: https://forums.somethingawful.com/s...number=specific(99)

I couldn't quickly find out where that encoding happens.

Whoops! Fixed in next beta. (Was in AwfulRoute.swift at the httpURL property.)

Dicty Bojangles posted:

Ok I figured it out - the issue (on my Xs, anyway) is when you enable "Prefer Cross-Fade Transitions" in Settings > Accessibility > Motion. When that's enabled the Awful app stops working, but when you disable the setting it goes back to working as normal. So I guess cross-fade makes Awful cross-eyed.

gently caress me that's a great catch. Thanks! Sorry for the pain, I'll figure out what the hell's going on and fix it up.

Grace Baiting posted:

On iOS, if I start swiping from the right edge of the screen on the Forums or Bookmarks page to return to my most recent / currently open thread, the bottom tabs get super squished during that transition. They become roughly twice as tall as they should be, and also moved so the left edge is ~1/3 away from the left side of the screen:

Interestingly, when you are finishing sliding the incoming thread almost all the way onscreen, the left edge of the tab bar ends up perfectly aligned with the left edge of the thread, as both meet the left side of the screen simultaneously.

The bottom tab bar will remain weird as long as you hold your finger on the screen from that point; if you lift your finger and fully return to the Forums or Bookmarks view, the tab bar reverts to normal. It also stays normal when you're swiping back out of a thread (from left edge of the screen) to the Forums/Bookmarks listings. Just swiping from right edge while starting on Forums/Bookmarks causes this graphical glitch.

iOS 13.3, iPhone 8+, portrait mode, Awful v4.0 (latest on App Store). Classic Dark Theme with Dark Mode on.


Also is there any movement towards making it so you can copy a thread title while actively viewing that thread, e.g. long-press on a thread's title bar? (Similar to how you can copy a URL in Safari by long-pressing on the URL bar for the e.g. "Copy | Speak | Paste and Search" buttons?)

Thanks y'all!

Tab bars are the worst. Appreciate the report though, I'm not hopeful for a fix but it drives me nuts when it gets messed up so here's hoping.

No movement yet but I'll +1 it on the list.

stuffed crust punk posted:

While I was on the login screen I did notice the 1password button is black-on-black in dark mode (turned on both in the app and OS)

Whoops. On the list ye go.

beuges posted:

Whatís the likelihood of adding Microsoft Edge as an option for the default browser list?

Nonzero!

abbazabba posted:

Iím seeing weird behavior on YouTube videos- I swear I used to be able to tap on the video and it would open in the app, but now the only way I can get them to play in the YT app is to tap Share, then double-tap the url.

Any ideas?



Ps: THANK YOU for fixing the rotation crashing issue! (At least on my 6s+)

I got nothing, though it breaks for me too sometimes. I try not to futz with embeds because they are painful to work with and change frequently in ways beyond my control. But if it's still busted in a week or two I can add it to the list.

And my pleasure!

Mister Facetious posted:

How do I attach an image for uploading directly if I don't feel like using imgur?

Can't at the moment. But I will +1 it on the list.

Keith Atherton posted:

Since you have platinum long press and choose [img] > From Library and it brings up your photos. I think it goes through imgur but you don't have to deal with the app

Should work regardless of plat, because it goes through Imgur.

Grace Baiting
Jul 20, 2012

Audi famam illius;
Cucurrit quaeque
Tetigit destruens.





Grace Baiting posted:

[Tab bar poo poo]

Also is there any movement towards making it so you can copy a thread title while actively viewing that thread, e.g. long-press on a thread's title bar? (Similar to how you can copy a URL in Safari by long-pressing on the URL bar for the e.g. "Copy | Speak | Paste and Search" buttons?)

Thanks y'all!

pokeyman posted:

Tab bars are the worst. Appreciate the report though, I'm not hopeful for a fix but it drives me nuts when it gets messed up so here's hoping.

No movement yet but I'll +1 it on the list.
Sounds good + good luck! I've also noticed this happens briefly even if you tap a thread from a forums/bookmark view. Hard to see but the bottom tab bar switches to the incorrect sizing during the fraction of the second that the thread view is sliding. And now that I've noticed it once, I can't unsee it!

abbazabba posted:

[YouTube embeds not being clickable]

pokeyman posted:

I got nothing, though it breaks for me too sometimes. I try not to futz with embeds because they are painful to work with and change frequently in ways beyond my control. But if it's still busted in a week or two I can add it to the list.
I've noticed YouTube embed titles not being tappable for a while now actually, like I think several months; the current behavior is that tapping the title does nothing. I normally open embedded YouTubes in the Awful browser, but I currently have to long-press on the video title and pick the "Open in Awful" choice. I imagine this unclickability is the same problem that abbazabba is experiencing with having to manually switch to the YouTube app.

In the reverse direction, I've also noticed I can't long-press on Twitter embeds -- previously, it was possible to long-press on an embedded tweet's timestamp to bring up the sharing menu, then copy the tweet URL right then and there. Currently I have to either quote the post and select the URL to copy it, or tap the timestamp to (note: successfully! Opposite of the YouTube stuff) load the tweet in Awful browser, long-press on the title bar to copy the URL, and then when I paste I need to manually delete the long "&thistweetwasembedded=true&source=somethingawful.com&thispersonisa=goon" kind of extended fragment, which is a tremendous burden.

Help me, pokey man kenobi~~~

Nondevor
Jun 1, 2011





catposting


pokeyman posted:

I haven't paid attention, did this work itself out?

Nah, newbie avatars still show up as the old one on mobile even after clearing my cache a couple times after that - dunno what other app options I could try out to see if itíd affect anything.

heeheex2
Sep 5, 2012

Go Cats

having an only-on-wifi option for embed tweets, show avatars, show images and animate gifs.

Midjack
Dec 24, 2007






Biscuit Hider

Grace Baiting posted:

In the reverse direction, I've also noticed I can't long-press on Twitter embeds -- previously, it was possible to long-press on an embedded tweet's timestamp to bring up the sharing menu, then copy the tweet URL right then and there. Currently I have to either quote the post and select the URL to copy it, or tap the timestamp to (note: successfully! Opposite of the YouTube stuff) load the tweet in Awful browser, long-press on the title bar to copy the URL, and then when I paste I need to manually delete the long "&thistweetwasembedded=true&source=somethingawful.com&thispersonisa=goon" kind of extended fragment, which is a tremendous burden.

Help me, pokey man kenobi~~~

Thatís Twitter datamining for referrals. In Safari hit the share menu at bottom center and copy link from there and itís a clean URL without the referral bit at the end.

Couch Life
Aug 20, 2010



Dicty Bojangles posted:

Ok I figured it out - the issue (on my Xs, anyway) is when you enable "Prefer Cross-Fade Transitions" in Settings > Accessibility > Motion. When that's enabled the Awful app stops working, but when you disable the setting it goes back to working as normal. So I guess cross-fade makes Awful cross-eyed.

THANK YOU!! I've been unable to use the app for so long and this fixed it. You are an angel.

the yeti
Mar 29, 2008

I FUCKING LOVE COCAINE



Cosmetic issue, if you highlight some text and let the context menu appear, scrolling down it just hangs out at the top forever

spanky the dolphin
Sep 3, 2006



Feature request - haptic feedback on buttons and pull to refresh / next page triggers.

MarcusSA
Sep 23, 2007



Grimey Drawer

Iím not sure this would be possible but drat it would be nice to break down the bookmarks by sub forum.

Itís a pain to try and find one sometimes when it gets bumped way down the list.

the yeti
Mar 29, 2008

I FUCKING LOVE COCAINE



Sometimes it seems like the parent forum button doesnít work but goddamn if I can duplicate it

bort
Mar 13, 2003



Oven Wrangler

My back/open menu button disappears from time to time, and I use parent forum to work around it. I go back a page if I canít get it

Ugly In The Morning
Jul 1, 2010

Don't look at me-
I'm ugly in the morning
When the headaches gone
The sun is not.
Forgot to turn the alarm
On - on


Pillbug

Last read markers are loving up somehow, itíll show the right amount of unread posts and send me to the last page instead of only showing unread.

shortspecialbus
Feb 16, 2006

WOULD YOU ACCOMPANY ME ON A BRISK WALK? I WOULD LIKE TO SPEAK WITH YOU!!




My complaint about it randomly shooting back to the top of the page when my finger is slightly overlapping the bezel and touching the edge of the screen seems to be getting worse. It doesn't seem to happen if nothing is touching, but if I'm holding it by the bezel and just bumping the screen, it seems to happen a lot. iPad Pro 11 so it's not a very big bezel and it's easy to accidentally do that.

Diabolik900
Mar 28, 2007



Fun Shoe

Youíre not accidentally touching the scroll indicator, are you? As of iOS 13, you can grab it to scroll quickly, but I find myself doing it accidentally all the time.

carry on then
Jul 10, 2010

donut gravy boat


Yeah,which edge are you touching? If itís the top, I donít think we have any control over that, either

shortspecialbus
Feb 16, 2006

WOULD YOU ACCOMPANY ME ON A BRISK WALK? I WOULD LIKE TO SPEAK WITH YOU!!




Diabolik900 posted:

Youíre not accidentally touching the scroll indicator, are you? As of iOS 13, you can grab it to scroll quickly, but I find myself doing it accidentally all the time.

carry on then posted:

Yeah,which edge are you touching? If itís the top, I donít think we have any control over that, either

Left edge, portrait mode.

the yeti
Mar 29, 2008

I FUCKING LOVE COCAINE



Looking at the announcements, for a while awful was displaying LABís av by lowtaxís name:





Going to lowtaxís profile displayed his actual ability and after that the app seemed to show it correctly on the announcement as well.

Regy Rusty
Apr 26, 2010



Grimey Drawer

Multiple announcements cause things to look weird on the non app version of the forums too, I think that's just the way it is.

Subjunctive
Sep 12, 2006

careful now


Cybernetic Crumb

the yeti posted:

Going to lowtaxís profile displayed his actual ability

I have to admit, Iíve been wondering

the yeti
Mar 29, 2008

I FUCKING LOVE COCAINE



Subjunctive posted:

I have to admit, Iíve been wondering

Lmfao. Ok Iím gonna leave that.

shortspecialbus
Feb 16, 2006

WOULD YOU ACCOMPANY ME ON A BRISK WALK? I WOULD LIKE TO SPEAK WITH YOU!!




I am noticing a thing, not sure when it started, but when I long press a quoted picture to get the full one to pop up, I'm now getting a random amount of text selected in that area. Sometimes the "Cut/Copy/Whatever" dialog box comes up on top of the now-full-size picture. This seems to happen 100% of the time now and I'm pretty sure it didn't used to.

iPad 11 Pro 2018

Is anyone else seeing this or is this something strange on my end? On a related note, I wouldn't mind if I didn't have to long press a quoted photo to make it full size, a single tap would be a lot easier, although it might conflict with photos that link, I dunno.

shortspecialbus
Feb 16, 2006

WOULD YOU ACCOMPANY ME ON A BRISK WALK? I WOULD LIKE TO SPEAK WITH YOU!!




shortspecialbus posted:

My complaint about it randomly shooting back to the top of the page when my finger is slightly overlapping the bezel and touching the edge of the screen seems to be getting worse. It doesn't seem to happen if nothing is touching, but if I'm holding it by the bezel and just bumping the screen, it seems to happen a lot. iPad Pro 11 so it's not a very big bezel and it's easy to accidentally do that.

While my previous post about long pressing an image still is a thing, I just had this scroll to the top in a thread when I am positive my fingers weren't near any edge. I may take this thing to an apple store as it might have some sort of issue. I've only noticed it in Awful, that I can remember, but I don't use other apps that scroll all that often.

Edit: now doing it more frequently and it happened twice in my pinball game where it randomly paused (the pause button is the top of the screen). Definitely hardware, will contact apple. This is not an awful app issue.

Edit 2, on the off chance anyone is interested - I went into draw mode in the notes app, put the iPad Pro in landscape mode, and let it sit a while. I was hoping to get definitive evidence of phantom presses. It worked - There's a small dot where it drew with the phantom presses right on what would be the top edge of the screen in portrait mode. Hopefully Apple will replace it, I think I have applecare on it.

shortspecialbus fucked around with this message at 19:10 on Mar 15, 2020

Zesty
Jan 17, 2012



Tortured By Flan

Adding someone to your ignore list on the app doesnít add them to your ignore list on the browser. Bug or no way around that?

teen witch
Oct 9, 2012




Is there a workaround for when you canít post images and get the API exception error?

my bat mitzvah ROCKED
Mar 13, 2002

We're still wearing the fucking hats!


Somehow I had recently set my browser to something awful instead of safari. I wasnít able to view any links clicked with this setup. I wasnít even able to back out to the app. It just took me to a blank page and forced me to close the app.

101
Oct 15, 2012


Vault Dweller


teen witch posted:

Is there a workaround for when you canít post images and get the API exception error?

https://www.icloud.com/shortcuts/c8...5adb365b5c218e3

Grassy Knowles
Apr 4, 2003

They're karai pantsu, spicy pants.
Which do you want? Pink happy bear or purple kissing bunny?


Subjunctive posted:

I have been crashing a lot on beta, I think related to orientation changes? Iíve sent most of them in, in case thatís helpful.

For imgur, Iíve taken to using the shortcut that has been posted a few times.



You can also make it pull from the clipboard.

Efb

the yeti
Mar 29, 2008

I FUCKING LOVE COCAINE



Zesty posted:

Adding someone to your ignore list on the app doesnít add them to your ignore list on the browser. Bug or no way around that?

Unless something's changed in a recent Awful release, that almost always means someone on your list is now an mod or IK.

If you have a lot of entries you can also max out the db field that stores that data (because naturally they're all concatenated into one field ) -- if that's the case it won't work in the browser either despite no error message coming back

MarcusSA
Sep 23, 2007



Grimey Drawer

teen witch posted:

Is there a workaround for when you canít post images and get the API exception error?

Yeah use that shortcut.

teen witch
Oct 9, 2012




Thanks for the shortcut...how the gently caress do I use it? I feel real stupid haha

MarcusSA
Sep 23, 2007



Grimey Drawer

teen witch posted:

Thanks for the shortcut...how the gently caress do I use it? I feel real stupid haha


https://youtu.be/zXzXF88MNt8

Adbot
ADBOT LOVES YOU

teen witch
Oct 9, 2012




Something is amiss then, as I cannot paste anything? gently caress (but thanks for the vid!)

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply
«73 »