Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
astral
Apr 26, 2004



Peachfart posted:

So with the default forums(no SALR) there is now a way to search smilies by tags, is that a function we could get added to the Quick Reply window?

Yeah, this would definitely be good to have. I'm a fan of the smilie search and the smilie tagging effort going on in QCS.

Adbot
ADBOT LOVES YOU

astral
Apr 26, 2004



There's a race condition with the option that changes the 'you were quoted' highlight color. This has been fixed for the upcoming SALR version.

edit: another race condition is making the advanced posting features from the full reply page attach to quick reply - seems to be happening for me in Firefox, but not Chrome. You get double the keyboard-shortcut-tags!

astral fucked around with this message at 04:05 on Jul 26, 2020

astral
Apr 26, 2004



There was also a race condition with the added-by-javascript "UP" links since the page navigator can load before the "UP" links get added. Fixed for the next SALR version.

e: submitted v2.2.1 for Firefox with these fixes:

quote:

* Thread search box now uses a threadid input instead of adding text into the box on submit
* Fix race conditions potentially breaking userquoted highlighting and "UP" to-top-of-page arrow
* Fix last three pages option breaking when there aren't pages (showpost)
* Updated jQuery to 3.5.1 and jquery-migrate to 3.3.1

e2: 2.2.1 is live for Firefox

astral fucked around with this message at 08:31 on Jul 26, 2020

OgNar
Oct 26, 2002

They tapdance not, neither do they fart

Using Chrome SALR

A few months back the Steam ID thread started always showing as 1 unread no matter how many times I opened it.
Now the Steam gifting thread is doing the same.

Is this a known bug or is something else causing it?

I mean, its a problem I can and have ignored, but still, wondering.

e: poo poo never mind, its not SALR, disabling it and I still get both showing 1 unread, its an SA bug.
I've been using SALR so long I forget what the forums actually do

e2: and i've enjoyed it the whole time.

e3: though the SA ignore list doesnt show anyone, I know I have put people on ignore, I'm going to think that its maybe someone i've ignored posting in those threads.

OgNar fucked around with this message at 07:27 on Aug 1, 2020

astral
Apr 26, 2004



OgNar posted:

Using Chrome SALR

A few months back the Steam ID thread started always showing as 1 unread no matter how many times I opened it.
Now the Steam gifting thread is doing the same.

Is this a known bug or is something else causing it?

I mean, its a problem I can and have ignored, but still, wondering.

e: poo poo never mind, its not SALR, disabling it and I still get both showing 1 unread, its an SA bug.
I've been using SALR so long I forget what the forums actually do

e2: and i've enjoyed it the whole time.

e3: though the SA ignore list doesnt show anyone, I know I have put people on ignore, I'm going to think that its maybe someone i've ignored posting in those threads.

The steam gifting thread has one of those stuck posts; if someone replies to it things should clear up.

Kheldarn
Feb 17, 2011




OgNar posted:

e3: though the SA ignore list doesnt show anyone, I know I have put people on ignore, I'm going to think that its maybe someone i've ignored posting in those threads.

I can say without a doubt that it's not that. I've never had anyone on my ignore list, and I'll still come across threads where that happens. Sometimes a new reply makes it go away, other times, it never goes away. It's just a forums issue.

OgNar
Oct 26, 2002

They tapdance not, neither do they fart

Kheldarn posted:

I can say without a doubt that it's not that. I've never had anyone on my ignore list, and I'll still come across threads where that happens. Sometimes a new reply makes it go away, other times, it never goes away. It's just a forums issue.

I'll just keep ignoring it as I have been then , thanks.

astral
Apr 26, 2004



Hey when you guys see that again could you post about it in QCS? This isnít a Ďstop posting about it in this threadí but I imagine staff seeing when and how often itís happening could help get the underlying issue fixed.

I appreciate when anyone reports weird behavior even if you arenít sure whatís causing it because it frequently is SALR.

Schweinhund
Oct 23, 2004

                                       


I made a site for looking up avatar histories. You can replace the broken SAARS link with this:
https://goons.neocities.org/?av=[avatar URL]&name=[username]

example: https://goons.neocities.org/?av=https://fi.somethingawful.com/safs/titles/76/44/00210240.0011.png&name=Sid Vicious

Inceltown
Aug 6, 2019







Schweinhund posted:

I made a site for looking up avatar histories. You can replace the broken SAARS link with this:
https://goons.neocities.org/?av=[avatar URL]&name=[username]

example: https://goons.neocities.org/?av=https://fi.somethingawful.com/safs/titles/76/44/00210240.0011.png&name=Sid Vicious

lmao, the first one I tried to check was a mods and that didn't work for what is now obvious reasons. Rip to me.

astral
Apr 26, 2004



Schweinhund posted:

I made a site for looking up avatar histories. You can replace the broken SAARS link with this:
https://goons.neocities.org/?av=[avatar URL]&name=[username]

example: https://goons.neocities.org/?av=https://fi.somethingawful.com/safs/titles/76/44/00210240.0011.png&name=Sid Vicious

Awesome, thanks for making a useful tool.

Javid
Oct 21, 2004

My sole partiality is to that delectable spiced meat. Any additional confederation of vegetables shall not compromise the pie as I see it.

tweet embeds are doing a thing that bugs me. I dunno if this is an SALR, chrome, or twitter 'feature', since I only deal with twoot embeds here ever

Example:

https://twitter.com/hunterschwarz/s...897844315824135

if I copy the link to try and share it elswhere, it appends unwanted data to the URL like so
code:
 https://twitter.com/hunterschwarz/status/1293897844315824135?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1293897844315824135%7Ctwgr%5E&ref_url=https%3A%2F%2Fforums.somethingawful.com%2Fnewreply.php
I don't want to include thread links when I copy a twoot to share offsite, and remembering/trimming it every time is obnoxious. Can this be fixed SALR-side?

astral
Apr 26, 2004



SALR has nothing to do with SA's twitter embeds.

Twitter is the one sticking that annoying poo poo at the end.

The forum JS trims it off the end if you want to paste it into another post; SALR's quick reply will get updated to do the same in time.

Neither one will be loving with your clipboard data when you hit copy.

Kheldarn
Feb 17, 2011




Yeah, Twitter is 100% to blame for that bullshit. Just like Google is to blame for appending &hl=en or feature=youtu.be bullshit to the end of links. I've yet to find any way to make it not happen on desktop, so I'd be surprised if there was a way to make it not happen on mobile...

Eh! Frank
Mar 28, 2006

I gave up blow and adderall for you



I can't seem to edit user notes any more, using Firefox. Anybody else having this problem or is it something on my end?

astral
Apr 26, 2004



Eh! Frank posted:

I can't seem to edit user notes any more, using Firefox. Anybody else having this problem or is it something on my end?

Works for me.


What part of it is failing for you?

Beverly Cleavage
Jun 22, 2004

I am a pretty pretty princess, watch me do my pretty princess dance....

Muh button doesn't work!

Chrome bar button just won't load the forums list anymore. I've removed and reinstalled both SALR and the button extension and it just can't repopulate. I feel so lost.

astral
Apr 26, 2004



Beverly Cleavage posted:

Muh button doesn't work!

Chrome bar button just won't load the forums list anymore. I've removed and reinstalled both SALR and the button extension and it just can't repopulate. I feel so lost.

Remove the button extension. It's dead.

Make sure the button from the SALR extension, and not the button from the button extension, is the one showing up in your browser UI.

Megillah Gorilla
Sep 22, 2003

One Potato to rule them all,
One Potato to find them,
One Potato to bring them all
And in the darkness bind them.





Bread Liar

astral posted:

Works for me.


What part of it is failing for you?

Doesn't work for me either.

I can type in a user note and even set a colour in the popup box. But when I hit okay and then refresh the page there's no change. When I open up the note box again, everything I typed in is gone.

But, older notes I've made are still around.


EDIT: I wonder if there's a maximum number of notes you can add? I have a horrible memory for people, so it's always been my habit to make notes both online and off. I may well have maxed it out.

Megillah Gorilla fucked around with this message at 03:47 on Aug 20, 2020

Klyith
Aug 3, 2007

GBS Pledge Week


I just had a settings wipe when updating extensions. SALR updated, but I can't assign blame because multi-account containers and cookie auto-delete both updated and those interact with localstorage.


I have regular backups that include my FF profile. If I wanted to get my old settings back, is there a way to directly extract them or should I just be looking to load the whole profile in FF and do the json export thing?

(Also if you were looking to make work for yourself, some sort of automatic backup option would be cool. For some reason SALR seems very vulnerable to settings wipes, this is the 2nd time I've had it happen.)

astral
Apr 26, 2004



If I recall correctly, the notes are not kept in localStorage but do use the proper storage.local. Pretty much everything else is kept in localStorage, which is bad and sucks and I've wanted to change it for a while but other projects have always taken priority.

astral
Apr 26, 2004



Megillah Gorilla posted:

Doesn't work for me either.

I can type in a user note and even set a colour in the popup box. But when I hit okay and then refresh the page there's no change. When I open up the note box again, everything I typed in is gone.

But, older notes I've made are still around.


EDIT: I wonder if there's a maximum number of notes you can add? I have a horrible memory for people, so it's always been my habit to make notes both online and off. I may well have maxed it out.

Do you have it set to sync notes or not? Do you have a Firefox account?

e: I ask this because synced extension storage can only have 8,192 bytes per item. There is no such limitation for non-synced extension storage.

Megillah Gorilla
Sep 22, 2003

One Potato to rule them all,
One Potato to find them,
One Potato to bring them all
And in the darkness bind them.





Bread Liar

Apparently I do. I clicked "Clear Synced User Notes" and it asked me if I wanted to clear 122 user notes.

How do I un-sync them?

astral
Apr 26, 2004



Megillah Gorilla posted:

Apparently I do. I clicked "Clear Synced User Notes" and it asked me if I wanted to clear 122 user notes.

How do I un-sync them?

I think (Important note: this is not something I have tested recently; proceed with caution before clearing anything!) you can hit 'backup synced user notes locally', then toggle your salr option to use the local notes and not the synced ones. See if your old notes still show up by (re)loading a thread page. See if you can add a new note. If that works, you could clear the synced ones.

astral
Apr 26, 2004



Also if this whole issue was happening to two (or more) people suddenly, and if it isn't just a coincidence, my best guess would be that they changed something on the backend where it was perhaps not enforcing the length limit on a synced item before but now it is.

Megillah Gorilla
Sep 22, 2003

One Potato to rule them all,
One Potato to find them,
One Potato to bring them all
And in the darkness bind them.





Bread Liar

astral posted:

I think (Important note: this is not something I have tested recently; proceed with caution before clearing anything!) you can hit 'backup synced user notes locally', then toggle your salr option to use the local notes and not the synced ones. See if your old notes still show up by (re)loading a thread page. See if you can add a new note. If that works, you could clear the synced ones.

Okay, I did the first part. A popup told me I would lose 7 user notes, which I'm guessing were the last ones I tried making. Thankfully that's no big deal because most of them were me trying to get user notes to work again anyway.

But how do I set it so that salr uses local notes?

These are the options it gives me:




Also, when I go to the extension page, it shows that it's supposed to be allowed to store unlimited amounts of client-side data so I'm guessing you're right that they're finally enforcing the data limits:

astral
Apr 26, 2004



Megillah Gorilla posted:

But how do I set it so that salr uses local notes?

Under thread options:


quote:

Also, when I go to the extension page, it shows that it's supposed to be allowed to store unlimited amounts of client-side data so I'm guessing you're right that they're finally enforcing the data limits:

That's just a permission for the local extension storage (client-side data). I had the extension request that as a precautionary measure in case people needed that much data (limit would've been ~5 megabytes otherwise, which is still much larger than the 8KB of notes you would have with synced storage). I have absolutely no idea what kind of performance impact having that much data would have, but I'm sure it's very exciting.

If we're talking wishlist items, one way to work around the sync storage quota in the future might be to split the notes into 10 or more buckets based on the last userid digit(s) or something.

Eh! Frank
Mar 28, 2006

I gave up blow and adderall for you




Un-checking sync storage seems to have fixed it for me. Thanks for the help!

astral
Apr 26, 2004



Eh! Frank posted:

Un-checking sync storage seems to have fixed it for me. Thanks for the help!

Youíre welcome! Hopefully you also hit the button to backup synced notes locally so you would keep your previous notes!

Klyith
Aug 3, 2007

GBS Pledge Week


astral posted:

Under thread options:


So on firefox the sync user note is using a firefox/mozilla account and their sync service right? Weirdly it says I have 8 user notes in sync. I don't have a firefox account and have never used sync.

astral
Apr 26, 2004



Klyith posted:

So on firefox the sync user note is using a firefox/mozilla account and their sync service right? Weirdly it says I have 8 user notes in sync. I don't have a firefox account and have never used sync.

If you don't have a Firefox account, it basically becomes a (different, I believe, and possibly/probably subject to those same limitations as if it really were syncing) local extension storage.

Megillah Gorilla
Sep 22, 2003

One Potato to rule them all,
One Potato to find them,
One Potato to bring them all
And in the darkness bind them.





Bread Liar

astral posted:

Under thread options:

I actually saw that option multiple times before I posted.

I just never read the second line

All seems to be working now. Thanks.

Nova69
Jul 12, 2012



(Firefox) I've been having issues with the "expand breadcrumbs" feature recently, on page load it will briefly show the expanded version of the breadcrumbs, but after a second it reverts back to the unexpanded version

astral
Apr 26, 2004



It showing up as briefly expanded before collapsing is "Normal Forums Behavior", for reference. I put that in quotes because it really shouldn't do that but the CSS for the forums is so badly laid out and there are layers upon layers of hacks and tweaks and a gigantic css file for it to process each time including a bunch of non-essential stuff and yuck.

I looked into this and it's apparently a race condition between the forums JS that manipulates the breadcrumbs into the more modern design and the SALR JS that tries to revert it. The forums shouldn't be doing this via javascript, so I think the fix will be making the forums not do this via javascript.

El_Elegante
Jul 3, 2004
Probation
Can't post for 6 days!


Biscuit Hider

is it possible to have SALR adjust the size of post/reply text?

astral
Apr 26, 2004



El_Elegante posted:

is it possible to have SALR adjust the size of post/reply text?

Sounds like you want the Stylus extension and a user stylesheet.

Beverly Cleavage
Jun 22, 2004

I am a pretty pretty princess, watch me do my pretty princess dance....

astral posted:

Remove the button extension. It's dead.

Make sure the button from the SALR extension, and not the button from the button extension, is the one showing up in your browser UI.

Thanks! it's what happens when you set and forget a lot of this stuff.

Probably worth mentioning in OP that button is dead.

nexus6
Sep 2, 2011

If only you could see what I've seen with your eyes

Javid posted:

tweet embeds are doing a thing that bugs me. I dunno if this is an SALR, chrome, or twitter 'feature', since I only deal with twoot embeds here ever

Example:

https://twitter.com/hunterschwarz/s...897844315824135

if I copy the link to try and share it elswhere, it appends unwanted data to the URL like so
code:
 [url]https://twitter.com/hunterschwarz/status/1293897844315824135?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1293897844315824135%7Ctwgr%5E&ref_url=https%3A%2F%2Fforums.somethingawful.com%2Fnewreply.php[/url]
I don't want to include thread links when I copy a twoot to share offsite, and remembering/trimming it every time is obnoxious. Can this be fixed SALR-side?

What I usually do is this:
  • Click the embedded twit to open the twatter page in a new tab
  • On the twooter page, click the twet again. This reloads the page with all the ?threadid query param guff removed. Then I share that link to the twuut

Example: clicking that one once opens
code:
https://twitter.com/hunterschwarz/status/1293897844315824135?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1293897844315824135%7Ctwgr%5E&ref_url=https%3A%2F%2Fforums.somethingawful.com%2Fshowthread.php%3Fthreadid%3D3845597pagenumber%3D13lastpost
but clicking it again on twooter loads up
code:
https://twitter.com/hunterschwarz/status/1293897844315824135

nexus6 fucked around with this message at 20:51 on Aug 22, 2020

Inceltown
Aug 6, 2019








This is what I do too but it's also prime for one of those "there has to be a better way" commercials.

Adbot
ADBOT LOVES YOU

astral
Apr 26, 2004



Inceltown posted:

This is what I do too but it's also prime for one of those "there has to be a better way" commercials.

astral posted:

The forum JS trims it off the end if you want to paste it into another post; SALR's quick reply will get updated to do the same in time.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply