Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
iospace
Jan 19, 2038




I think this got eaten by the last thread, but when I sent r to do a quick reply, it seems to ignore the command.

Also ctrl+1 gets overridden by SALR, is there any way to restore default functionality?

Adbot
ADBOT LOVES YOU

iospace
Jan 19, 2038




Alright, to expand on the Ctrl+1 behavior. It will switch to the first tab as it should, but it will go to the top post on the page.

iospace
Jan 19, 2038




astral posted:

If that's missing I'll look into how easy it'd be to add; that was one of my favorite features of legacy SALR.

Hiding stupid newbie is an option, but I didn't see the option for an individual avatar button in the options.

iospace
Jan 19, 2038




My r button works again! How I've missed you!

Thanks for the work, astral

iospace
Jan 19, 2038




Found a live preview bug:


When submitted, it will actually show up as , not

iospace
Jan 19, 2038




Three bugs to report:

When hitting the "go to last read" button while "Last post button reloads the current thread to check for new posts instead of scrolling to an unread post" is checked on the first page of a thread, it will only reload the first page instead of going to the first new post. This behavior only seems to happen on the first page.

Secondly, hitting a tag in the list will not put it under the cursor, but instead at the end of the message. This behavior only happens when text isn't highlighted (when text is highlighted, it works as one would expect, putting the tags around the highlighted text).

e: another bug found, or well, annoyance, timg tagged images show up stupidly tiny in the preview.

e2: the first bug only shows up when "&pagenumber=" is not in the URL. If you click directly on the page 1 link it will work, but if you click on the thread title it will not.

iospace fucked around with this message at 15:43 on Jan 22, 2018

iospace
Jan 19, 2038




Found yet another pair of bugs:

ctrl+q, which used to be the shortcut for inserting quote tags is not working

"blank" quote tags, as in ones that are simply (quote)(/quote), without any link to a post or poster, do not get parsed in the live preview, even if there are words between the tags themselves.

e:

iospace fucked around with this message at 17:11 on Jan 24, 2018

iospace
Jan 19, 2038




Bug and suggestion for the Imgur uploader:

Bug:
When clicking on the "drag an image here" text, it opens up a file picker window. Selecting a file does nothing, nor does dragging the image from that window. If you drag it from a explorer.exe window, it works.

Suggestion:
Checkbox for "insert as timg", so that when the upload finishes, it uses timg tags instead if img tags.

iospace
Jan 19, 2038




One of the threads I follow in PYF requires all images to be timg, which is where I was thinking it was useful.

iospace
Jan 19, 2038




Yet another bug report:

While the the "insert tag under the cursor" part got fixed, when the tags are inserted, the cursor goes to the end of the closing tag, instead of the middle of the tags.

iospace
Jan 19, 2038




To do you a favor, I'll be probating myself tonight and reporting on how SALR handles it.

I know the old version threw an generic error when that was the case.

iospace
Jan 19, 2038




Alright, sounds good.

I may or may not have been looking for a reason to bump the thread and avoid archives

iospace
Jan 19, 2038




Alright, a bug report and a feature request:

Feature:
Right now, imgur uploader sticks the image at the end of the post, not under cursor. Could this be changed to be under cursor please?

Bug:
<Text vanishes when prefaced with a left angle bracket.

iospace
Jan 19, 2038




Teddybear posted:

Hm. Trying to post in the D&D Trump thread (https://forums.somethingawful.com/s...hreadid=3851537) using Quick Reply fails, giving an error message that it was a bad/invalid request and a reminder that third-party posting (like Awful App or SALR) isn't officially supported. Other threads seem to work fine, including this one, if this post goes through.

On the first failed attempt, resubmit it. ZDR is aware of the bug and currently has bigger fish to fry (read: real world priorities).

iospace
Jan 19, 2038




Teddybear posted:

Oh, ok. Is it on the forums side, then, and not on the app? And by 'resubmit' do you mean go back and redo the post, or refresh the page, or...

Redo the post, and yeah, it's forum-side.

iospace
Jan 19, 2038




I just copy and pasted an imgur url, and it pasted it as [Imgur](https://i.imgur.com/<>.jpg)

Is this intended behavior?

iospace
Jan 19, 2038




astral posted:

No. What was the URL, and is it reproducible?

It's reproducible...

but it's because io hit the wrong "copy" button from the imgur page

My bad.

iospace
Jan 19, 2038




hannibal posted:

Is Twitter embeds something this extension does or the forums? I was trying to figure out why they weren't embedding for me, but I didn't see anything in SALR's settings.

Forums.

iospace
Jan 19, 2038




Stare-Out posted:

Sorry if this has been asked before, but is the issue with threads scrolling out of whack after loading due to tweets being posted on the page a SALR issue or a forums issue? Either way, it sucks pretty bad when you click on a thread and have it load to the first new post only to have it sling all the way up because a bunch of tweets were linked.

Forums

iospace
Jan 19, 2038




Stare-Out posted:

Ok. It sucks and since it's the forums, it definitely should be fixed somehow.

E: I don't know anything about coding but couldn't the tweets be set to have priority in the load order when opening a thread or something so they load first then the rest of the page?

Radium.

Seriously, you don't want to poke the code.

iospace
Jan 19, 2038




Does anyone remember the original hex color codes for the UserCP view? Thanks.

Adbot
ADBOT LOVES YOU

iospace
Jan 19, 2038




He's a dev more than super mod. The mod position is mostly so he has more space access for testing.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply