Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
JBark
Jun 27, 2000
Good passwords are a good idea.
Something in one of the more recent Windows 10 Feature Updates (1709 maybe?) started causing issues with high CPU usage and DisplayLink adapters. I think it broke the ability for DisplayLink to offload the graphics stuff to the GPU. You can see the CPU problems mentioned quite a bit on their forums:
https://www.displaylink.org/forum/

They've had various releases of the software that supposedly help, but I've noticed no difference. On my HP 1040 G4 with an i7, WMI Provider Host spends most of the day above 20% GPU usage, and pegs even higher if I'm doing something like watching a YouTube video. Anything graphically intensive gets quite choppy. It's pretty annoying, especially since it means the laptop fan is always running. Disconnect the dock and performance is fine and it's silent.

My plan is the same as your IT dept, go with TB docks only in the future. Luckily only one other person has a USB-C dock where I work, and he doesn't do enough on his laptop to notice the issues.

Adbot
ADBOT LOVES YOU

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply