Register a SA Forums Account here!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us $3,400 per month for bandwidth bills alone, and since we don't believe in shoving popup ads to our registered users, we try to make the money back through forum registrations.
  • Post
  • Reply
Oysters Autobio
Mar 13, 2017

Problem description:

The last few days I've noticed lots of lags and disconnects from online gaming, and when I checked my speedtest I saw that I was getting an average of 50-60mbps when my plan is set to 250mbps. My PC is connected to a CAT6 ethernet cable (and I tested the cable on another laptop and it was fine, see below) to our router. I then went ahead and decided just to factory reset both my modem and my router.

I called up my ISP thinking it was on their end, and after remoting in and after running through a bunch of tests in CMD prompt he said everything seemed to be working fine. So, we tried directly connecting the PC to my modem, and my speeds jumped up to 120-150mbps, but still far below the speeds its supposed to be. Finally, we used the same connection and ran it to a separate laptop and could see that I was then getting normal speeds of 250mpbs, which seems to confirm its not the ISP and instead my PC.

I went into Device Manager and selected Network Adapters and checked for newer drivers and Windows couldn't find any. Every Google description walks through the common problems like WiFi issues, ISP issues etc. but given that I get full speeds when connected to my laptop I believe we can rule out most of those other issues.

Recent changes: I built this PC back in April but am not sure when it was this slow, though I did have quite a few stutters and disconnects as well early on (stupidly never thought to check the speed though)


Operating system: Windows 10 Home 64bit

System specs::

CPU: Ryzen 5 2600
Mobo: ASRock B450 Pro4
RAM: Team T-FORCE VULCAN Z 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3000 (PC4 24000) ,
GPU: ASUS GeForce GTX 1660 Super Phoenix OC - 6GB GDDR6
Network Adapter (built into mobo): Realtek PCIe GbE Family Controller

Modem: TP-LINK TC7650
Router: TP-LINK AC1200 Archer C50
Cable: CAT6 ethernet

also here's screenshots of my CPU-Z output:

Location: Canada

I have Googled and read the FAQ: Yes (see above for the steps I've taken from what I found).


Oysters Autobio
Mar 13, 2017

DeepBlue posted:

Update your drivers using the program below:

Ping the following IP addresses to test out what part of your network is causing issues. This will need to be running in the background to provide any troubleshooting benefits, so keep an eye on it and try to recreate the issue when running this test.

Your Router - Usually 192.168.x.y
Your Gateway - Check your IP address using
Your DNS provider - I usually hit up Google's DNS at

Let us know how that goes.

I'll definitely go through and check drivers, which ones do you think are applicable other than the Ethernet adapter? I'm a bit wary of driver software so I'd rather just do it manually, and I've heard Snappy particularly is loaded with adware and other bloat.

Ping results:


Packets: Sent = 30, Received = 30, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

Packets: Sent = 30, Received = 30, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms
Google DNS:

Packets: Sent = 30, Received = 30, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 21ms, Maximum = 31ms, Average = 23ms

Oysters Autobio
Mar 13, 2017

astral posted:

Go to your network settings, hit 'Change Adapter Options', take a screenshot of that window. From that window, next right-click the Ethernet connection, select status, and take a screenshot of that one too.

Here's the first:

And here's the second:

Interestingly the speed is showing as 100mpbs, so I wonder if its being throttled or limited somehow?

EDIT: I went onto the Realtek website and downloaded the latest driver (Windows didn't detect it on its driver update tool), but still the speed is only showing as 100mpbs on the connection itself. More googling shows that sometimes these adapters are only working in Half-Duplex mode which limits its speed to 100mpbs, could this be the case? How could I modify this to Full Duplex mode?

EDIT 2: So I went into Change Adapter Options and found the Link Speed & Duplex option and changed it from auto negotiation to Full Duplex 1gbps, unfortunately this didn't seem to do anything to the speed (if anything, my speed may have gone down to around 40mpbs from 90, but I'm not certain). I also checked and saw that "Autodisable Gigabit" was Disabled to make sure.

Next, I went and saw that "Gigabit Lite" was enabled, and googling showed apparently its a 500mpbs option, so I disabled it and ran another speedtest. Same speeds unfortunately. Finally, I tried both Gigabit Lite disabled and changed from Auto Negotiation to Full Duplex and it seemed to up my speed back in the 90-100mpbs range, but nowhere near the 250mpbs I'm supposed to be getting (and this could be completely unrelated because I normally get 90-100mpbs and only the last few minutes was getting 40mpbs). I'm going to leave these settings this way to see if anything changes for now but still no luck.

Honestly, I might just buy another PCIe adapter even if it costs me $50 but I don't want to buy one if I can't absolutely be certain its the current adapter throttling the speed.

Oysters Autobio fucked around with this message at 12:43 on Aug 14, 2020

Oysters Autobio
Mar 13, 2017

Zogo posted:

The Archer C50 has four fast ethernet ports which max out at 100Mbps.

You've gotta be kidding me, I knew it would be something stupid like this. The router has faster speeds on WiFi than it does on ethernet???? What? Why? So I guess a new router is what's needed here, or can I use a switch to connect both the router and a direct ethernet?

The only thing still odd is that I connected the ethernet straight from the modem as well and still got slow speeds, but when I did the same on my laptop I got my maximum 300mpbs.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply