Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
The Pirate Captain
Jun 6, 2006

Avast ye lubbers, lest ye be scuppered!

Problem description: I'm running Windows 10 to a Denon AVR to a Samsung TV, everything connected with HDMI 2.1 cables. I have it set up to run at 4k120. In Windows via the display settings switch I am unable to turn on the HDR setting - it slides, the TV goes dark for a split second like it's trying to enable it, then it comes back with the switch sliding back to the "off" setting and HDR not enabled. The weird thing though is that some games work just fine at high res/high frame rate/HDR. For example, Mortal Kombat 11 pops up right in HDR every time I launch it and looks beautiful. I think Resident Evil 2 also works fine, and a handful of other games as well. But in other games like CyberPunk or any Assassins Creed game, the option is greyed out as though my device doesn't support it, and of course I am unable to enable it directly in Windows device setting.

Short version: Some games work fine in HDR, others don't and Windows won't turn it on.

Attempted fixes: I have tried a little bit of everything. Updating drivers, changing cables, lowering resolution and frame rate. I connected the cables from the TV directly to the PC bypassing the DVR,I have messed with related settings on the TV, in Windows, and on the DVR to no success. I did quite a bit of googling and it looks like a lot of people have the same problem with the windows HDR switch setting turning off as soon as it turns on but have not found anyone else with the same problem where it works in some games but not others in quite the same way I'm having. I have tried all the solutions in those similar cases, including some of the above items, manually adding a registry key to enable HDR streaming, but nothing works. The most success I've had is that if I run Assassins Creed Valhalla in windowed mode, I can get HDR that way, but I still can't enable it directly in Windows and that doesn't work with Cyberpunk. And even then, when I exit AC the rest of Windows looks horrible/colors are way off, and doesn't look right until I restart the entire machine. I even tried unseating and reseating the RAM, CPU, and graphics card.

Recent changes: It got worse after I got my latest video card, an RTX 3090, but the issue kind of came and went with the 1080 Ti SLI rig I had going before that.

--

Operating system:
Windows 10 Home x64

System specs:
ASUS ROG Maximus X Hero
Intel Core -7-8700K (not overclocked)
32 GB G.SKILL TridentZ RGB
RTX 3090
Samsung 860 EVO 1TB SATA III SSD (2x)
Samsung 970 EVO Plus 1TB NVMe
Samsung OLED GX
Denon


Location: USA

I have Googled and read the FAQ: Yes

Adbot
ADBOT LOVES YOU

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply