Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
Dungeon Ecology
Feb 8, 2011



Hey all,

I'm at my wits end here trying to get my earbuds to work on my desktop PC. Here are the details:

OS: Windows 10 Home x64 v. 20H2
Processor: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
RAM: 16GB
Earbuds: Raycon E25 Pro
Mobo doesn't have onboard Bluetooth so I purchased a USB WiFi Adapter: TP-Link UB400

Issue:
Earbuds do connect successfully via Bluetooth, but the sound quality is very tinny. After some research I determined that the issue stemmed from the 'handsfree profile' that is created when the bluetooth device connects. When the earbuds are connected, Windows recognizes two different playback devices associated with the earbuds: Bluetooth Audio Renderer (Bluetooth Stereo) and Bluetooth Hands-free Audio (Bluetooth Hands-free Audio Device). The hands-free audio device option correlates with tinny, bad-quality sound with high latency and sound dropping issues. The Bluetooth Audio Renderer option never gives any sound. When playback is tested in sound settings for the Renderer option, the sound bar indicates something is being played, but there is no sound from the earbuds.
There has been no sound or quality issue connecting the earbuds to my mobile phone.

Attempted fixes:
- Unpair and repair the headphones (many times)
- Uninstall and reinstall the TP-Link drivers (several times)
- Update Windows 10 sound drivers
- Fully charge the earbuds
- Disable the Hands-free profile via the Bluetooth settings (this eliminates the Bluetooth Hands-free Audio option, but does not fix the 'no sound' issue).
- Disable the Bluetooth Hands-free Audio option in the Control Panel > Hardware and Sound > Sound > Playback
- Disable the Bluetooth Audio Input Device in Control Panel > Hardware and Sound > Sound > Recording

Thoughts: I initially thought this was an issue with Hands-free telephony, but now I'm not so sure. I've successfully prevented the system from automatically connecting to Hands-free telephony, but I'm still getting no sound. What's even stranger is that once, during the unpairing and repairing, I was able to get the headphones to play sound successfully and in high quality when the pairing process somehow timed out mid-pairing. The device never showed up in the Bluetooth Devices (no profiles were created), but the Bluetooth Audio Renderer option was available in Windows and worked! I had it working all day today before I unpaired to do some yard work and repaired again this evening...

Any of you folks have thoughts on what I might troubleshoot next? Thanks all!

Adbot
ADBOT LOVES YOU

Dungeon Ecology
Feb 8, 2011



SOLVED: :doh: the audio driver for onboard sound has a companion app that was superceding the sounds settings in Windows. I was able to configure the sound settings correctly in the app and the earbuds work with the stereo setting.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply