Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
Hakarne
Jul 23, 2007
Vivo en el autobús!


Problem description: I am trying to set up the integrated Remote Desktop Connection (RDC) app to run a /shadow session on my kid's computer (to make sure he is actually doing schoolwork when we leave the room, because he doesn't). I am able to successfully connect using my windows admin account on both computers through RDC, but this forces off the current user which defeats the purpose. I used information from here http://woshub.com/rdp-session-shadow-to-windows-10-user/ to try to enable shadowing sessions. I run the command as "Mstsc /shadow: <session ID> /v:<Computer name>" and it returns an "Access Denied" error. If I run that same command line without "/shadow" it will work fine, but again that just boots off the current user. I also receive the same error when I try to run a qwinsta command to find the session IDs on the remote computer, so I've been pulling the session ID manually from the other computer. My kid uses a local account on the PC.

Attempted fixes: I changed the Group Policy as mentioned in the article, trying "Full Control Without User's Permission" and "View Session without user's Permission." I tried editing registry parameters at HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server by changing "AllowRemoteRPC" to 1, 2, or 4 in order to match the settings for session control. I still get the same error.

Recent changes: N/A

--

Operating system: Windows 10 Pro (both PCs)

System specs: PC 1: Custom Desktop PC connected via Ethernet cable to a T-Mobile Cellspot Router. PC2 (kid's PC): Gigabyte Laptop connected via Wi-Fi to the same router. I don't think any other specs would be relevant to the problem but if I'm wrong I'll provide more details.

Location: USA

I have Googled and read the FAQ: Oh God yes

Adbot
ADBOT LOVES YOU

Scruffpuff
Dec 23, 2015

Fidelity. Wait, was I'm working on again?

If the person you're trying to shadow has multiple monitors, this is one of the error's you'll get. It might be worth keeping yourself from pulling your hair out to just get a third-party solution. The built-in MS tools for shadowing require too many planets to align to be of much use.

Hakarne
Jul 23, 2007
Vivo en el autobús!


Scruffpuff posted:

If the person you're trying to shadow has multiple monitors, this is one of the error's you'll get. It might be worth keeping yourself from pulling your hair out to just get a third-party solution. The built-in MS tools for shadowing require too many planets to align to be of much use.

Thanks for the reply. I have two monitors but the user I’m shadowing only has one. I’m fine with throwing in the towel on it - do you know of any good 3rd party apps that would work for keeping an eye on a PC user? Preferably something with a phone app, that’d make it easiest.

Scruffpuff
Dec 23, 2015

Fidelity. Wait, was I'm working on again?

Hakarne posted:

Thanks for the reply. I have two monitors but the user I’m shadowing only has one. I’m fine with throwing in the towel on it - do you know of any good 3rd party apps that would work for keeping an eye on a PC user? Preferably something with a phone app, that’d make it easiest.

If the target PC only has one monitor then first try setting your remote desktop connection Display tab and uncheck "use all my monitors for the remote connection"

AeroAdmin is one of many similar apps for just the purpose you've described. It's free for home use.

Scruffpuff fucked around with this message at 04:48 on Jan 22, 2021

Hakarne
Jul 23, 2007
Vivo en el autobús!


Scruffpuff posted:

If the target PC only has one monitor then first try setting your remote desktop connection Display tab and uncheck "use all my monitors for the remote connection"

AeroAdmin is one of many similar apps for just the purpose you've described. It's free for home use.

AeroAdmin is working perfectly and saved me a lot of headache. Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply